My steering pulls to the left! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 09-28-2008, 07:25 AM   #1
Newb
Thread Starter
 
Join Date: May 2008
Location: Northern Ireland
Posts: 29
Total Cats: 0
Default My steering pulls to the left!

I have an Eunos and ever since I got it the steering pulls slightly to the left. I have had the wheel alignment done and it did not cure the problem. I know the drivers side has recieved a new wing as it had a slight bump before I bought it. Is there anything to look out for or should I just replace the whole strut?
colinp is offline   Reply With Quote
Old 09-28-2008, 08:40 AM   #2
Junior Member
iTrader: (1)
 
Join Date: Jul 2007
Location: Johannesburg, South Africa
Posts: 109
Total Cats: 0
Default

did the alignment shop give you a print out of the "before" and "after" ?
post up this if you have it
have you checked tyre pressures ?
swapped tyres from left to right ?
does it always pull left ? or is it dependent on road suface / camber ?
does it pull left in the wet ?
how far left does it pull ? a slight wander or a lane change ? if you let the steering wheel "go"
3barboost is offline   Reply With Quote
Old 09-28-2008, 09:10 AM   #3
Elite Member
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

maybe a sticking caliper?
paul is offline   Reply With Quote
Old 09-28-2008, 10:08 AM   #4
Elite Member
iTrader: (12)
 
Join Date: Apr 2008
Location: Longs, SC
Posts: 2,583
Total Cats: 13
Default

tire pressure?
icantthink4155 is offline   Reply With Quote
Old 09-28-2008, 11:38 AM   #5
Junior Member
iTrader: (3)
 
Join Date: Nov 2007
Location: Boston / '90 Mariner Blue
Posts: 310
Total Cats: 14
Default

Quote:
Originally Posted by icantthink4155 View Post
tire pressure?
Are the tires new?
alik is offline   Reply With Quote
Old 09-28-2008, 11:48 AM   #6
Newb
Thread Starter
 
Join Date: May 2008
Location: Northern Ireland
Posts: 29
Total Cats: 0
Default

car has original tyres on from I bought it, doesn't seem to matter what pressure I put in them it still pulls regardless of the road or weather conditions! If I let wheel go it will change lanes in a matter of seconds. I havn't changed tires from side to side and the guy who done the alignment didn't give any printouts.
colinp is offline   Reply With Quote
Old 09-29-2008, 02:59 AM   #7
Senior Member
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

It could be a bad tire. It's fairly common for a tire to cause the car to pull and not make any noise or vibrations. Cross your two front tires, if it pulls to the right one of your tires is bad. You then will have to rotate them one at a time to the rear to figure out exactly which one is bad.
miataspeed1point6 is offline   Reply With Quote
Old 09-29-2008, 03:09 AM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

Quote:
Originally Posted by colinp View Post
the guy who done the alignment didn't give any printouts.

so for all you know he didnt touch the car and you still paid for a service.
Braineack is offline   Reply With Quote
Old 09-29-2008, 05:50 AM   #9
Newb
Thread Starter
 
Join Date: May 2008
Location: Northern Ireland
Posts: 29
Total Cats: 0
Default

I watched the guy do the alignment and he has done different cars in the past so I know hes ok. I will switch tyres to see if that helps. Thanks for the advice!
colinp is offline   Reply With Quote
Old 10-09-2008, 02:28 PM   #10
Newb
Thread Starter
 
Join Date: May 2008
Location: Northern Ireland
Posts: 29
Total Cats: 0
Default I got a laser wheel alignment done with print out!

I got this done today but the car is still pulling. Tyres look good with no uneven wear. Check out the red bit on the final values. Could this be my problem? I didn't get to read this untill I had left the tyre depot
Attached Thumbnails
My steering pulls to the left!-mx5-wheels.jpg  
colinp is offline   Reply With Quote
Old 10-09-2008, 02:30 PM   #11
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

that's the caster...odd they don't match...odd the numbers on the left they were able to achieve....ever hit a curb?
Braineack is offline   Reply With Quote
Old 10-09-2008, 02:32 PM   #12
Newb
Thread Starter
 
Join Date: May 2008
Location: Northern Ireland
Posts: 29
Total Cats: 0
Default

It's been pulling since I bought it. What should I change to rectify it?
colinp is offline   Reply With Quote
Old 10-09-2008, 03:25 PM   #13
Junior Member
 
Join Date: Sep 2008
Location: Tulsa, Oklahoma
Posts: 350
Total Cats: -1
Default

Steer to the right.
944obscene is offline   Reply With Quote
Old 10-09-2008, 08:10 PM   #14
I'm Miserable!
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

that guy SUCKS at alignments. but your caster is prob causing the problem
bryantaylor is offline   Reply With Quote
Old 10-10-2008, 02:02 AM   #15
Junior Member
iTrader: (1)
 
Join Date: Jul 2007
Location: Johannesburg, South Africa
Posts: 109
Total Cats: 0
Default

go to a different alignment shop ?

and at the next one
sit in the car or have the car ballasted to your weight by sandbagging on the drivers seat - if you sit in the car SIT STILL
insisist that the castor is equalled - unless theres mchanical damage preventing it
3barboost is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:52 PM.