No spark, No CEL illimination, just cranks. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 08-03-2013, 12:00 AM   #1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Posts: 86
Total Cats: -28
Default No spark, No CEL illimination, just cranks.

'99 10AE 142k-

Came off the freeway and parked it. Went into the shop and built a couple of firearms, came out and hour and a half later to leave and it won't start. It just cranks.

With the key on the CEL should illuminate and it's not. The code reader is 'unable to establish link'.. I'm getting no spark. I pulled the main relay with the key on and as soon as I started putting it back in it fired(clicked), so I don't think it's the main relay. All fuses under the dash and in the main relay box look good.

I tried resetting the ECU and there is no change.


Any ideas?

Thanks in advance.
Wastemore is offline   Reply With Quote
Old 08-03-2013, 03:41 AM   #2
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,441
Total Cats: 198
Default

The fact that it clicked doesn't mean that the contacts are good/not internally broken. Try jumping the relay socket pins.
Reverant is offline   Reply With Quote
Old 08-03-2013, 10:29 AM   #3
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Posts: 86
Total Cats: -28
Default

How would I do that?

and thanks.
Wastemore is offline   Reply With Quote
Old 08-04-2013, 12:25 AM   #4
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: May 2011
Posts: 86
Total Cats: -28
Default

Bad ECM. Shucks.
Wastemore is offline   Reply With Quote
Old 08-04-2013, 02:03 AM   #5
Junior Member
iTrader: (1)
 
Join Date: Jan 2012
Location: San Jose, CA
Posts: 144
Total Cats: -3
Default

Quote:
Originally Posted by Wastemore View Post
Bad ECM. Shucks.
How did you conclude this?
HardHitter is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
01-05 Fab9 PNP COPs (used) FrankB Miata parts for sale/trade 6 09-30-2015 12:48 PM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM
First to get it out of the way main Meet and Greet 2 09-05-2015 02:03 PM
First to get it out of the way main Meet and Greet 1 09-05-2015 01:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:27 PM.