Noisy Fuel Pump - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 02-18-2007, 04:04 AM   #1
Junior Member
Thread Starter
iTrader: (3)
 
timhill78's Avatar
 
Join Date: Aug 2006
Location: Oregon
Posts: 241
Total Cats: 0
Default Noisy Fuel Pump

so today in after some traffic while i was parking i turned off the radio and noticed that what sounds like my fuel pump was louder than normal. when i came back about an hour latter it was still loud. It stopped after about an hour of driving . When it was the making noise i could turn the key part way so the pump would run but it wouldn't make the louder noise. It only was loud when running. Well it stopped so I guess that's that's but it just made me a little concered. Any ideas.
timhill78 is offline   Reply With Quote
Old 02-18-2007, 04:09 AM   #2
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

your afm shouldn't let the fp run with out being opened. is it a wlaboro they tend to get noisy?
magnamx-5 is offline   Reply With Quote
Old 02-18-2007, 04:15 AM   #3
Junior Member
Thread Starter
iTrader: (3)
 
timhill78's Avatar
 
Join Date: Aug 2006
Location: Oregon
Posts: 241
Total Cats: 0
Default

yeah it's a 255hp but it's never been that loud
timhill78 is offline   Reply With Quote
Old 02-18-2007, 04:23 AM   #4
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

i dunno mine is loud do you have the fuel cut on the afm disabled. how is your pressure?
magnamx-5 is offline   Reply With Quote
Old 02-18-2007, 04:27 AM   #5
Junior Member
Thread Starter
iTrader: (3)
 
timhill78's Avatar
 
Join Date: Aug 2006
Location: Oregon
Posts: 241
Total Cats: 0
Default

that's another thing. I just put in a fuel pressure guage that other day and i was reading 50 psi. But today i checked the guage and its all skrewy. It reads 80 psi off and all the way when running. I think thats because it oly went to 100 psi so i probaly messed it up when I was in boost 110 psi. Does anyone know where to get a higher gauge?
timhill78 is offline   Reply With Quote
Old 02-18-2007, 04:33 AM   #6
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

Parker or another hydralic store should have them fittings would be Fastenal. Maybe the pump is fucked up to the point where it is restricing your fuel flow this would account for more noise at the pumps new work laod.
magnamx-5 is offline   Reply With Quote
Old 02-21-2007, 02:05 AM   #7
Junior Member
Thread Starter
iTrader: (3)
 
timhill78's Avatar
 
Join Date: Aug 2006
Location: Oregon
Posts: 241
Total Cats: 0
Default

Been a few days and it hasn't come back. Any ideas what made it do that.

Last edited by timhill78; 02-21-2007 at 02:21 AM.
timhill78 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:29 AM.