stock oil pressure gauge? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 10-17-2010, 04:22 PM   #1
Senior Member
Thread Starter
iTrader: (6)
 
Join Date: May 2009
Location: San Francisco
Posts: 989
Total Cats: 23
Default stock oil pressure gauge?

what is the oil pressure gauge in my 95 supposed to do? i thought from posts i've seen on here that it should move according with rpms, but since ive gotten the car, the oil pressure gauge has slowly but surely just gone up, it used to just be stuck right about at the middle of the gauge, and now it looks like this.



my guess is that its clogged? where is the sender unit at? any other tips or is it working ok. car runs just dandy, no oil trouble except piston 4 valve tick when the oil gets too old.

thanks
wittyworks is offline   Reply With Quote
Old 10-17-2010, 05:20 PM   #2
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,106
Total Cats: 518
Default

You have an idiot light with a needle instead of a bulb, where as '90-'94 Miatas had an actual gauge.

Buy the sender and gauge from a '90-'94 and replace your current gauge and sender. The sender is on the passenger side of the engine, below the intake manifold, behind (towards the rear) of the oil filter.

http://www.miata.net/garage/opg.html
curly is offline   Reply With Quote
Old 10-17-2010, 08:35 PM   #3
Want fries with that?
iTrader: (3)
 
Join Date: Oct 2009
Location: Twin Cities, Minnesota
Posts: 2,023
Total Cats: -1
Default

Get an aftermarket oil pressure gauge.

FWIW, mine stock gauge isn't even an "idiot light". I unplugged mine near 3,000 miles ago and it still reads normal... So with no signal going to it at all it still reads just fine.
rider384 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:23 PM.