Strange noise... please help - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 07-14-2007, 01:31 PM   #1
Junior Member
Thread Starter
 
Join Date: Dec 2006
Posts: 209
Total Cats: -1
Default Strange noise... please help

So I just got my new EGR pipe put on and when I got the car back, I started hearing a strange noise when accelerating. It sounds kind of like a clicking noise( to me it sounds like the noise that comes off of the POS car next to you at the light :gay It sounds like it increases as I accelerate ( the repetition of the sound) If I accelerate really slowly then I can't hear the noise. As the Rpms get higher I can't hear the noise really just due to the sound of the turbo and exhaust.I looked at the belts, didn't see any signs of them being loose or torn. It kind of sounds like the car is super low on oil, but I checked it and it is fine. I also feel a slight vibration. I hope it isn't anything in the transmission. What do yall think? (I know it is a hard analysis to do in a post)
ak47bravo is offline   Reply With Quote
Old 07-14-2007, 01:34 PM   #2
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

Check the wires at the coil. May be a plug wire arcing to ground if they pulled a wire loose installing EGR.
olderguy is offline   Reply With Quote
Old 07-14-2007, 01:34 PM   #3
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

is this on accel only what about when you caost down in gear. It could be a tranny case flex is a bitch but i would, try to eliminate the other variables first. Brake sheilds rubbing, maybe the powersteering is going out, check the fluid in there.
magnamx-5 is offline   Reply With Quote
Old 01-15-2008, 08:12 PM   #4
Junior Member
iTrader: (6)
 
Join Date: Oct 2007
Location: So Cal
Posts: 331
Total Cats: 0
Default

Sorry to bring this back, but my turbine is making this same noise...OP did you ever find out what it was, I am thinking along the lines of an exhaust leak.
99NBMia is offline   Reply With Quote
Old 01-15-2008, 08:35 PM   #5
Junior Member
iTrader: (1)
 
Join Date: Dec 2007
Location: Orlando,Fl
Posts: 402
Total Cats: 0
Default

yeah i my makes the same noise when i accelarate no noise but as the turbo spool and it passes 3 grand or fast spool it makes that noise at first it was my mani that was cracked but i fixed it so it can't be that, also i just did an oil change yersterday so that's not the problem but when i was taking off the mani i lost a bunch of power steering fluid i don't know if that might be it?
mx03tb is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
VE values too low? compuw22c MEGAsquirt 4 09-12-2015 08:42 PM
Help Needed: Some kind of 1st gear (TOB?) issue miatamania General Miata Chat 8 02-04-2008 11:18 AM
Weird noise??? SOLDIER General Miata Chat 6 04-08-2007 11:17 PM
Bov question. Fireindc Prefabbed Turbo Kits 9 02-12-2007 01:49 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:53 PM.