General Miata Chat A place to talk about anything Miata

V-LEDs FTL?

 
Old 05-14-2009, 08:56 PM
  #1  
Elite Member
Thread Starter
iTrader: (15)
 
Join Date: Dec 2007
Location: San Antonio, Texas
Posts: 4,847
Total Cats: 28
Default V-LEDs FTL?

A heads-up on V-LEDs

So I noticed on the way home that a few cars would come up behind me quickly, then back off whenever I got on the brakes. I was not sure what was going on until I got home. No brake lights, no tail lights.

I had recently installed a set of these...
V-LEDS RED 48 SMT TURN/BRAKE LIGHT BULBS 7443-SRCK

I reported when I first put them in that they were bright, and responded quickly. I liked them, that is, until today. After doing the usual fuse checks, I pulled the rear lenses off and removed the left hand bulb. Rattle, rattle... Huh? Sure enough, it is completely dead, and there is something rattling around inside of the cylinder formed by the LED boards. Fail.

So then I remove the right hand bulb, and notice if I push on it just right, it flickers on and off. I check the socket, checked the contacts on the bulb, not it. It only works if I push on one part of the bulb, not on the whole thing. Clearly an intermittent connection within the bulb itself.

I have had these in the car for less than three weeks. I have contacted V-LEDs requesting new bulbs. If you have been thinking about getting a set of these, you might want to wait and see what happens next.
ZX-Tex is offline  
Old 05-15-2009, 12:19 AM
  #2  
Elite Member
iTrader: (33)
 
RotorNutFD3S's Avatar
 
Join Date: Jan 2007
Location: Newnan, GA
Posts: 2,518
Total Cats: 30
Default

That's no good. I've had no issues with my V-LED taillights, of course the parts are different for an NA and NB.
RotorNutFD3S is offline  
Old 05-15-2009, 09:32 AM
  #3  
Hear me Meow
iTrader: (3)
 
skidude's Avatar
 
Join Date: Apr 2008
Location: Outside Portland Maine
Posts: 2,006
Total Cats: 18
Default

I've always liked the idea of LED tail lights, I've just never gotten around to doing it. I'll be interested to see what they say.
skidude is offline  
Old 05-15-2009, 10:12 AM
  #4  
Elite Member
Thread Starter
iTrader: (15)
 
Join Date: Dec 2007
Location: San Antonio, Texas
Posts: 4,847
Total Cats: 28
Default

RotorNut how long have you had yours installed?
ZX-Tex is offline  
Old 05-16-2009, 10:45 AM
  #5  
Elite Member
iTrader: (33)
 
RotorNutFD3S's Avatar
 
Join Date: Jan 2007
Location: Newnan, GA
Posts: 2,518
Total Cats: 30
Default

I ordered/installed mine right after ben91 did his, I think it was sometime early last year. It's been a long time, they've been sitting for 10 months, but they still work fine.
RotorNutFD3S is offline  
Old 05-16-2009, 10:48 AM
  #6  
Elite Member
Thread Starter
iTrader: (15)
 
Join Date: Dec 2007
Location: San Antonio, Texas
Posts: 4,847
Total Cats: 28
Default

Thanks RotorNut.
They are going to send me a new set.
ZX-Tex is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
aidandj
MEGAsquirt
12
09-27-2014 01:26 PM
ZX-Tex
General Miata Chat
8
04-26-2009 10:41 PM
akaryrye
DIY Turbo Discussion
21
01-07-2009 10:02 PM
Stein
Insert BS here
34
10-25-2008 08:50 PM


Thread Tools
Search this Thread
Quick Reply: V-LEDs FTL?


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.