MS3x Nitrous In and JP8 question - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 09-25-2014, 10:26 PM   #1
SADFab Destructive Testing Engineer
Thread Starter
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,991
Total Cats: 1,457
Default MS3x Nitrous In and JP8 question

Reading step 31 here: Megasquirt-3 MS3 DIY board assembly manual

It says that custom firmware is required to use the jumper on JP8.

But here: https://www.miataturbo.net/megasquir...e2/#post815941

Brain says to just jump it and it gives a pullup.

By custom firmware do they just mean custom settings in the tune?

Also what gauge wire should I be using to connect the Pins of my ECU connector to the outputs of the MS3x and MS3.
aidandj is offline   Reply With Quote
Old 09-26-2014, 03:23 PM   #2
SADFab Destructive Testing Engineer
Thread Starter
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,991
Total Cats: 1,457
Default

Instead of starting a new thread I'll just continue this one. Hopefully someone has an answer:

Ok I'm stumped. It worked on the bench but now it won't work installed in my car. Any ideas?

I get 12v at power and ground. And it shows up in my devices. But tuner studio can't connect to it
aidandj is offline   Reply With Quote
Old 09-26-2014, 03:56 PM   #3
SADFab Destructive Testing Engineer
Thread Starter
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,991
Total Cats: 1,457
Default

Update: Testing on the car i get .25 volts where I should be getting 5 on the CPU connector. I get 11.38 On the left leg of U5.
aidandj is offline   Reply With Quote
Old 09-26-2014, 04:01 PM   #4
SADFab Destructive Testing Engineer
Thread Starter
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,991
Total Cats: 1,457
Default

And i get 5V on the right leg of U5 so that part seems to be working too.
aidandj is offline   Reply With Quote
Old 09-26-2014, 04:02 PM   #5
SADFab Destructive Testing Engineer
Thread Starter
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,991
Total Cats: 1,457
Default

Proto area only gets .3 Volts
aidandj is offline   Reply With Quote
Old 09-26-2014, 04:02 PM   #6
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,264
Total Cats: 51
Default

With the current firmware, JP8 should be left off.
Matt Cramer is offline   Reply With Quote
Old 09-26-2014, 04:04 PM   #7
SADFab Destructive Testing Engineer
Thread Starter
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,991
Total Cats: 1,457
Default

Quote:
Originally Posted by Matt Cramer View Post
With the current firmware, JP8 should be left off.
Any ideas about it not working in the car?
aidandj is offline   Reply With Quote
Old 09-26-2014, 04:20 PM   #8
SADFab Destructive Testing Engineer
Thread Starter
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,991
Total Cats: 1,457
Default

Megasquirt Support Forum (MSEXTRA) • board voltage wrong (View topic)

Reading there I have 5 volts at all those places except for D19.

I wish I had a schematic of this board. I'm lost at what everything does.
aidandj is offline   Reply With Quote
Old 09-26-2014, 05:09 PM   #9
SADFab Destructive Testing Engineer
Thread Starter
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,991
Total Cats: 1,457
Default

Doing more digging. Found 5 volts on the top end of F1, and .3 on the bottom end. Does this mean F1 is blown?
aidandj is offline   Reply With Quote
Old 09-27-2014, 01:44 AM   #10
SADFab Destructive Testing Engineer
Thread Starter
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,991
Total Cats: 1,457
Default

Found it. I didn't unplug the tps...that shorted out VREF. I feel stupid.
aidandj is offline   Reply With Quote
Old 09-27-2014, 11:36 AM   #11
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,819
Total Cats: 1,780
Default

what are you trying to use Nitrous IN for?

It's only good for trigger something with 12v and not a ground, unlike almost every other input ever.
Braineack is online now   Reply With Quote
Old 09-27-2014, 11:43 AM   #12
SADFab Destructive Testing Engineer
Thread Starter
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,991
Total Cats: 1,457
Default

I was gonna use it for VSS like you talked about in another thread.
aidandj is offline   Reply With Quote
Old 09-27-2014, 02:26 PM   #13
SADFab Destructive Testing Engineer
Thread Starter
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,991
Total Cats: 1,457
Default

Braineack, any idea on this?
So everything was going great:

maybe a bit rich. But then this happened...



Smoke everywhere and the wire burnt up. Its too late and it pissed me off so I am going to bed. Any ideas why this happened? The engine continued running while this happened. I have they flyback diodes wired in there.

It seems to be the 12v power wire that burnt up.

EDIT: I dug around and the 12v wire that went to the flyback diode burnt up along with the wire that goes from the fan output (Inj G) to the diode. The wire from the diode to MS3x pin 1 is fine, and so is the power wire in other places.

EDIT 2: Also I didn't jump the fuel pump relay and it still ran, this weirded me out. Any ideas?

Last edited by aidandj; 09-27-2014 at 02:41 PM.
aidandj is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
15x10 - 15x11 6UL @ 949 Racing emilio700 Wheels and Tires 151 06-02-2017 03:36 PM
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
NA Seat Sliders and Seat Belt Receivers skipstr Miata parts for sale/trade 2 09-28-2015 11:53 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:24 PM.