General Miata Chat A place to talk about anything Miata

various electrical issues driving me crazy

 
Old 06-10-2018, 11:59 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Jun 2015
Location: TAMPA, FL
Posts: 787
Total Cats: 18
Default various electrical issues driving me crazy

This has been going on for a while, since I rebuilt the car a couple years ago.

I have a bunch of Autometer gauges (mech boost, oil pres, oil temp, EGT) and an AEM wideband gauge. The others are all fine but the EGT gauge will sometimes flutter back and forth (very quickly) between 0 and whatever the actual reading is, like there's some kind of intermittent short. I checked the EGT probe wires and they aren't close to anything that would cause a short. is this just an issue with the gauge? It worked fine for years.

I've got the gauge running off a voltage regulator which is hooked up a 12v power supply (teed into the ignition 12v) and the chassis ground.

Any ideas where to start? This is annoying the **** out of me.

Also, anyone ever have the issue where you go to start the car and nothing will happen. Everything is completely normal up to the point that you try to engage the starter. It's not a low battery thing. It's like the starter just isn't there and then it is fine, like nothing was wrong. This particular problem started years. I swapped out the starter like 5 years ago and that seemed to address the problem, but now it is back. Maybe there's a short somewhere near the starter or something?
It's like :
Try > nothing
Try > nothing
Try > nothing
Try > vroom
AlwaysBroken is offline  
Old 06-10-2018, 02:56 PM
  #2  
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,605
Total Cats: 135
Default

Pull apart your ignition switch.
olderguy is offline  
Old 06-10-2018, 06:03 PM
  #3  
Senior Member
Thread Starter
 
Join Date: Jun 2015
Location: TAMPA, FL
Posts: 787
Total Cats: 18
Default

I did that already. Is there some special technique to cleaning it that I may have missed?
AlwaysBroken is offline  
Old 06-10-2018, 06:11 PM
  #4  
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,605
Total Cats: 135
Default

If you are satisfied that the ignition switch is not the problem, make sure the line to the starter solenoid is good and that there is clean contact to the ground at the starter.
olderguy is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
miatanutz
Miata parts for sale/trade
6
07-26-2011 12:55 AM
Rushin
Engine Performance
28
04-28-2009 03:50 PM
linuxbox
General Miata Chat
1
04-06-2009 08:09 AM
zoom2zoom
DIY Turbo Discussion
3
09-25-2007 08:14 AM
rappadan
Insert BS here
9
06-16-2007 05:59 PM


Thread Tools
Search this Thread
Quick Reply: various electrical issues driving me crazy


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.