Vibrant t-bolts not fitting? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 03-21-2008, 07:25 PM   #1
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default Vibrant t-bolts not fitting?

Well, I was all excited when I got home to put together my stripes kit. I ordered Vibrant t-bolts.

Part number 2791 which has the clamp Range: 2.06"-2.37"
I bought these for my 2" piping. They fit perfect.

Part number 2792 which has the clamp Range: 2.37"-2.68"
I bought these for my 2.5" piping. They don't fit.

It says to use them on 2.5" ID couplers. I'm using Vibrant couplers too. I tried taking the nut off all the way and the bridge just didn't fit. I'm going to get the next size up. This just seemed strang to me. Ever happen to anyone else?
miataspeed1point6 is offline   Reply With Quote
Old 03-21-2008, 07:34 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,831
Total Cats: 1,786
Default

i have the hardest time with some clamps....one of my 2.5" pipes has a 3" clamp on it just because it's such a thick silicone coupler...
Braineack is online now   Reply With Quote
Old 03-21-2008, 07:44 PM   #3
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

the size they are rated for "2.37"-2.68"" is the clamp ID.

If you have a 2.5" pipe add 2* the coupler thickness to that diameter to determine clamp size... usually about .25" so you'd need a 2.75" clamp for a 2.5" pipe
Arkmage is offline   Reply With Quote
Old 03-21-2008, 11:02 PM   #4
Elite Member
iTrader: (9)
 
TurboTim's Avatar
 
Join Date: Jun 2006
Location: Chesterfield, NJ
Posts: 6,481
Total Cats: 248
Default

Interesting. With vibrant t bolts and couplers, I have no problems with the 2.5 and 3" t bolts but I have a world of grief getting the 2" t bolts onto the 2" couplers.
TurboTim is online now   Reply With Quote
Old 03-21-2008, 11:37 PM   #5
Elite Member
iTrader: (12)
 
Join Date: Jan 2007
Location: Hermosa Beach, CA
Posts: 2,575
Total Cats: 11
Default

I had this problem with some t bolt clamps, its a pain. When you get clamps, make sure they are ateast .25 inches bigger than your pipe, .5 would be good.
cardriverx is offline   Reply With Quote
Old 03-22-2008, 01:59 AM   #6
Elite Member
 
Join Date: Jan 2005
Location: vancouver canada
Posts: 1,618
Total Cats: 0
Default

You can get T-bolt clamps at a hydraulic shop or deisel truck shop,they are cheaper and the selection in size is bigger.Make sure you take your couplers with you to determine what size you need.
spike is offline   Reply With Quote
Old 03-22-2008, 03:07 AM   #7
Elite Member
iTrader: (14)
 
Join Date: Mar 2006
Location: Edmonton, AB
Posts: 4,921
Total Cats: 0
Default

Quote:
Originally Posted by spike View Post
You can get T-bolt clamps at a hydraulic shop or deisel truck shop,they are cheaper and the selection in size is bigger.Make sure you take your couplers with you to determine what size you need.
I agree. I'm off to Princess Auto tomorrow to buy all the clamps I need.
jayc72 is offline   Reply With Quote
Old 03-24-2008, 05:08 PM   #8
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

I returned the clamps. New ones are,

Part number 2793 which has the clamp Range: 2.66"-2.97"

They are a perfect fit for the 2.5" couplers. Just updating in case someone needs to search for the info.
miataspeed1point6 is offline   Reply With Quote
Old 03-25-2008, 09:27 AM   #9
Elite Member
iTrader: (9)
 
TurboTim's Avatar
 
Join Date: Jun 2006
Location: Chesterfield, NJ
Posts: 6,481
Total Cats: 248
Default

I'm glad you found a good clamp.

According to vibrants website, 2792 are for 2.25" couplers, 2793 are for 2.5" couplers.
TurboTim is online now   Reply With Quote
Old 03-25-2008, 02:15 PM   #10
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

I think there is a typo in the catalog we were using. Their part numbers make sense, each number is .25". I swore the catalog said to use them on 2.5", but maybe we read wrong. Now I'm just waiting for my intercooler to show up and 3 more 2.5" couplers.

Oh, and for the record, stripes kit was a great deal at his selling price. Putting it together myself I've gone over his cost.
miataspeed1point6 is offline   Reply With Quote
Old 03-25-2008, 02:43 PM   #11
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,355
Total Cats: 1,322
Default

Quote:
Originally Posted by cardriverx View Post
I had this problem with some t bolt clamps, its a pain. When you get clamps, make sure they are ateast .25 inches bigger than your pipe, .5 would be good.
.25, not .5. I had a couple that were .5 larger (they were out of 2.25s, sent me 2.5s instead) and 6 months later they are all popping off. As they go, I am replacing them with 2.25s I sourced on eBay and they stop being issues. The 2.5s I have can't clamp down tight enough on the connection.
Savington is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Garrett Turbo, 1.8 Oil Pan, & Misc. Stuff nbdooey Miata parts for sale/trade 9 08-30-2017 10:50 PM
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:05 PM.