Wiring Question - Injectors - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 04-12-2012, 10:21 PM   #1
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default Wiring Question - Injectors

Okay, I've looked, re-looked, and looked yet again on my harness.

As far as I can figure out, for injectors, it is wired 1+3 and 2+4, I would assume that it would be wire 1+4 and 2+3.

Someone correct me if I'm wrong, please, on the signal wires.
blaen99 is offline   Reply With Quote
Old 04-12-2012, 10:28 PM   #2
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

I had to move over to m.net to search, this makes me sad in the pants.

http://forum.miata.net/vb/showthread.php?t=238496

There's no problem with 1+4 and 2+3 according to this, what else do I have to do to my MS2 to make it okay with 1+4 and 2+3?
blaen99 is offline   Reply With Quote
Old 04-12-2012, 11:21 PM   #3
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,326
Total Cats: 1,926
Default

Quote:
Originally Posted by blaen99 View Post
As far as I can figure out, for injectors, it is wired 1+3 and 2+4,
That is correct. It's weird, but correct.


Quote:
Originally Posted by blaen99 View Post
I had to move over to m.net to search,
Yes, you waited a whole seven minutes for an answer before giving up.

http://forum.miata.net/vb/showthread.php?t=238496

Quote:
Originally Posted by blaen99 View Post
what else do I have to do to my MS2 to make it okay with 1+4 and 2+3?
Nothing. Just tell it you have two injector channels.
Joe Perez is offline   Reply With Quote
Old 04-12-2012, 11:24 PM   #4
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

Quote:
Originally Posted by Joe Perez View Post
That is correct. It's weird, but correct.
Thanks Joe, still feeling really weird about 1+3 and 2+4.

Quote:
Yes, you waited a whole seven minutes for an answer before giving up.
Naw, it had me WTFing that m.net had the information, and mt.net did not. Seriously, how? Searching m.net for MS-related questions is like asking Faeflora to do bodywork on my car.

Quote:
Nothing. Just tell it you have two injector channels.
Roger. So all injectors inject fuel on all injectors at every injection event? Or...? I'm not really getting how you can swap from 1+3 and 2+4 to 1+4 and 2+3 without ------- something up, unless all injectors inject fuel at every injection event. Equally, if this is the case, I don't understand why you don't just run one wire for injector signals, instead of 2.
blaen99 is offline   Reply With Quote
Old 04-13-2012, 01:18 AM   #5
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,326
Total Cats: 1,926
Default

Quote:
Originally Posted by blaen99 View Post
Thanks Joe, still feeling really weird about 1+3 and 2+4.
That's ok. At first, I felt weird when Hustler invited me to share "secret playtime" with he and his uncle. But you get used to it.

It's not just the Miata. Most (all?) 80s vintage I4 engines with banked port injection are wired this way.



Quote:
Naw, it had me WTFing that m.net had the information, and mt.net did not. Seriously, how?
Yeah, it's a shame nobody at MiataTurbo thought to put this information at the very top of the Megasquirt-specific folder, in the sticky thread entitled "SUPER Important Megasquirt Threads" under the very first link at the top called "How To Make and Install Your Own DIY Megasquirt" wherein you'd find that information conveyed in the picture near the middle of post #3 under the heading "90-93 1.6L STANDALONE HARNESS WIRING."


I just don't know what we were thinking...


Quote:
Searching m.net for MS-related questions is like asking Faeflora to do bodywork on my car.
Props for most creative insult I've read all day.


Quote:
So all injectors inject fuel on all injectors at every injection event?
No.


Quote:
Or...?
Ideally, you'd set it up like everyone else's, by specifying "Alternating" under "Injector Staging," such that each injector bank fires twice per engine cycle, alternating A-B-A-B.

But that's just how I'd do it if it were my own car or any of the others that I've worked on in recent years. You're free to be creative.


Quote:
I'm not really getting how you can swap from 1+3 and 2+4 to 1+4 and 2+3 without ------- something up, unless all injectors inject fuel at every injection event. Equally, if this is the case, I don't understand why you don't just run one wire for injector signals, instead of 2.
Injector timing just isn't all that critical. It's best if you have four injector channels and time the injectors such that each individual injector pulse ends right about the time that the corresponding intake valve opens, but it's just not that big a deal if the timing isn't perfect.

Remember carburetors? Remember TBI? Remember CIS? None of these schemes timed the fuel delivery to valve events, and they worked fine. Slightly higher idle emissions then a modern engine, but like Pusha's mom at closing time, they were good enough.
Joe Perez is offline   Reply With Quote
Old 04-13-2012, 02:09 AM   #6
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

Thanks for the explanation, Joe. I kind of sort of vaguely "get it" now, I'll just have to figure out how to bend TunerStudio to my will on the injection settings!
blaen99 is offline   Reply With Quote
Old 04-13-2012, 04:18 AM   #7
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,367
Total Cats: 1,331
Default

It's nice that Mazda flipped the pairing on the injectors - it makes it much easier to troubleshoot when something goes wrong.

Injector timing is for those of you who are gas mileage weenies - play with it until you have the richest AFRs for a given injector pulsewidth, then re-tune the fuel table.

Why aren't you doing sequential fuel?
Savington is offline   Reply With Quote
Old 04-13-2012, 05:00 AM   #8
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

No MS3 - I'm running a MS2, so I'm wiring so I can swap over to seqfuel with a minor change, but that's part of trying to wrap my head around what Mazda was doing with the injectors.
blaen99 is offline   Reply With Quote
Old 04-13-2012, 03:56 PM   #9
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,326
Total Cats: 1,926
Default

Quote:
Originally Posted by blaen99 View Post
No MS3 - I'm running a MS2,
So, you're aware that JBPerf has a mod that allows you to run full sequential on the MS2, right?

http://jbperf.com/sequential/index.html
Joe Perez is offline   Reply With Quote
Old 04-13-2012, 04:00 PM   #10
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

I am aware, Joe, but I'd rather pick up a MS3 then deal with modifying my board for Seqfuel.

----, if I have to get seqfuel on the MS2, I'm gonna sweettalk Brainy into doing the mod for me.
blaen99 is offline   Reply With Quote
Old 04-13-2012, 11:22 PM   #11
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

Related to the above:

Install harness, gauge cluster goes nuts. Even turning the car off doesn't get it to stop it's bonkers on/off/on/off clicking - I have to disconnect the battery.

Unplug everything, gauge cluster is fine.

My hunch: It is the water temp sensor I miswired. Is the stock Mazda temp sensor possible to wire incorrectly?

Alternatively, did I somehow ---- up wiring my temperature sensor and/or CLT sensor and put voltage on a ground? I thought I matched colors exactly.

Final alternative: Miswired the injector plugs, but there's nothing there to miswire. Seriously, there's nothing there to focking miswire - shared 12v to all points, then point to point injector triggers.

Last edited by blaen99; 04-13-2012 at 11:33 PM.
blaen99 is offline   Reply With Quote
Old 04-14-2012, 01:38 AM   #12
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

What the fuckity ----?

I tear the harness apart completely, look everywhere for a problem, double and triple check wiring, repeatedly check continuity, etc. etc. find no problem.

Go back out, plug it in, it works. What the ----?

I mean, it idles rough as ---- still, but it works no problem (Not running it at length at this time of night). What the ----?
blaen99 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 Yesterday 09:00 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM


Tags
joe perez

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:37 AM.