Hydra
Sponsored by:
Sponsored by:

Hydra tunning software and Linux

 
Old 11-06-2011, 01:37 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Asheville, NC
Posts: 98
Total Cats: 2
Default Hydra tunning software and Linux

Has anyone successfully run the Hydra tuning software in a linux computer. I have been trying to run it under a wine windows emulator but im still getting a runtime error.
mgtmse01 is offline  
Old 11-06-2011, 01:56 AM
  #2  
Elite Member
iTrader: (10)
 
Join Date: Oct 2008
Location: Seattle, Wa
Posts: 1,770
Total Cats: 31
Default

Originally Posted by mgtmse01 View Post
Has anyone successfully run the Hydra tuning software in a linux computer. I have been trying to run it under a wine windows emulator but im still getting a runtime error.
Post a dump of the error message.
Jeff_Ciesielski is offline  
Old 11-06-2011, 02:43 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Asheville, NC
Posts: 98
Total Cats: 2
Default

hi thanks for replying. here is a screen shot. i have to go back to the computer and copy the log, i cant remember how to do a data dump
Attached Thumbnails Hydra tunning software and Linux-nemesis%2520error.jpg  

Last edited by mgtmse01; 11-06-2011 at 02:44 AM. Reason: adding
mgtmse01 is offline  
Old 11-06-2011, 03:33 AM
  #4  
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,583
Total Cats: 240
Default

Looks like the ecgraph activex control isn't registered properly. Is this during setup or are you actually trying to run the tuning program?
__________________
Originally Posted by ninerwfo View Post
The “into to megasquirt thread” mentions that the MS3 basic has 5 inputs with built in pull up resistors - and I was just wondering why it would have so many, while the MS3Pro PnP has just 2 (with no pull ups?)
MS Labs: Plug and Play Megasquirt ECUs for ANY 90-05 Miata (NA, NB1, NB2 w/VVT, MSM), including basemaps to get you started ASAP. PM me or email or details.
For support on MS Labs ECUs: Please email, be sure to include the unit's serial number and include a datalog and your current map.
Reverant is offline  
Old 11-06-2011, 08:43 AM
  #5  
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,676
Total Cats: 119
Default

I see this ending well.
Faeflora is offline  
Old 11-07-2011, 08:03 AM
  #6  
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Asheville, NC
Posts: 98
Total Cats: 2
Default

the program installed with no problems, that screenshot you see is from trying to run the program. i checked the log files and as i thought it would, it did not record anything because the program is being run in wine. wine program im using emulates windows xp.
mgtmse01 is offline  
Old 11-07-2011, 09:36 AM
  #7  
Elite Member
iTrader: (10)
 
Join Date: Oct 2008
Location: Seattle, Wa
Posts: 1,770
Total Cats: 31
Default

Originally Posted by mgtmse01 View Post
wine program im using emulates windows xp.
Actually it provides an inter-op/compatibility layer between windows programs and the linux kernel and various libraries, it doesn't emulate anything.

In fact, its name(WINE) is a recursive acronym. Wine Is Not an Emulator .

Have you tried manually registering the activeX control? The .ocx file should be in Hydra's install directory (check this first). It could be somewhere else though. If you aren't sure, open up a terminal and from your home directory and type: "find | grep ecGraph.ocx". After that, open up a terminal and navigate to ~/.wine/c_drive/program files/{Hydra install dir}. Type: "wine Regsvr32 ecGraph.ocx".

Report back with any error messages.
Jeff_Ciesielski is offline  
Old 11-13-2011, 04:32 AM
  #8  
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Asheville, NC
Posts: 98
Total Cats: 2
Default

thank you Jeff. i tried your suggestions and here are the results. when i tried to find the .ocx file i found it was not there. i did a search in terminal and nothing. i went ahead and downloaded the new tunning software 2.70r13 and ran the .exe file with wine. it brought up and ran the instal wizzard like the last time and installed the program. tried to run the program and i got the same error. tried the find|grep....in terminal and nothing. what am i doing wrong?
mgtmse01 is offline  
Old 11-13-2011, 02:41 PM
  #9  
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,676
Total Cats: 119
Default

You're doing it wrong by trying to use linux without being a *nix dork.

try

find / -name ecGraph.ocx 2>/dev/null

syntax may need some work for above command
Faeflora is offline  
Old 11-13-2011, 04:37 PM
  #10  
Elite Member
iTrader: (10)
 
Join Date: Oct 2008
Location: Seattle, Wa
Posts: 1,770
Total Cats: 31
Default

^ You are fail aids

cd ~
find | grep *.ocx
Jeff_Ciesielski is offline  
Old 11-22-2011, 02:14 AM
  #11  
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Asheville, NC
Posts: 98
Total Cats: 2
Default

Originally Posted by Faeflora View Post
You're doing it wrong by trying to use linux without being a *nix dork.

try

find / -name ecGraph.ocx 2>/dev/null

syntax may need some work for above command
you're right about that, im slowly learning tho. while i was on vacation i did a little reading on line commands, its hard for me to understand that stuff. now that im back at work my internet time is limited and i cant sit and "study".

anyway, thank you for the help. are you running nemesis on a linux computer or are you using windows? i ran the above command and still no .ocx file.
mgtmse01 is offline  
Old 11-22-2011, 02:18 AM
  #12  
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Asheville, NC
Posts: 98
Total Cats: 2
Default

Originally Posted by Jeff_Ciesielski View Post
^ You are fail aids

cd ~
find | grep *.ocx
i tried this one also, no .ocx file, i also thank you for your help. im thinking i will get a cheap windows laptop and try the linux way at a later time when i know more about linux.
mgtmse01 is offline  
Old 11-22-2011, 02:22 AM
  #13  
Elite Member
iTrader: (10)
 
Join Date: Oct 2008
Location: Seattle, Wa
Posts: 1,770
Total Cats: 31
Default

Word.

Offer still stands. Provide me with an install package and I'll try to get it going.
Jeff_Ciesielski is offline  
Old 11-22-2011, 04:33 AM
  #14  
Junior Member
iTrader: (4)
 
Join Date: May 2009
Location: Athens GA
Posts: 434
Total Cats: 3
Default

Originally Posted by Jeff_Ciesielski View Post
^ You are fail aids

cd ~
find | grep *.ocx
It should be:

cd ~
find . | grep -i ecGraph.ocx

-Raj
redrider706 is offline  
Old 11-22-2011, 11:52 AM
  #15  
Elite Member
iTrader: (10)
 
Join Date: Oct 2008
Location: Seattle, Wa
Posts: 1,770
Total Cats: 31
Default

Getting Closer. I'll post a how-to when I get this error resolved.

Jeff_Ciesielski is offline  
Old 11-23-2011, 01:45 AM
  #16  
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Asheville, NC
Posts: 98
Total Cats: 2
Default

AWESOME! you are the man
mgtmse01 is offline  
Old 12-03-2011, 08:19 AM
  #17  
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Asheville, NC
Posts: 98
Total Cats: 2
Default

bump
mgtmse01 is offline  
Old 12-15-2011, 04:45 PM
  #18  
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Asheville, NC
Posts: 98
Total Cats: 2
Default

I THINK i got it fixed. i ended up using virtual box to run xp in linux and installed hydraems. the program comes up and the usb are working too. i wont be home till february so i dont have a way to actually test it. i was hoping to be able to use wine to run ems but i just dont know enough at the moment to get it to work that way.
mgtmse01 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
nick470
MEGAsquirt
7
06-16-2017 01:53 PM
z31maniac
Insert BS here
13
09-22-2015 02:59 PM
bahurd
Front Desk
0
09-21-2015 08:45 AM
ndragun
MEGAsquirt
0
09-20-2015 10:28 PM
TorqueZombie
MEGAsquirt
64
09-18-2015 05:03 PM


Thread Tools
Search this Thread
Quick Reply: Hydra tunning software and Linux


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.