Hydra
Sponsored by:
Sponsored by:

TPS sensor fail

 
Old 05-27-2018, 08:25 AM
  #1  
Newb
Thread Starter
 
Join Date: Dec 2016
Location: North of Shelburne Ontario, Canada on 100 acres
Posts: 26
Total Cats: 0
Default TPS sensor fail

I have had to recaibrate my throttle postion sensor three times as I work through my FMII install. Before I just order a new OEM one, are there better/cheaper options? It is a 99 motor in a 90 chassis.
Robin-42 is offline  
Old 05-28-2018, 12:59 PM
  #2  
Junior Member
 
Join Date: Oct 2015
Location: virginia
Posts: 63
Total Cats: 1
Default

id say check to make sure you are receving the 5v and ground to the sensor itself. test it and test it if the voltages change when opening/closing it manually. my 0.02.
Tastysi2004 is offline  
Old 06-08-2018, 08:12 PM
  #3  
Newb
Thread Starter
 
Join Date: Dec 2016
Location: North of Shelburne Ontario, Canada on 100 acres
Posts: 26
Total Cats: 0
Default

Of course, since posting it has not acted up. I will check when it is misbehaving.
Robin-42 is offline  
Old 06-09-2018, 09:58 AM
  #4  
Junior Member
 
Join Date: Sep 2006
Location: Reading PA
Posts: 134
Total Cats: 68
Default

Check the ground connection at the front of the intake manifold. If this is not a good low resistance connection, the TPS signal will float around a bit.

Also, when calibrating the TPS (or any other sensor) always perform the calibration steps multiple times until the two values do not change when you press the calibration button. In other words, the throttle closed value may need to change a bit after the throttle open value has been set. I always go back and forth between closed and ope throttle, until is see the numeric values stop changing. I have also found a few bad ground connections this way because the two values never stop changing.
Ken Hill is offline  
Old 06-10-2018, 12:54 PM
  #5  
Newb
Thread Starter
 
Join Date: Dec 2016
Location: North of Shelburne Ontario, Canada on 100 acres
Posts: 26
Total Cats: 0
Default

Thanks Ken, a bad ground is a cheaper fix than a new sensor. I will clean the grounds I have not disturbed during the build. It''s one of those things I tend to ignore, but shouldn't.
Robin-42 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
diddy
Miata parts for sale/trade
5
07-07-2012 02:32 PM
levnubhin
Insert BS here
91
04-01-2011 03:57 PM
hustler
Insert BS here
29
11-07-2010 04:21 PM
zzyx7
MEGAsquirt
25
04-22-2009 03:17 AM
m2cupcar
Miata parts for sale/trade
2
08-11-2008 10:16 PM


Thread Tools
Search this Thread
Quick Reply: TPS sensor fail


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.