90's mercury villager no start - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Insert BS here A place to discuss anything you want

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 01-30-2012, 11:34 AM   #1
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2010
Posts: 639
Total Cats: 2
Default 90's mercury villager no start

ok so my friends mercury villager 94 i think wont start
it cranks just great but wont start
the first time it happened we just wiggled this fuze labeled inj so im assuming injector, it started then

the next time it happened we cleaned off the coil wire and it started

now it is doing it again and idk why it wont start
i have verified spark with my timing light

i still need a second person to crank as i use my mechanics stethescope to see if i can hear the injectors pulsing and also to listen for the fuel pump to turn on

i just put some heet in the gas tank
it is in the twenties here right now


so im just lookin for some tips and tricks on what to do in these situations
thanks
jared
jared8783 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 12-13-2017 10:04 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:29 AM.