How many of you guys have running FI miatas? no, really - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Insert BS here A place to discuss anything you want

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 02-18-2008, 08:05 PM   #21
Elite Member
iTrader: (24)
 
Join Date: Jun 2007
Location: Sherman Oaks, CA
Posts: 4,481
Total Cats: 3
Default

i was boosted for some time, then took turbo off, now im going back to boost w/ gt2560r in few weeks
UrbanSoot is offline   Reply With Quote
Old 02-19-2008, 12:48 AM   #22
Senior Member
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

I've had the Greddy kit running on the stock computer with 6* timing for 2 years.

Now that I have upgraded everything and picked up MS, I'm going to build it right. I have never had an issue with the car not running, and I have never been left stranded. It's my daily in the Summer.

I wish I would have listened before buying the Greddy. After the MS install the only parts left will be the manifold and turbo. After I get out of college I think I will upgrade to Begi parts.
miataspeed1point6 is offline   Reply With Quote
Old 02-19-2008, 01:04 AM   #23
Senior Member
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,124
Total Cats: 0
Default

92 with about 130k on it
2k of that are boosted

greddy kit, bt set to 5-6*
clutch masters 35% increase clutch setup
xtd flywheel 9lbs
both clutch and flywheel have 5k on them
etd cross over
stock everything else

i drive my car 20 min every day to work, and some days to school


only problem ive had was heat bubbling the heater core hose,
which i failed to wrap.......

now its all set, runs and drives fine
urgaynknowit is offline   Reply With Quote
Old 02-19-2008, 11:13 AM   #24
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

'91 w/GReddy. 55K on turbo (110K total on car)still running [email protected]~15 psi, but making strange(but different) noises when clutch engaged and disengaged. Pulled everything apart. Clutch shot, manifold cracked. Pulled motor apart to check: Pristine inside, surprised that even the thrust bearing is perfect.

Tapped pan, replaced clutch and manifold, Godspeed radiator, big brakes, should be on the road next couple weeks for another 50K trouble free.
olderguy is offline   Reply With Quote
Old 02-19-2008, 11:54 AM   #25
Elite Member
iTrader: (12)
 
Join Date: Sep 2007
Location: Charlotte, NC
Posts: 6,868
Total Cats: 66
Default

Well, i've had 3 reliable boosted miatas. Well, one of them had problems..only after i let someone drive it unattended... but before that it was great.

96
JRSC,FMIC,RX7 injectors,Crank pulley,60mm s/c pulley, SAFC and dyno tuned 10psi w/16* advanced timing across the board

99
JRSC,FMIC,Voodoo BOX, crank pulley,62mm pulley, OBX header, street tuned w/ WB o2, no timing control,8psi

02 SE
FMII,Hydra,2560R,large FMIC, 550cc, 10psi, set on Auto-Tune/base maps from Jeremy at FM (one day going to BPM for 12 psi tune)

All 3 have made MANY long road trips with no problems.
Doppelgänger is offline   Reply With Quote
Old 02-19-2008, 01:03 PM   #26
Guest
iTrader: (1)
 
ray_sir_6's Avatar
 
Join Date: Dec 2006
Location: DFW, TX
Posts: 714
Total Cats: 0
Default

8k miles on stock motor and Greddy kit @ 8psi with Begi AFPR 2025, JR Inj Controller, MSD Timing Box, and O2 clamp. The car is now down due to the rear gears failing, but I needed this to get all my extra parts in...so it worked out perfectly to get the project moving in the right direction.
ray_sir_6 is offline   Reply With Quote
Old 02-19-2008, 01:51 PM   #27
I'm Miserable!
Thread Starter
 
Join Date: Nov 2007
Location: Sweden
Posts: 67
Total Cats: 0
Default

Lots of reliability here, mostly low and moderate boost applications. Seems great so far.
anyone with a high boost DD or track car?
Niklas is offline   Reply With Quote
Old 02-19-2008, 02:02 PM   #28
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

I have 18K turbo miles on my "02. No problems except a downpipe rattle and tires.

Daily driver, but Mom is not allowed to drive it. She somehow manages to get her foot under the dash and unplug Xede wires???

BEGI S3, w/ Xede, Enthuza Dual 3" Exhaust.
Stephanie
Stephanie Turner is offline   Reply With Quote
Old 02-19-2008, 02:23 PM   #29
Senior Member
 
Join Date: Jun 2005
Location: WA
Posts: 500
Total Cats: 0
Default

Mine was running fine for 10k+ miles. GT28R + 305cc + EMU. I blew the engine after that but that was my fault of starving the engine of oil.
RusMan is offline   Reply With Quote
Old 02-19-2008, 08:27 PM   #30
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,326
Total Cats: 1,924
Default

I know I can't be alone in saying that 99% of the downtime I've had with my car since going FI was not because something broke, but because I said to myself "Gee, it'd be neat if..." or "I bet I could improve..." followed by several days of cutting, welding, machining, wiring, etc...

Last edited by Joe Perez; 02-19-2008 at 08:47 PM.
Joe Perez is offline   Reply With Quote
Old 02-19-2008, 08:36 PM   #31
Elite Member
iTrader: (12)
 
Join Date: Aug 2006
Location: Central-ish VA
Posts: 4,449
Total Cats: 16
Default

Ya, projects are the cause of most of my downtime. I start out with something simple (READ rods and pistons) and end up building something entirely different (I don't think there is anything else I could have possibly replaced with an aftermarket part). So instead of 1 month, it takes 5 months.
neogenesis2004 is offline   Reply With Quote
Old 02-20-2008, 09:40 AM   #32
I'm Miserable!
Thread Starter
 
Join Date: Nov 2007
Location: Sweden
Posts: 67
Total Cats: 0
Default

Quote:
Originally Posted by Joe Perez View Post
I know I can't be alone in saying that 99% of the downtime I've had with my car since going FI was not because something broke, but because I said to myself "Gee, it'd be neat if..." or "I bet I could improve..." followed by several days of cutting, welding, machining, wiring, etc...
Very familiar from my last car. Of course, once i got to 14+ psi stuff started to happen, only on track though, that surely is the true test of durability.
(I guess 16 y/o piston rings made for n/a applications just didn't cut it )

But the miatas seem better than that.

Last edited by Niklas; 02-20-2008 at 09:59 PM.
Niklas is offline   Reply With Quote
Old 02-20-2008, 12:36 PM   #33
Elite Member
iTrader: (2)
 
Join Date: Jun 2006
Location: ABQ, NM
Posts: 1,850
Total Cats: -8
Default

91 greddy 5psi, jim pipes starion IC, ceramic coated tony DP, 1.8 diff, oil cooler, timing 10* advance, act 6 puck.

DD and track rat 180K miles, 60K boosted.

Lost a motor from rocks in the intake, melted some random stuff and 2 brake master cylinders, had studs in the manifold shear, that's about it. All issues have been fixed, waiting for some more track time to see if there is anything else that needs attention.

Pretty reliable given the environment and amount of abuse.
BenR is offline   Reply With Quote
Old 02-20-2008, 01:06 PM   #34
Elite Member
iTrader: (5)
 
Join Date: Oct 2007
Location: Canton, Ga
Posts: 1,707
Total Cats: 19
Default

I used to have a reliable boosted car. I had a JRSC for three years, but the more power I eeked out of it the less reliable it got... I had insane torque but nothing up top. I'm all motor now and the car is now more fun then it ever has been. I did raise the compression but not so much that I could not go turbo later... If I do get bored with N/A power I think my engine would be perfect for a turbo on the larger side... say a GT2871 at moderate boost, 10-12 PSI... the engine should be good for 300 reliable RWHP, But I dont want the extra complications right now... like the extra underhood heat and cooling issues that could come with that, but when/if the time comes its only a matter of a kit and larger injectors.
Stealth97 is offline   Reply With Quote
Old 02-20-2008, 08:10 PM   #35
Senior Member
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

96, DIY, ~30K miles, She drives it- I don't get to drive it much, Maybe I'll remember to change the oil this year..

94, Cold Side BRP M45--was a POS for belt reliability, have since re-engineered the belt system - hoping for better this year, Had battery drain issues too, (this system was installed BRP dealer) discovered they taped the wrong wires for the idle relay...(was always on...)

FWIW 03 P5 +50K miles DIY, recently de turboed (85K on OD> time to find something else)Had an O2 wire short out once, and a hose clamp puncture an A/C line but nothing that wasn't my fault.
Jefe is offline   Reply With Quote
Old 02-20-2008, 09:47 PM   #36
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

See sig... Have about 3-4K miles on the setup and the turbo sounds like it is eating itself. It's a $100 turbo though so I'm not really upset.

With the exception of turbo starting to fail everything has been golden. It's fantastic. Car is my DD and get's heavy abuse.
Arkmage is offline   Reply With Quote
Old 02-20-2008, 09:57 PM   #37
Junior Member
iTrader: (4)
 
Join Date: Dec 2007
Location: Minneapolis
Posts: 415
Total Cats: 0
Default

Technically I have 3 boosted Miatas.

1) '01 turbo - Trouble free for 30k miles. Literally not one problem. This spring I am pulling off the link piggy and putting in a Hydra.

2) '00 Hotside SC (roots M62) - No real issues except for occasional idle droop. It is my GF's car and she like the turbo much better. The SC is now off the car and I will be selling it. I will likely put a turbo in the car within the next year.

3) '94 SC Twin Scew - Bought the car in December sight unseen (It was Corky Bells prototype car for the MOAB). I hope to pick it up next month when the snow melts and this will be my toy to play with.
Scuba_Steve is offline   Reply With Quote
Old 02-20-2008, 11:27 PM   #38
Junior Member
 
Join Date: Mar 2005
Location: high performance all year round california
Posts: 82
Total Cats: 0
Default

I am at around 40k miles boosted so far. Granted I have had tons of issues over the years but thats cause running redline uphill for 5 minutes 6 times a night kept the Manifold nice and busy. But honestly nowa days I don't run it nearly as hard as I use to so its pretty damn reliable.....but everyones definition of "reliable" is different.
Gloko is offline   Reply With Quote
Old 02-21-2008, 04:19 AM   #39
Junior Member
 
Join Date: Jan 2008
Posts: 208
Total Cats: 0
Default

93 1.6-116,000 on the clock-? miles on turbo set up
begi S w/ gt2560, megasquirt, 460cc injectors @ 6psi(on paper)- really 10psi(boost creep)
The good- the car turns on
The bad- lc-1 keeps taking a **** on me, just developed odd cooling problem, was rear ended all in the matter of a week or so

updated- As of today the car no longer turns on

Last edited by driftbandito; 02-21-2008 at 09:31 PM.
driftbandito is offline   Reply With Quote
Old 02-23-2008, 11:48 PM   #40
Newb
 
Join Date: Nov 2006
Location: Lancaster, PA
Posts: 42
Total Cats: 0
Default

Quote:
Originally Posted by LateralSpeed View Post
No problems with mine so far. 36k miles on the factory microscopic turbo with boltons and running great.
Yours doesn't count
got rice? is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
elesjuan's mediocre 95 Miata adventure (google fiber edition) elesjuan Build Threads 8 02-16-2016 09:36 PM
VE values too low? compuw22c MEGAsquirt 4 09-12-2015 08:42 PM
Drummersrs old Miata, new to me foshizzle Meet and Greet 9 09-08-2015 01:26 PM
New here, saying hi, here's what I'm workin with. SuperSneakySecretSquirrel Meet and Greet 5 09-06-2015 09:30 PM
Help Rough Idle Backwoodsballer General Miata Chat 0 09-04-2015 07:39 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:59 PM.