Sh*t just got real son! - Page 3 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Media Got any pics or vids to share?

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 01-21-2012, 03:54 PM   #41
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

Progress... I got an F1 stage two carbonized kevlar clutch and PP. Should hold up to 250ftlb of torque, it looks like a quality product but the clutch material isn't very thick. Will probably last 10-15k miles with the type of driving I do, but I only put on about 4-5k miles a year.

I'm off to autozone to pick up a slave cylinder and then it's complete.

Next stage, clean engine compartment.
Attached Thumbnails
Sh*t just got real son!-img_20120120_200629.jpg   Sh*t just got real son!-img_20120120_213005.jpg   Sh*t just got real son!-img_20120121_133157.jpg   Sh*t just got real son!-img_20120121_134826.jpg   Sh*t just got real son!-img_20120121_142822.jpg  

Sh*t just got real son!-img_20120121_133316-large-.jpg  

Last edited by flounder; 01-21-2012 at 11:05 PM.
flounder is offline   Reply With Quote
Old 01-21-2012, 07:18 PM   #42
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

Has anyone ever painted their waterpump pulley? I'm thinking about painting the front of it the same blue as my block. Add some color to the front.

Yay or nay?
flounder is offline   Reply With Quote
Old 02-03-2012, 09:57 PM   #43
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

Bit of an update....

My new engine mounts came in the mail today, and since I will be installing the engine in the driveway I have been hoping for a nice weekend to get started. This weekend appears to be in the high 30's/low 40's so I will try to at least shoehorn this bastard into place tomorrow afternoon.

I had a 2hr window last weekend where I pulled off the hood, gave the cradle a good cleaning and had a chance to wipe down most of the engine compartment and get it ready.

If the weather works out, I will hopefully be posting pics of progress by sunday night.
flounder is offline   Reply With Quote
Old 02-04-2012, 08:14 PM   #44
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

Progress...

Well, I got more done today then I thought I would. Engine is in and the engine mounts are installed, I still need to bolt together the ppf, install the driveshaft, exhaust, radiator, IC piping, etc, but most of the wiring is connected so I am hoping to have it idling by tomorrow afternoon!
Attached Thumbnails
Sh*t just got real son!-img_20120204_123614-medium-.jpg   Sh*t just got real son!-img_20120204_130255-medium-.jpg   Sh*t just got real son!-img_20120204_131120-medium-.jpg   Sh*t just got real son!-img_20120204_150733-medium-.jpg   Sh*t just got real son!-img_20120204_150742-medium-.jpg  

flounder is offline   Reply With Quote
Old 02-05-2012, 09:09 PM   #45
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

She runs!

After I realized that I had the s-wire and the oil sender wire crossed, I dry cranked until I got oil pressure, popped the INJ fuse back in, and it fired right up.

It sounds healthy, no leaks I can see, and the stiffness of the s2 clutch kit feels so nice. I'm still a couple of days away from a test drive but so far so good.

I will put up a vid soon.
Attached Thumbnails
Sh*t just got real son!-img_20120205_185220.jpg   Sh*t just got real son!-img_20120205_185133.jpg   Sh*t just got real son!-img_20120205_185149.jpg   Sh*t just got real son!-img_20120205_185204.jpg   Sh*t just got real son!-img_20120205_185231.jpg  


Last edited by flounder; 02-05-2012 at 10:58 PM.
flounder is offline   Reply With Quote
Old 02-05-2012, 11:11 PM   #46
NB/VVT Connoisseur
iTrader: (23)
 
viperormiata's Avatar
 
Join Date: Aug 2008
Location: Key West
Posts: 6,065
Total Cats: 253
Default

Looks great man!
viperormiata is offline   Reply With Quote
Old 02-08-2012, 01:55 AM   #47
Elite Member
iTrader: (10)
 
soviet's Avatar
 
Join Date: Jan 2010
Location: VA
Posts: 3,516
Total Cats: 255
Default

How did you clean the head/block headgasket surfaces? I'm going through the same thing and was told not to use anything abrasive on it.
soviet is offline   Reply With Quote
Old 02-08-2012, 08:09 PM   #48
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

Use this exact disc. It's good for the block and head, and anything else on your engine for that matter. Don't use the green hard discs, those cut away too fast and will mess up aluminum pretty quick. Just make light sweeps until the surface is clean and even looking. You don't need to run the grinder at full speed, I usually turn down the regulator on my compressor to about 40-50psi.

Back to the car, I haven't started it/worked on it since Sunday night and from the looks of my week probably won't have any free time until the weekend. I will update on the weekend.
Attached Thumbnails
Sh*t just got real son!-img_20120208_184859.jpg   Sh*t just got real son!-img_20120208_184908.jpg   Sh*t just got real son!-img_20120208_184919.jpg  
flounder is offline   Reply With Quote
Old 02-12-2012, 08:20 PM   #49
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

Well, Detroit got hit with 4" of snow friday night, so my lazy *** spent all weekend on the couch. Hoping for some better weather in the coming week so I can wrap this build up.
flounder is offline   Reply With Quote
Old 02-20-2012, 08:28 PM   #50
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

Ok, I got a chance to do the first test drive on Saturday afternoon. I've put on around 30 miles so far and the only issues to note are a very small oil leak running down the oil return line and my downpipe is touching the trans tunnel causing a vibration/humming.

I am pretty sure the leak is just a loose clamp on the hose, and the vibration may be from the new engine mounts I installed. I think I need to add a shim or two and hopefully that will give me more clearance between the tunnel and dp.

I kept it under 4k rpm for the first 20 miles, but let it rev up to about 6k after that. (wastegate wired open and zero map on emb) It runs good, the clutch already feels pretty solid, it only hops a bit when backing up but even from a dead stop going forward it feels really nice and the pedal travel feels stock. Only 470 miles to go before I reconnect the wga and let the fun begin!

The next time I take it out, I will snap some new pics.
flounder is offline   Reply With Quote
Old 02-21-2012, 02:09 AM   #51
Senior Member
iTrader: (6)
 
Join Date: May 2009
Location: San Francisco
Posts: 989
Total Cats: 23
Default

Definitely make sure that you let that clutch have it's break in period. You should have done some more research before buying the stage two, I think there's a couple threads here about it. It's pretty good up to about 200, but once you fry it once it starts to degrade. Mine would slip getting on the highway when I hit like 4500 rpm in third gear full throttle. I wasn't dropping it at that point, just accelerating. Sorry to post somewhat of a bummer post. If it does slip, I would suggest just getting a fm setup.
wittyworks is offline   Reply With Quote
Old 02-21-2012, 08:15 PM   #52
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

I hope I have better luck.

Specs for it say 291hp/260tq. My turbo is only a china 2854 so I don't think I'll see anywhere near those torque levels at 15psi.

I guess we'll find out in about 470 miles
flounder is offline   Reply With Quote
Old 02-26-2012, 05:48 PM   #53
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

Went on a nice long 80 mile excursion today and my confidence with the engine and clutch is building! But no boost yet.

The clutch has felt great since about 20 miles in. The pedal is a little stiffer but I like it, and the engage point feels identical to stock.

After I hit 60 miles, I ran it up to about 6500rpm a few times and one thing I noticed is how much stronger this engine feels above 4k then before the rebuild. I can feel the vics kick in like vtec yo! Even with 0 boost (watching the gauge) it just feels like it's going to be a beast. Compression numbers at 57 miles was 185 psi even across all four when warm. I will test it again at 500 miles.

I was able to fix all the leaks but the dp flange where it meets the cat is touching the trans tunnel and driving me crazy. Lots of vibration in the cabin whenever they rub together. I am not gonna sweat it though since it will all be replaced shortly with a nice 2.5in system ending at a straight through muffler. I am debating on cutting the flange off of the dp and sliding a new intermediate pipe over it then relocating my wb into the intermediate pipe.

I also removed the little vapor canister from the engine compartment and capped the ends off. It definitely makes for a cleaner look. I ordered a new 2 row aluminum radiator from ebay which should be here by Wednesday, and yes, I will be wrapping the heater core hoses very shortly.

Only 375 miles of break-in to go.
Attached Thumbnails
Sh*t just got real son!-img_20120226_144625.jpg   Sh*t just got real son!-img_20120226_144642.jpg  

Last edited by flounder; 02-26-2012 at 06:03 PM.
flounder is offline   Reply With Quote
Old 03-03-2012, 06:10 PM   #54
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

250 miles to go. Honestly, the engine and clutch both feel rock solid and I am growing impatient for da boosts.

Today I went out and did some NA launching with redline shifts and nothing has slipped, leaked or exploded. I'm seeing boost creep to about 1-2psi by redline and it's making me horny. Me thinks 300 miles is my new target for the fun stuff.

Does anyone think I should go the full 500?
flounder is offline   Reply With Quote
Old 03-07-2012, 09:30 PM   #55
Junior Member
 
Golferluke's Avatar
 
Join Date: Oct 2009
Location: Springfield, MO
Posts: 497
Total Cats: 3
Default

I don't know if i'd be doing redline shifts half way through breakin period? Just take a quick trip up to bay city and back and your good to go. Only 4 hours away from boosting with piece of mind.
Golferluke is offline   Reply With Quote
Old 03-22-2012, 11:21 PM   #56
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

RX8 injectors arrived today.
Attached Thumbnails
Sh*t just got real son!-img_20120322_184538.jpg   Sh*t just got real son!-img_20120322_184625.jpg  
flounder is offline   Reply With Quote
Old 03-22-2012, 11:28 PM   #57
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

Here is a shot of the new radiator.
Attached Thumbnails
Sh*t just got real son!-img_20120307_201715.jpg  
flounder is offline   Reply With Quote
Old 03-25-2012, 02:07 PM   #58
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

I installed the new injectors on Thursday night and have been tuning for 12psi at the moment. It's so nice to have bigger injectors! I'm seeing afr's in the low 11's at 70% DC.

The clutch is holding the power just fine so far, and I plan on turning it up to 15psi within a couple days.

I really need to get the exhaust situation taken care of, I feel like I'm leaving about 30hp on the table with this pos stock system. I don't want to wait 2 months to order one, so I think I'll make a trip to my friendly local exhaust shop and see what they have to offer.
flounder is offline   Reply With Quote
Old 11-18-2012, 11:49 AM   #59
Junior Member
iTrader: (1)
 
Join Date: Jan 2008
Posts: 161
Total Cats: 0
Default

Huge difference the exhaust system.

Good job!
psiturbo is offline   Reply With Quote
Old 11-22-2012, 10:04 PM   #60
Elite Member
Thread Starter
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default





3" straight, magnaflow#12579.
Attached Thumbnails
Sh*t just got real son!-1343269084986.jpg   Sh*t just got real son!-1343269094575.jpg   Sh*t just got real son!-1343269097129.jpg  
flounder is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
An Old Driver but a newbie in Miata Patriarca Meet and Greet 17 10-13-2015 02:34 PM
Please school me on life insurance... samnavy Insert BS here 14 10-11-2015 12:21 AM
2003 VVT Head/Valve Cover/Actuator/Coil Packs - Low Miles! - $250 StratoBlue1109 Miata parts for sale/trade 7 09-24-2015 04:50 PM
ME221 Now has Autotune and Long Term Fuel Trim Tables Motorsport-Electronics ECUs and Tuning 0 09-05-2015 09:02 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:41 AM.