1.6 idles at 2600 and creeps up to 3k - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-05-2012, 08:39 AM   #1
Newb
Thread Starter
 
Join Date: Dec 2012
Posts: 9
Total Cats: 0
Default 1.6 idles at 2600 and creeps up to 3k

Okay quick background. Car is a pretty stock 1.6. Has cat delete and intake with timing at 14 advanced running only 93. I am building a 1.8 for boost but have not used a megasquirt before so I figured I would hook it up and figure out the software. I have used cobb ap and hydras before. I got it with the base map preinstalled, started and drove okay. Logged a lil and did some adjustments. Ran a lot better and quit drinking gas. Made a rev limiter and launch control adjustment to just play and uploaded them, started the car and it ideled at 2600 and starting creeping up to 3k. I took those new changes off and reuploaded. No change. Looked at other things I was clickig on to see what was were with the software and all was not touched as far as I could tell. Nothing changes with new base maps etc. I went back to the factory ecu and the car is fine. Only thing that will change the idle is the warmup enrichments and it idoes not seem like the right way as it wont free rev after that. Ideas?

Ive done a lot of research and see maybe the iacv needs cleaned as wel as tb but on stock ecu its fine. seems like i changed something that shouldn't hae been on accident and cant find it. Found nothin in searching with idle this high.
dawgincustoms is offline   Reply With Quote
Old 12-05-2012, 09:46 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,847
Total Cats: 1,788
Default

You either have a vacuum leak, or you need to tune your idle.
Braineack is offline   Reply With Quote
Old 12-06-2012, 12:18 AM   #3
Newb
Thread Starter
 
Join Date: Dec 2012
Posts: 9
Total Cats: 0
Default

Thanks im gonna look at it more this weeked. Pull the TB and iac and clean em both up, run my iat sensor and ditch the maf and then get back to the megasquirt.
dawgincustoms is offline   Reply With Quote
Old 12-09-2012, 03:18 PM   #4
Junior Member
 
Join Date: May 2011
Location: Central Kentucky
Posts: 221
Total Cats: 1
Default

Mine was having a high idle caused by the IACV. I covered the hole and my idle dropped to normal so I just capped it. I'm not sure if it's the best solution but it works. So you could try that.
Oochi is offline   Reply With Quote
Old 12-09-2012, 03:28 PM   #5
Newb
Thread Starter
 
Join Date: Dec 2012
Posts: 9
Total Cats: 0
Default

I got it figured out. It was stupid actually. My vaccume like for the megasquirt actually got pinched off under the hood by the headlight motor ( I tucked the extra by it as it was a temporary route). Car is running pretty good now. Just drinking gas like its cool.
dawgincustoms is offline   Reply With Quote
Old 12-09-2012, 03:55 PM   #6
Junior Member
 
Join Date: May 2011
Location: Central Kentucky
Posts: 221
Total Cats: 1
Default

That's good to hear! Mine loves gas too. Haven't had the time to work that out yet though.
Oochi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:28 PM.