1997 tps to MS1 w/relay board question - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 05-26-2012, 12:37 PM   #1
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 62
Total Cats: 0
Default 1997 tps to MS1 w/relay board question

I have been making amazing progress on my standalone install, but it seems i have a gremlin in my TPS.

I have a off idle stumble, i checked it out in the diag page of TS, the tps signal it really jumpy for just a bit then is stable and drives nice.
maybe it is connected wrong, what kind of values are normal to see in the calibrate tps window. i see a min value of 5 and a max of 17.

thank you, this forum has been so amazingly helpful. ive searched but it seems that the wiring is explained very well with regards to the 90-93 cars, but there is not much on the topic of 94-97 with regard to the tps wiring.
jamiemiller is offline   Reply With Quote
Old 05-26-2012, 01:04 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

you totally have it wired wrong.

5vref should go to 2K
TPS signal should go to 2H


that's it.
Braineack is offline   Reply With Quote
Old 05-26-2012, 02:07 PM   #3
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 62
Total Cats: 0
Default

thank you
5vref the light green wire on the original harness
black and blue is tps return
red with black is tps signal

does this sound correct? im using the wiring diagram from http://www.madracki.com/miata/images/wiring/97sys.pdf

and full rewire using stock connectors, but not full harness.
jamiemiller is offline   Reply With Quote
Old 05-26-2012, 03:23 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

that's not correct for a 97. The breakdown for different wiring is 90-93, 94-95, 96-97.

for the 97 it's:

5vref to 3I (lg/w)
tps to 3F (r/b)

Last edited by Braineack; 05-27-2012 at 10:55 AM.
Braineack is offline   Reply With Quote
Old 05-26-2012, 04:47 PM   #5
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 62
Total Cats: 0
Default

It works! Thank you sir! Had the return and tps flipped.
jamiemiller is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Tags
97, megasquirt ms ms1 ms2 ms3, standalone, tps

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:24 AM.