90 miata only one coil firing MSPNP2 issue - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-18-2013, 01:12 PM   #1
Newb
Thread Starter
 
Join Date: Oct 2012
Posts: 29
Total Cats: 0
Default 90 miata only one coil firing MSPNP2 issue

Ok, any miata and or MS experts please chime in.

I've got only plug 1 and 4 firing, and 1 is much brighter than 4. The other coils are producing no spark at all. Tried swapping out the coil pack, no change. So, this car was previously running great. What are the potential culprits here. I believe the ecu does not send individual signals to each coil pack seperately, is this correct? It seems to be the case by looking at the pinout. Does the ignitor send seperate signals to the two packs? Could the CAS have packed it in, or is there a specific wiring issue that seems likely?

Any help trying to diagnose is greatly appreciated.

90 miata, running mspnp2 ecu, variable TPS (Bosch,) GM air temp sensor.
joejoepop is offline   Reply With Quote
Old 02-18-2013, 01:52 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,847
Total Cats: 1,788
Default

was it working previously and now only 1 of the coils is firing?

or are you saying

you just installed a MSPNP2 and now only 1 of the coils is firing?
Braineack is offline   Reply With Quote
Old 02-18-2013, 03:41 PM   #3
Newb
Thread Starter
 
Join Date: Oct 2012
Posts: 29
Total Cats: 0
Default

Nope, it was running fine with the megasquirt MSPNP2, until something must have malfuntioned or died. What I am trying to understand is what could make this happen. Could the megasquirt malfunction in such a way as to only fire one coil, and one of those plugs is firing much better than the other, or could this be ignitor, or CAS?
The timing was set carefully, and everything was functioning great, then something has simply gone wrong and I am asking for help in the diagnosis, as i n, what units could malfunction to cause this?
joejoepop is offline   Reply With Quote
Old 09-25-2017, 04:51 PM   #4
Newb
Thread Starter
 
Join Date: Oct 2012
Posts: 29
Total Cats: 0
Default

In the end, it was the igniter, and I went through a couple of them before I abandoned that system all together and went with the trackspeed engineering coil on plug kit, which eliminates the whole igniter and stock coil system.
Ignition
joejoepop is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
91 1.6l turbo complete part out. Tony the Tiger Miata parts for sale/trade 63 12-29-2016 03:23 AM
No spark while cranking? navalhawkeye MEGAsquirt 9 10-07-2015 08:10 PM
MS PNP requires reading and following directions??? satisfied MEGAsquirt 141 10-06-2015 11:44 AM
Reasonable source for NB coils. mx5-kiwi Race Prep 10 09-20-2015 08:31 PM
Mystery Engine Trouble. Halp, mt.net! vehicular General Miata Chat 12 09-14-2015 04:17 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:36 PM.