Adding VDO sensors to MS3 and sharing with gauge? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 10-19-2014, 12:33 PM   #1
Senior Member
Thread Starter
 
Join Date: Mar 2006
Location: Schwarzenberg, Germany
Posts: 1,497
Total Cats: 81
Default Adding VDO sensors to MS3 and sharing with gauge?

Hi to all the MS experts on here,

I have 3 additional VDO sensors on my Miata and would like to bring them into the MS (and maybe share them with the VDO gauge?!)

1 oil pressure sensor
1 oil temp sensor
1 coolant temp sensor (not needed in the MS of course)

Sensor is like that:
http://www.vdo-instruments.com/senso...-4-18nptf.html

The sensors are all resistive(?) sensors and don't give out 5V that the MS would need.

How would I have to wire the sensors to make them readable in th MS and would I be able to share them with the original VDO gauge...

I have seen that the new MS3 firmwares already have a oil pressure menu - how would I have to set this up... ?

Thank for your advices and sorry for my electronic noob-ness....

Greets
Sven
Zaphod is offline   Reply With Quote
Old 11-07-2014, 11:03 AM   #2
Senior Member
Thread Starter
 
Join Date: Mar 2006
Location: Schwarzenberg, Germany
Posts: 1,497
Total Cats: 81
Default

O.K. seems I need to put a bias resistor on the MS3X card R65 or R66 or R67 to use

Ext map
EGO2
Spare ADC

as additional inputs - in the schematics the resistors show a value of 2,49kohm (like the other temp sensors).

Now I do have a whole bunch of extra resistors lying here - but as it is no single 2,49k ohm one. Can I also use a 1k resistor?
Zaphod is offline   Reply With Quote
Old 11-07-2014, 11:55 AM   #3
Senior Member
iTrader: (8)
 
Join Date: Jan 2012
Location: Azusa, CA
Posts: 1,376
Total Cats: 80
Default

Quote:
Originally Posted by Zaphod View Post
Hi to all the MS experts on here,

I have 3 additional VDO sensors on my Miata and would like to bring them into the MS (and maybe share them with the VDO gauge?!)

1 oil pressure sensor
1 oil temp sensor
1 coolant temp sensor (not needed in the MS of course)

Sensor is like that:
Temperature Sender 300F/150C 1/4-18NPTF | Sensors | VDO Instruments and Accessories

The sensors are all resistive(?) sensors and don't give out 5V that the MS would need.

How would I have to wire the sensors to make them readable in th MS and would I be able to share them with the original VDO gauge...

I have seen that the new MS3 firmwares already have a oil pressure menu - how would I have to set this up... ?

Thank for your advices and sorry for my electronic noob-ness....

Greets
Sven
Those sensors function just like your IAT sensor which is a variable resistor. MS has an internal voltage divider circuit to convert that resistance into a voltage. I do not know how many of these types of inputs your MS has. It might only have 1 for the IAT. If it does have more you would most likely just need to input the calibration curve values to have the data scaled appropriately.

If you only have 0-5V inputs available you can make you own circuit to do the signal conditioning. It's just 2 resistors really. I believe the sensor that have power, grnd and signal out have this type of circuit internal to the sensor.

AS220 Arduino Workshop
cyotani is offline   Reply With Quote
Old 11-07-2014, 02:10 PM   #4
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Chicago (Over two miles from Wrigley Field. Fuck the Cubs. Fuck them in their smarmy goat-hole.)
Posts: 26,317
Total Cats: 1,914
Default

DANGER TO THE MANIFOLD!

So, yeah. These are resistive sensors, just like the stock temperature sensors.

And they require a pullup, just like the stock sensors.

The difference here is that the gauge you plan on also connecting to them already has it's own internal pullup (you can't have two pullups), and you don't know what value it's using.

For starters, it's probably using 12 volts, so you'll need to build an external voltage divider or else you'll blow up the ECU.

Beyond that, you just need to determine the pullup resistor value and then compute the resultant voltage curve. For this, you just need a voltmeter, a load resistor of known value, and math. I'd go into more detail, but I'm at a bar in the Indianapolis airport right now, and this whiskey ain't gunna drink itself.
Joe Perez is online now   Reply With Quote
Old 11-07-2014, 02:35 PM   #5
Senior Member
Thread Starter
 
Join Date: Mar 2006
Location: Schwarzenberg, Germany
Posts: 1,497
Total Cats: 81
Default

I ditched the idea of sharing the sensors - so I guess the pullup to 5v will be fine.
Does a 1k pullup do the trick?

And how do I evaluate the ADC for Tuner Studio for the sensors? I do have the
Specific resistances for the sensors in a spreadsheet, but the inputs in TS are 2 value linear only anyway...
Zaphod is offline   Reply With Quote
Old 11-07-2014, 02:56 PM   #6
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

That's not for the '99 with the Basic MS3, is it?
Reverant is offline   Reply With Quote
Old 11-07-2014, 03:05 PM   #7
Senior Member
Thread Starter
 
Join Date: Mar 2006
Location: Schwarzenberg, Germany
Posts: 1,497
Total Cats: 81
Default

Nope, for my 96 VVT swap MS3X...

The 99 with the MS3Basic is waiting for the ExtremeMS3... hint, hint.... ;-)
Zaphod is offline   Reply With Quote
Old 11-07-2014, 03:08 PM   #8
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Booooo. The Basic MS3 already has 2.49K pullups.

You won't be able to use custom NTC-type thermistor sensors with the MS3. You need to use either a sensor that has the same curve as the CLT or IAT sensor, or use a linear sensor. These usually have a linear 0-300R output.
Reverant is offline   Reply With Quote
Old 11-07-2014, 03:41 PM   #9
Senior Member
Thread Starter
 
Join Date: Mar 2006
Location: Schwarzenberg, Germany
Posts: 1,497
Total Cats: 81
Default

Ah, damn'it
Zaphod is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:53 PM.