Air Density Correction Issues - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-17-2015, 01:07 AM   #1
Newb
Thread Starter
 
Join Date: Jun 2013
Location: San Diego, CA
Posts: 26
Total Cats: -15
Unhappy Air Density Correction Issues

Have read the threads by Brain and others and can,t seem to perfect the curve and seem to be chasing my tail. Has anyone gotten this curve down? I find that my idle AFR after warmup is about 14.5 but by the time I get to work its in the 12.5-13.5 range. Thats temp change from 56F-90F but my cruise afr seems to always be changing aswell from where I want to lean. I get closer and closer but always end up back where I started. Can you guys post up examples of your Correction Curves? Firmware is 3.3.X on a DIYPNP. Any input would really be appreciated! Thanks!
Attached Files
File Type: msq Tune for Sleeping Giant.msq (109.4 KB, 33 views)
96miata is offline   Reply With Quote
Old 03-17-2015, 08:05 AM   #2
Elite Member
 
DNMakinson's Avatar
 
Join Date: Jan 2013
Location: Seneca, SC
Posts: 2,705
Total Cats: 269
Default

Idle gets richer but cruise gets lean? Issue may lie elsewhere. Pick a nominal air temp to set as zero correction. Then, when air is close to that, tune VE table when coolant is above 185*F and WUE is at 100%. Then work on temp related corrections once operating temp settings are dialed in.
DNMakinson is offline   Reply With Quote
Old 03-17-2015, 08:50 AM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

log it.

is it due to enrichments or corrections? for example: is Gair increasing too much as temps increase and causing the rich conditions?
Braineack is offline   Reply With Quote
Old 03-17-2015, 09:01 PM   #4
Newb
Thread Starter
 
Join Date: Jun 2013
Location: San Diego, CA
Posts: 26
Total Cats: -15
Default

Ok so i notice that my WUE has my idle in the 15s which is leaner than warm, but once driving during WUE it runs richer which is expected. The idle gets richer after WUE and then at the end of my log the idle is high 12s low 13s AFR. To me everywhere seems to stay close to my targets except idle with temp changes.
Attached Files
File Type: msq CurrentTune.msq (109.4 KB, 43 views)
96miata is offline   Reply With Quote
Old 03-17-2015, 09:02 PM   #5
Newb
Thread Starter
 
Join Date: Jun 2013
Location: San Diego, CA
Posts: 26
Total Cats: -15
Default

Trying to add log but it says "failed to upload" ?
96miata is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Moroso Air Oil Separator Catch Can Aroundcorner Miata parts for sale/trade 2 10-01-2015 04:20 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM


Tags
diypnp, mat correction, megasquirt

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:45 AM.