Anyone running the "mario" modified 3.1.1 code??? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 04-24-2011, 02:19 AM   #1
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default Anyone running the "mario" modified 3.1.1 code???

If so, how much did you have to adjust your idle PID. I must say that before this code I had my setup dialed in very well. It seldom hung open and idle was very good.

I upgraded to this code because I liked the idea of being able to control idle with a CLT table. People have mentioned that they had to lower their P adn I terms, but I wondering by what percent. I'm able to control my idle pretty well through various temps, but it still seems like it is hunting more than it did on my well tuned 3.1 code.

As is I'm running a P term of 5.1, an I term of 52 and D of 0. This new code has made it nice for cold starts. I don't have to run rich until it warms up.
miatauser884 is offline   Reply With Quote
Old 04-24-2011, 03:23 AM   #2
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

I do. Expect to cut down on P and I by about 50% or more.
Reverant is offline   Reply With Quote
Old 04-24-2011, 06:27 PM   #3
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

Damn, I just had to increase it to get stability. Would this be for boost control and ego as well.
miatauser884 is offline   Reply With Quote
Old 04-24-2011, 06:33 PM   #4
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

IIRC only the idle code has been changed.
Reverant is offline   Reply With Quote
Old 04-24-2011, 06:46 PM   #5
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

I thought Mario had modded both in his version?
miatauser884 is offline   Reply With Quote
Old 04-24-2011, 06:49 PM   #6
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

I didn't check the other two, I was really only interested in the idle part.
Reverant is offline   Reply With Quote
Old 04-24-2011, 07:08 PM   #7
Senior Member
iTrader: (8)
 
Join Date: Jun 2010
Location: Navarre, FL
Posts: 1,127
Total Cats: 39
Default

I only tired the 'new' idle changed one that Ken posted. Works pretty good!

Looking forward to the EGO and boost control changes as well.
aaronc7 is offline   Reply With Quote
Old 04-24-2011, 07:48 PM   #8
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

Now on the idle PID I'm only running P:2.5 I:12

Very nice idle. It was at 15.7:1 800rpm and steady +/- .2 ~ 32.5 kpa

It's much easier to see the changes in the P term now.

I questioned the PID for boost because i did a 25psi pull today and was surprised how steady and flat it was since the last couple of times I noticed it needed to be retuned. I want to wait for all the changes before I head out on the road again to retune since it looks like the PID will change a lot. Right now boost P:16 I:90 D:160
miatauser884 is offline   Reply With Quote
Old 04-25-2011, 07:42 AM   #9
Junior Member
 
Join Date: Jun 2007
Posts: 411
Total Cats: 0
Default

Gonna try the Mario code this week. How did you guys end up setting up the added clt curve/table?
Greg G is offline   Reply With Quote
Old 04-25-2011, 11:50 AM   #10
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

Quote:
Originally Posted by Greg G View Post
Gonna try the Mario code this week. How did you guys end up setting up the added clt curve/table?
Mke your PWM duty table the same as your PWM cranking duty table. Then start the car. Adjust the PWM duty table at the the current temp until your idle is where you want it. It works fantastic. I found that I had to lower my values.

F idle PWM
80 49.2
99 44.9
147.5 34.4
196 32.0
miatauser884 is offline   Reply With Quote
Old 04-25-2011, 08:07 PM   #11
Junior Member
 
Join Date: Jun 2007
Posts: 411
Total Cats: 0
Default

Thanks! Does the value at 196F equal the value of the minimum duty for the idle valve?
Greg G is offline   Reply With Quote
Old 04-25-2011, 08:23 PM   #12
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default



not sure about that. make sure u pay attention to the fact that your max value in pwm duty will change your wue max value to the same. i just realized this after autotuning. looked down and wondere why i still had 6% wue being added. max value was moved to 196 degrees. either move your max duty value to where u want wue to hit 100%. not sure if this is a bug
miatauser884 is offline   Reply With Quote
Old 04-25-2011, 09:25 PM   #13
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

that's just the table the idle valve runs at during/after cranking..then the PID kicks in.
Braineack is online now   Reply With Quote
Old 04-25-2011, 11:37 PM   #14
Junior Member
 
Join Date: Jun 2007
Posts: 411
Total Cats: 0
Default

Which file do I need to edit to fix the 1000% EGO correction in TunerStudio?
Greg G is offline   Reply With Quote
Old 04-25-2011, 11:42 PM   #15
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

Download the ms2extra.ini file in marios thread, and point tunerstudio to it in the project properties
miatauser884 is offline   Reply With Quote
Old 04-26-2011, 01:16 AM   #16
Junior Member
 
Join Date: Jun 2007
Posts: 411
Total Cats: 0
Default

Arggg. Turns out I downloaded it but forgot to transfer to the 'mario' folder. Fixed now.

I must say, idle is noticeably smoother in this version. I can't place my finger on exactly why just yet, but it is

It messed up my warmup enrichments though! I was wondering why I was a bit rich at 180F, turns out it was set for 115% at that temp. Which brings up my next question- at what temp should WUE be at 100%?
Greg G is offline   Reply With Quote
Old 04-26-2011, 08:42 AM   #17
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

I have my WME set to 100% at 150 degrees. I ended up changing my WUE curve so that it is 100% at 150 degrees and I still have a point at 196. This allows me a 196 point in the PWM duty table to adjust idle when hot.
miatauser884 is offline   Reply With Quote
Old 04-27-2011, 09:33 AM   #18
Junior Member
 
Join Date: Jun 2007
Posts: 411
Total Cats: 0
Default

OK I got everything working nicely, except the car is a real dog when warming up. Nice and smooth above 130F, but below...very rough sounding.

Name:  427badwarmup.png
Views: 2
Size:  77.6 KB

Here are the warmup settings
Name:  427warmup.png
Views: 1
Size:  104.1 KB

Suggestions?
Attached Files
File Type: msl 2011-04-27_15.46.36.msl (1.74 MB, 74 views)
File Type: msq 2011-04-27_20.05.17.msq (79.6 KB, 54 views)
Greg G is offline   Reply With Quote
Old 04-27-2011, 10:17 AM   #19
Senior Member
 
Join Date: Mar 2006
Location: Schwarzenberg, Germany
Posts: 1,497
Total Cats: 81
Default

What the heck is your spark advance doing back there?
Zaphod is offline   Reply With Quote
Old 04-27-2011, 10:28 AM   #20
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

This is probably retarded, but how do you get 4 traces pr window in your log up there?
miatauser884 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:09 PM.