Built my first Megasquirt - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 07-18-2007, 11:29 AM   #21
y8s
2 Props,3 Dildos,& 1 Cat
iTrader: (8)
 
y8s's Avatar
 
Join Date: Jun 2005
Location: Fake Virginia
Posts: 19,038
Total Cats: 407
Default

dude, scott, are you soldering from the top (component side)??
y8s is offline   Reply With Quote
Old 07-18-2007, 11:35 AM   #22
Boost Czar
Thread Starter
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,865
Total Cats: 1,790
Default

Quote:
Originally Posted by y8s View Post
dude, scott, are you soldering from the top (component side)??
For me, on the reistors it was easier up top...pretty much a mix of both.

Quote:
Originally Posted by miatamania View Post
You want to make a PnP harness for me and tell me how to do it so I don't have to...
spend $109 at boomslang.us and solder your db37 harness into that. Then you just gotta leave out the wires for the IAT, FP, O2, & EBC.
Braineack is offline   Reply With Quote
Old 07-18-2007, 06:41 PM   #23
Senior Member
iTrader: (4)
 
Join Date: May 2007
Location: Ontario
Posts: 790
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post

spend $109 at boomslang.us and solder your db37 harness into that. Then you just gotta leave out the wires for the IAT, FP, O2, & EBC.
Or spend X amount on a stock ecu, cut/desolder the connector and wire a male db37 connector to that.

I spent something like 30$ on my pnp harness, but I got the ecu supercheap.
reddroptop is offline   Reply With Quote
Old 07-18-2007, 06:44 PM   #24
Boost Czar
Thread Starter
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,865
Total Cats: 1,790
Default

acutally not a bad idea....I've been trying to find a source on the connectors...i know they are very common, but havent tried hard enough yet.
Braineack is offline   Reply With Quote
Old 07-18-2007, 07:06 PM   #25
Senior Member
iTrader: (4)
 
Join Date: May 2007
Location: Ontario
Posts: 790
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
acutally not a bad idea....I've been trying to find a source on the connectors...i know they are very common, but havent tried hard enough yet.
They are ******* terrible is what they are, I have never found an ecu more difficult to pull then the stupid POS miata ecu. The connectors SUCK. I have been having issues with my megasquirt so I have pulled it in and out 10+ times, it doesn't get any easier with time.

Blown stock ecu's are the best price wise for connectors, but they don't come up for sale all that often.
reddroptop is offline   Reply With Quote
Old 07-18-2007, 07:36 PM   #26
Junior Member
iTrader: (2)
 
Join Date: Jul 2006
Posts: 482
Total Cats: 0
Default

ya. the easier the better for me...just waiting on my 550cc injectors.
rappadan is offline   Reply With Quote
Old 07-18-2007, 07:45 PM   #27
Boost Czar
Thread Starter
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,865
Total Cats: 1,790
Default

mine sits where the passenger puts his feet, takes about 30 secs to access. 90-93 that is.
Braineack is offline   Reply With Quote
Old 07-18-2007, 07:53 PM   #28
Senior Member
iTrader: (4)
 
Join Date: May 2007
Location: Ontario
Posts: 790
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
mine sits where the passenger puts his feet, takes about 30 secs to access. 90-93 that is.
It is easy to get to. Just the connectors blow.
reddroptop is offline   Reply With Quote
Old 07-18-2007, 08:47 PM   #29
Senior Member
iTrader: (3)
 
Join Date: Feb 2006
Location: Centennial, CO
Posts: 672
Total Cats: 20
Default

https://www.miataturbo.net/forums/sh...97&postcount=4

I looked around and it turns out turbo 2nd gen DSM's have identical ECU connections, might be easier to find one of those in a junkyard (it is a DSM!). Other than that check this thread:

http://forum.miata.net/vb/showthread.php?t=235701

Quick question though, Braineack, did you build that MS based on Kags mods to the board, or DIYAutoTune? I haven't totally completed mine yet, was planning on following DIYAutoTune, but I have heard some people have had issues following it.....
karter74 is offline   Reply With Quote
Old 07-18-2007, 09:17 PM   #30
y8s
2 Props,3 Dildos,& 1 Cat
iTrader: (8)
 
y8s's Avatar
 
Join Date: Jun 2005
Location: Fake Virginia
Posts: 19,038
Total Cats: 407
Default

onlinecomponents.com

I got sum for my 01 there. whoopie.
y8s is offline   Reply With Quote
Old 07-18-2007, 09:48 PM   #31
Senior Member
iTrader: (3)
 
Join Date: Feb 2006
Location: Centennial, CO
Posts: 672
Total Cats: 20
Default

Quote:
Originally Posted by y8s View Post
onlinecomponents.com

I got sum for my 01 there. whoopie.
I wanted to do the same, but they are out of one of the crimp pin sets I need along with one of the connectors. They have an 8 week lead time.......
karter74 is offline   Reply With Quote
Old 07-18-2007, 10:49 PM   #32
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,775
Total Cats: 1,106
Default

Quote:
Originally Posted by karter74 View Post
Quick question though, Braineack, did you build that MS based on Kags mods to the board, or DIYAutoTune? I haven't totally completed mine yet, was planning on following DIYAutoTune, but I have heard some people have had issues following it.....
He is using kags mods. Him and I have tried both DIY and kags and kags work. We have never gotten DIY's to work with the several MS we have tried on.
shuiend is offline   Reply With Quote
Old 07-18-2007, 11:58 PM   #33
Senior Member
iTrader: (3)
 
Join Date: Feb 2006
Location: Centennial, CO
Posts: 672
Total Cats: 20
Default

Interesting, if anyone from DIYAutotune can chime in here and please help with why your tutorial doesn't work........
karter74 is offline   Reply With Quote
Old 07-19-2007, 10:16 AM   #34
Boost Czar
Thread Starter
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,865
Total Cats: 1,790
Default

If you look closely and read the Spark mod, they describe it different from how it's acutally drawn in the diagram...I trust that if you correct it, it will be fine.
Braineack is offline   Reply With Quote
Old 07-20-2007, 12:49 PM   #35
Supporting Vendor
iTrader: (5)
 
Join Date: Jun 2006
Location: Duluth, GA 30097
Posts: 798
Total Cats: 0
Default

Quote:
Originally Posted by karter74 View Post
Interesting, if anyone from DIYAutotune can chime in here and please help with why your tutorial doesn't work........

This is the first I've heard of a report that the mod 'doesn't work'-- I know multiple people are using these docs to run their Miata, and the MSPNP is based on this as well with the ignition mods being schematically identical. There are literally dozens of cars running on this exact setup so this is a bit puzzling to hear.

I just looked over our doc to try and find where our text doesn't match the pictures so I could correct it and I'm having trouble locating that, can someone help me out? I want to make it correct if it's got a mistake, and as clear as possible if it's just a bit confusing somewhere...
FoundSoul is offline   Reply With Quote
Old 07-21-2007, 10:36 PM   #36
Boost Czar
Thread Starter
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,865
Total Cats: 1,790
Default

Jerry, There were a select few on here that had trouble, mine included....I'll PM you about it.

Here's the harness I finished ealier:


Last edited by Braineack; 09-25-2007 at 11:11 AM.
Braineack is offline   Reply With Quote
Old 07-21-2007, 10:40 PM   #37
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

nice job dude.
Ben is offline   Reply With Quote
Old 07-22-2007, 12:09 AM   #38
Boost Czar
Thread Starter
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,865
Total Cats: 1,790
Default

Jerry,

I think i figured it out.

Since I didn't build my first MS, I wasnt sure exactly how it was wired, based off your writeup...it was said to have been step by step off your instructions. and I never got spark when it was wired with the resistors off the LEDs.

But I would get spark off r29 and r26. But poking around with a multimeter I figured it out. q8 and q6 are pulled, so that's why. If they were put back and wired like your writeup, it should get spark.

Although I do believe spark 1 and 2 had to be reversed as well.
Braineack is offline   Reply With Quote
Old 07-22-2007, 11:12 PM   #39
Supporting Vendor
iTrader: (5)
 
Join Date: Jun 2006
Location: Duluth, GA 30097
Posts: 798
Total Cats: 0
Default

That's probably it then...

for anyone modding their ECU for use with a Miata ignition system... Kags mods and my mods both work well, but they don't mix well.... you want to pick one or the other and follow that doc exclusively, and also note that the spark output setting and likely the dwell settings are going to be different (for instance, I've heard of people burning coils with more than 2.5ms dwell on 1.8 coils with kags mods, and I'm running something like 5ms dwell on a 95 with my mods to match the stock ECU waveforms as verified with a scope, car is rock solid reliable)
FoundSoul is offline   Reply With Quote
Old 07-23-2007, 12:12 AM   #40
Elite Member
iTrader: (12)
 
Join Date: Aug 2006
Location: Central-ish VA
Posts: 4,449
Total Cats: 16
Default

well, that would fully explain why i could never get the diy mod to work.

on another note, aka hijack, can I buy the transistor that is on q6 at radioshack? I'm building an MS2 setup for my upcoming setup and am going to add an additional led circuit to run full sequential COP ign. I just don't wanna have to order a bunch of them and wait if I can pick them up at radioshack and get a few.
neogenesis2004 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Any pnp megasquirt for 2001 Big_gumby WTB 0 09-30-2015 04:34 PM
1996 Turbo Build Goldwar DIY Turbo Discussion 2 09-29-2015 10:20 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:38 AM.