A/C stuck on - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-10-2012, 07:31 PM   #1
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default A/C stuck on

I was f-ing with my idle it seemed to get worse all of a sudden the other day staying below 600rpm and dieing all the time. So I am trying to fix it in TS when I notice both my fans are running. I slaped my self and checked the control it was off. I clicked the button a couple time then check fan still running. Turn off everything no fan nothing. Still extra radiator fan is on so I looked at the pulley and the clutch is engaged so the condensor is running.

Any idea how to fix.
What adjustment in MS diypnp affect ac?
90 Turbo is offline   Reply With Quote
Old 02-10-2012, 07:44 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

did u build the diypnp with gslender idle up firmware?
Braineack is offline   Reply With Quote
Old 02-10-2012, 09:40 PM   #3
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

No I used the regular firmware. 3.2.1

You said build with gslender. Is that something I have to build in I figured when summer got here I would change firmware.

Anyway it has only been doing this for a short time.
90 Turbo is offline   Reply With Quote
Old 02-10-2012, 10:07 PM   #4
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

well I checked now that its dark and the a/c switch is working the blue light goes off. Both fans are running even on the cold engine. would the extra radiator fan for the ac come one if the ac clutch got stuck? I would guess not.
90 Turbo is offline   Reply With Quote
Old 02-11-2012, 12:25 AM   #5
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

Well I reloaded the firm ware and the base tune and still the fans come on as soon as the key is turned to on.

The ac runs all the time.

I know for a fact it has not always been this way. Just last week I was trying to get the idle right and turning on the ac to see if the idle setting could take it with out stalling. THe on off worked fine then of course the car would almost die with ac on but the ac on off worked fine.
I am lost.
90 Turbo is offline   Reply With Quote
Old 02-11-2012, 12:09 PM   #6
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

Does anyone know if I want to use the special firmware I know I have to rewire ms
The suggested is
You'd wiring 1Q to Input 1 IN, The input 1 OUT to PE1.
Then from PAO to 1J.

but I used pa0 for ebc can I just use another output?
90 Turbo is offline   Reply With Quote
Old 02-11-2012, 03:06 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

It is currently 1Q to IN then OUT to 1J?

Possible that transistor is bad, or you soldered the legs together.
Braineack is offline   Reply With Quote
Old 02-11-2012, 03:37 PM   #8
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

thanks Brain maybe the transistor is bad. Both fans start as soon as I turn the car on. Would a bad transistor there make that happen?
I though also it could be short in the switch but then turning the whole system off should take the switch out of the loop?
90 Turbo is offline   Reply With Quote
Old 02-11-2012, 03:55 PM   #9
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

that's what I'd check, that circuit...i bet you have a big solder blob that's connecting 2 of the three pins.
Braineack is offline   Reply With Quote
Old 02-11-2012, 04:24 PM   #10
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

Ok I have been going thru the FSM and can not find out where the ac relay is. it tell how to test it but not where it is.
90 Turbo is offline   Reply With Quote
Old 02-11-2012, 04:25 PM   #11
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

Big soldier glob.
Why would this just now show up?

anyway I will look.
90 Turbo is offline   Reply With Quote
Old 02-11-2012, 04:28 PM   #12
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

a/c relay is near throttle body, kinda where the hood prop connects.


I bet if you just connect 1Q and 1J together, without going through the Input IN and OUT, your issue will go away.
Braineack is offline   Reply With Quote
Old 02-11-2012, 04:38 PM   #13
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

just disconnected the wire to the clutch at least now the ac compresor is not turning all the time while I figure it out. Its winter after all I have a couple of months.


Thanks for the help Brain.
I think i will just rewire diypnp for the special firmware. Brain do you think that will resolve the issue if it is soldier related assuming of course I do it correctly.

So what do i do with the PAO already in use by ebc?
I could desoldier that but seems un necessary if another port will do?
90 Turbo is offline   Reply With Quote
Old 02-11-2012, 05:26 PM   #14
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

Well both fans on all the time = no heat in winter.
90 Turbo is offline   Reply With Quote
Old 02-13-2012, 11:32 AM   #15
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

Would a soldier glob make both fans run all the time?
90 Turbo is offline   Reply With Quote
Old 02-13-2012, 11:39 AM   #16
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Who is this guy who lives 10-miles away from me with a turbo Miata on MS who I've never met?
hustler is offline   Reply With Quote
Old 02-13-2012, 12:26 PM   #17
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

Quote:
Originally Posted by 90 Turbo View Post
Would a soldier glob make both fans run all the time?
come on dude. yes.

General 90-93 that everyone that owns a miata should know: The main fan comes on when the a/c relay is activated.

Therefore: If the transistor on INPUT 1 is what ultimately controls the a/c relay, and if you've built it in such a manner that the transistor is constantly grounded and sending a ground signal to 1j, then the a/c compressor, a/c fan, and main fan will constantly be activated.
Braineack is offline   Reply With Quote
Old 02-13-2012, 02:15 PM   #18
Elite Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Granbury, TX
Posts: 6,010
Total Cats: 583
Default

I though soldier globs were only used in Afghanistan. ???
hornetball is offline   Reply With Quote
Old 02-13-2012, 02:18 PM   #19
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

RSGs!
Braineack is offline   Reply With Quote
Old 02-16-2012, 01:38 PM   #20
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

OK I am going to check the MS this weekend. I figured I would wire it for gslender firm ware but I already used PA0 for the ebc can I use another? which ones can I use?
90 Turbo is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM
New here, saying hi, here's what I'm workin with. SuperSneakySecretSquirrel Meet and Greet 5 09-06-2015 09:30 PM
Advanced Engine Dynamix Review (dead oil pump content) itsMikey Insert BS here 0 09-05-2015 03:56 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:09 PM.