car won't idle after new spark plugs - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 07-05-2010, 09:10 AM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2009
Location: maine
Posts: 224
Total Cats: -1
Default car won't idle after new spark plugs

i have a 94 with a diypnp. i swapped out my old plugs for ngk bkr7e copper core. pretty standard on a turbo miata and now my car won't idle. i also put a new set of wires on it also NGK. when i give it a little throttle to keep it running it will pulsate from about 1400 -2000 rpms. All ideas are appreciated.
94blackmx5 is offline   Reply With Quote
Old 07-05-2010, 09:12 AM   #2
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Did you put the plug wires on the correct cylinders?
Reverant is offline   Reply With Quote
Old 07-05-2010, 09:46 AM   #3
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

That or vac leak.
Ben is offline   Reply With Quote
Old 07-05-2010, 10:16 AM   #4
Junior Member
Thread Starter
 
Join Date: Mar 2009
Location: maine
Posts: 224
Total Cats: -1
Default

yes they are on the right cylinders. it could be a vac but i'm not sure how, the only thing that changed was the plugs and wires i'll double check all that when i get home. I will also add that under throttle it is much smoother up to red line with the new plugs. it just won't idle. i was also just thinking that wouldn't it idle high if it had a vacume leak? Mine won't idle at all unless i'm on the gas a little. I did adjust the idle screw with no results.

Last edited by 94blackmx5; 07-05-2010 at 12:07 PM.
94blackmx5 is offline   Reply With Quote
Old 07-05-2010, 12:30 PM   #5
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,775
Total Cats: 1,106
Default

If you switch back to old plugs and wires does it idle fine?
shuiend is offline   Reply With Quote
Old 07-05-2010, 01:03 PM   #6
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Try unplugging and replugging the wires one by one while it's idling. See if removing one or more of the wires doesn't affect the idle or it it affects it ever so slightly compared to the other wires.
Reverant is offline   Reply With Quote
Old 07-05-2010, 07:19 PM   #7
Junior Member
 
Join Date: Dec 2007
Location: Santa Fe, TX
Posts: 95
Total Cats: 2
Default

Quote:
Originally Posted by Reverant View Post
Try unplugging and replugging the wires one by one while it's idling. See if removing one or more of the wires doesn't affect the idle or it it affects it ever so slightly compared to the other wires.
Be sure to brace your other hand on something grounded to check the insulation on the plug wires..GL



OK edit...i.e. don't touch anything anywhere on the car when you pull plug wires...or you could light yourself up...

A good shock is pretty funny when it happens to someone else, but when you have to do CPR - not so funny...
secretsquirrel is offline   Reply With Quote
Old 07-05-2010, 10:41 PM   #8
Junior Member
Thread Starter
 
Join Date: Mar 2009
Location: maine
Posts: 224
Total Cats: -1
Default

ok so i managed to get it to idle pretty well. i went in to More engine constants and set a target afr of 14.7 now it idles fine. I'm not sure that was the problem but it seems to have fixed it for now.
94blackmx5 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
FS/FT: 03.5 Mazdaspeed Protege leatherface24 Cars for sale/trade 15 10-16-2015 12:35 PM
00/99 IAC into 92 wiring harness AdoboMiata MEGAsquirt 4 09-22-2015 03:32 AM
Mystery Engine Trouble. Halp, mt.net! vehicular General Miata Chat 12 09-14-2015 04:17 PM
VE values too low? compuw22c MEGAsquirt 4 09-12-2015 08:42 PM
Obligatory "N00B" post! D_Breezy Meet and Greet 5 09-08-2015 06:37 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:20 PM.