Datalogging with a Palm...it CAN be done! - Page 3 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 10-15-2007, 07:43 AM   #41
Elite Member
iTrader: (5)
 
Join Date: Oct 2007
Location: Canton, Ga
Posts: 1,707
Total Cats: 19
Default

Quote:
Originally Posted by Splitime View Post
I really need to try and use my Handspring Visor.....
If it works please let us know.
Stealth97 is offline   Reply With Quote
Old 10-17-2007, 05:26 PM   #42
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

PalmLog is running on my TRGPro. Ben, would you mind sharing the PalmLog Environment Setup for the MSPNP? Thx
Ben is offline   Reply With Quote
Old 10-17-2007, 05:52 PM   #43
Elite Member
Thread Starter
iTrader: (5)
 
Atlanta93LE's Avatar
 
Join Date: Sep 2006
Location: Marietta, GA
Posts: 2,198
Total Cats: 1
Default

Sure thing. I'll post up when I'm home tonight and can grab the palm.
Atlanta93LE is offline   Reply With Quote
Old 10-17-2007, 06:09 PM   #44
Elite Member
iTrader: (5)
 
Join Date: Oct 2007
Location: Canton, Ga
Posts: 1,707
Total Cats: 19
Default

I did a little research on the Visor, looks like it has the multi connector, and it talks TTL, not RS-232 so it is probably a no-go. too bad, I love those.
Stealth97 is offline   Reply With Quote
Old 10-17-2007, 06:39 PM   #45
Miotta FTW!
iTrader: (24)
 
Splitime's Avatar
 
Join Date: Jun 2006
Location: Chicagoland, IL
Posts: 4,295
Total Cats: 26
Default

Quote:
Originally Posted by Stealth97 View Post
I did a little research on the Visor, looks like it has the multi connector, and it talks TTL, not RS-232 so it is probably a no-go. too bad, I love those.
Well crap... looks like i have to buy an old palm then.
Splitime is offline   Reply With Quote
Old 10-17-2007, 07:16 PM   #46
Elite Member
iTrader: (5)
 
Join Date: Oct 2007
Location: Canton, Ga
Posts: 1,707
Total Cats: 19
Default

as long as you have it, please try it. The Serial cradle bumps the TTL signal up to RS-232, so it *may* work using that. If you dont want to bother, you can send it to me and I'll play with it on the MSPNP

EDIT:

Nevermind, Looks like one guy on MSEFI got it to work, he had to yank out the TTL signals from the CPU before it went to the RS232 chip.

http://www.msefi.com/viewtopic.php?t=16019

EDIT Again:

After further research, I'm pretty sure this is everything you'd need for the Visor through the MS serial port:

RS-232 Visor Specific Serial cable (or hack a cradle). These have built in chip for TTL/RS232 conversion. This chip needs 5V to operate it, you need a way to power it.

Null modem adapter or swap pins.

I will probably look for a pIIIxe, but something about rocking an old-school VisorPhone appeals to the geek in me.

Last edited by Stealth97; 10-17-2007 at 09:03 PM.
Stealth97 is offline   Reply With Quote
Old 10-17-2007, 08:07 PM   #47
Elite Member
Thread Starter
iTrader: (5)
 
Atlanta93LE's Avatar
 
Join Date: Sep 2006
Location: Marietta, GA
Posts: 2,198
Total Cats: 1
Default

Here is my PalmLog Environment Setup, as requested. It works for me on my MSPNP MM9093, but I cannot guarantee the values. In fact, I can't remember how I got all of them. I did a bit of reading on the msefi forum.

MAP-Off: 9.0
Map-Sc: 0.984
C-Bias: 2490
A-Bias: 2490
Cool-A: 1.222E-3
Cool-B: 2.776E-4
Cool-C: 4.196E-8
Air-A: 1.506E-3
Air-B: 2.250E-4
Air-C: 1.247E-7
WB-Off: 10.00
WB-Sc: 2.00
RTU Char: R
Bytes 39

I have my "boost in psi," "Fahr," and "diywb" boxes clicked; I am using the Techedge diywb.
Atlanta93LE is offline   Reply With Quote
Old 10-17-2007, 08:20 PM   #48
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Wow, thanks, I'm glad I asked you for yours. My values were different. I used the therm and mat factor values from the config file that was WITH AFM, not the values from the WITHOUT AFM file. Confused me for a minute, but I'm glad I was able to see your values and catch my error.

Still working on the MAP scaling... I think I have it nailed. Haven't built the null modem adaptor yet to check it though.

I think my values will be the same as yours, except for the MAP sensor calibration:
MAP-Off: 20
Map-Sc: 1.490
Not 100% on those values yet though.
Ben is offline   Reply With Quote
Old 10-18-2007, 09:49 AM   #49
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

So I made a null modem adaptor out of a pair of DB9 ends I had. And guess what. Without looking, I made a M-->F adaptor, like what every other device gets... And this piece of crap needs a M-->M adaptor. I don't have any more male DB9 terminals.
Ben is offline   Reply With Quote
Old 10-18-2007, 09:53 AM   #50
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Bum deal. Radioshit has more DB9 terminals if you need them.
cjernigan is offline   Reply With Quote
Old 10-18-2007, 09:56 AM   #51
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

just waiting on traffic to die down.
Ben is offline   Reply With Quote
Old 10-18-2007, 10:07 AM   #52
Elite Member
Thread Starter
iTrader: (5)
 
Atlanta93LE's Avatar
 
Join Date: Sep 2006
Location: Marietta, GA
Posts: 2,198
Total Cats: 1
Default

Quote:
Originally Posted by Ben View Post
So I made a null modem adaptor out of a pair of DB9 ends I had. And guess what. Without looking, I made a M-->F adaptor, like what every other device gets... And this piece of crap needs a M-->M adaptor. I don't have any more male DB9 terminals.
Atlanta93LE is offline   Reply With Quote
Old 10-18-2007, 10:11 AM   #53
Elite Member
Thread Starter
iTrader: (5)
 
Atlanta93LE's Avatar
 
Join Date: Sep 2006
Location: Marietta, GA
Posts: 2,198
Total Cats: 1
Default

btw: Have you looked at how the palm transfers a datalog to the computer? The data is sent via batch mode to MLV while essentially "synchronizing" the palm via PalmLog. I'm not so sure you'll be able to just pop the CF card out of the palm and read the datalog file from the computer. You'll have to figure out a way to translate the raw palm file to datalog file on the computer (replacing the palmlog synch. built-in translation).
Atlanta93LE is offline   Reply With Quote
Old 10-18-2007, 08:14 PM   #54
Elite Member
iTrader: (5)
 
Join Date: Oct 2007
Location: Canton, Ga
Posts: 1,707
Total Cats: 19
Default

woot. I just picked up a IIIxe off ebay for $6.00. Cant wait to give it a shot.
Stealth97 is offline   Reply With Quote
Old 10-23-2007, 11:12 AM   #55
Junior Member
iTrader: (4)
 
Join Date: Jul 2007
Location: Indianapolis, IN
Posts: 113
Total Cats: 0
Default

Started doing this myself recently. Freaking loving it.

However, I'm unsure on the AFR readings at the moment. For the LC-1 what would the WB-Off, WB-Sc settings (or any other settings) be for its default setup? Right now I just have "Other WB" selected with WB-Off: 10.00, WB-Sc: 2.00. The readings seem close they seem but perhaps a little rich.

Any ideas?
sotaku is offline   Reply With Quote
Old 10-23-2007, 03:11 PM   #56
Miotta FTW!
iTrader: (24)
 
Splitime's Avatar
 
Join Date: Jun 2006
Location: Chicagoland, IL
Posts: 4,295
Total Cats: 26
Default

Fun... have a winning bid on a lot of 3 palm m105s... with docs and nother junk... and I find out that palmlog isn't written to support the USB mod to MS.

Blah.
Splitime is offline   Reply With Quote
Old 10-23-2007, 03:52 PM   #57
Junior Member
iTrader: (4)
 
Join Date: Jul 2007
Location: Indianapolis, IN
Posts: 113
Total Cats: 0
Default

Nevermind on my question, got it. Found it in the MSEfi forums.

WB Offset goes from 10 to 7.35
WB Scale goes from 2 to 3.01
(for the LC-1 Analog 2 default set up of 0v = 7.35AFR, 5v = 22.39)
sotaku is offline   Reply With Quote
Old 10-23-2007, 03:59 PM   #58
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

mmm... is that how you have yours set? I'd configure it for 10:1 5V - 20:1 0V
and get more useful resolution out of it.
Ben is offline   Reply With Quote
Old 10-23-2007, 04:29 PM   #59
Junior Member
iTrader: (4)
 
Join Date: Jul 2007
Location: Indianapolis, IN
Posts: 113
Total Cats: 0
Default

Hmmm, really... I suppose that'd be true, since I'm not running that rich, or that lean.

I may just do that this evening.

And do you mean 10:1 0V - 20:1 5V? Or am I just not understanding that right?
sotaku is offline   Reply With Quote
Old 10-23-2007, 04:33 PM   #60
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

yeah 5V @ 20:1, sorry, my mind was somewhere else when I was finishing hte message... because when I was reading your post, I realized the solution to my map sensor scale problem.
Ben is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
1st Datalog levnubhin MEGAsquirt 6 06-03-2008 10:27 AM
Any AE tuning tips from you gurus? ThePass MEGAsquirt 11 05-21-2008 04:00 PM
Questions on my approach to tuning EMB 924_nick E-Manage 0 09-03-2007 01:45 PM
Datalogging Bandwagon Stripes DIY Turbo Discussion 3 05-11-2007 04:53 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:22 AM.