Ds1's Horrible ECU Tuning Thread - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 01-13-2014, 02:05 PM   #1
Ds1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Feb 2011
Posts: 283
Total Cats: -31
Default Ds1's Horrible ECU Tuning Thread

Hey all,

So just before Christmas I got my turbo install all done, and got the car up and running. I'm having a lot of trouble with the idle on the car (seemingly only when its warm?). It hunts, fluctuates like crazy, and dies if I take my foot of the accelerator. I'm new to MegaSquirt, and new to tuning, and I can't figure out if it is just settings or what.

Here is a post in the build thread with Pics and Video: https://www.miataturbo.net/build-thr...5/#post1080227

I am going up to the shop right now to work on the car and diagnose it more. I also bought an automatic throttle body to do the 1.6 TPS to VTPS conversion, as I have read that could be a big part of the issue (at least the stalling).

The car is a '92 1.6, with Greddy-based turbo setup that now includes an intercooler, MAF delete using GM IAT, BOV, and the DIY Autotune EBC solenoid. The ECU is a Brain-built MS3X. Injectors are RX7 460cc's. Wideband is Innovate MTX-L.

Any ideas what this could be? I will be checking for vacuum leaks today. I will also record the setting file and post it later so you can see the idle settings. Right now they are whatever Brain sets (or doesn't set) them to. Thanks!
Ds1 is offline   Reply With Quote
Old 01-14-2014, 10:36 AM   #2
Elite Member
iTrader: (2)
 
Join Date: Aug 2012
Location: Indianapolis
Posts: 3,325
Total Cats: 235
Default

Quote:
Originally Posted by Ds1 View Post
Right now they are whatever Brain sets (or doesn't set) them to. Thanks!
I don't want to sound like too much of a dick but...

How about tune your idle, then if it's still bad make a thread. Instructions on msextra or look at the tens of threads about it here.
thenuge26 is offline   Reply With Quote
Old 01-14-2014, 10:42 AM   #3
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

Tune it
18psi is offline   Reply With Quote
Old 01-14-2014, 10:42 AM   #4
Ds1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Feb 2011
Posts: 283
Total Cats: -31
Default

Yeah I was working on finding that reading yesterday. We made some progress, and I think I've determined (from home) that the idle needs more fuel at the warmer side of the warm up curve. My AFR's start to creep up, but thats when it will begin to oscillate and hunt.

I'm going to try that today and go from there. I also just bought TunerStudio with the new auto-tune warmup, so that should be a big help
Ds1 is offline   Reply With Quote
Old 01-14-2014, 05:48 PM   #5
Ds1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Feb 2011
Posts: 283
Total Cats: -31
Default

Okay, tuned the warmup a little. It's much better already, but it has a tough time getting off the warmup curve and idling normally. It will start out rich, end up closer to where it needs to be (13-14) then hit 15 for a second, then get worse and worse in fluctuations until it dies.
Ds1 is offline   Reply With Quote
Old 01-14-2014, 06:09 PM   #6
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

keep tuning it
18psi is offline   Reply With Quote
Old 01-14-2014, 07:25 PM   #7
Junior Member
iTrader: (1)
 
Join Date: May 2009
Location: TN
Posts: 328
Total Cats: 4
Default

Trying to use the binary 1.6 tps is part of the problem. Everything in your tune that uses throttle position will **** with you.
southernmx5 is offline   Reply With Quote
Old 01-14-2014, 08:03 PM   #8
Ds1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Feb 2011
Posts: 283
Total Cats: -31
Default

I locked the timing at 11, made the entire corner of the Fuel table 40.0, and messed with some other settings like the IACV frequencies and stuff and got it to idle when warm. Relatively roughly.

Problem is I can't change anything even the slightest bit without it going into isolation again.

I don't know where to go from here. I've tried every thread, every forum, every article. Fricken everything. And literally two days of time.
Ds1 is offline   Reply With Quote
Old 01-14-2014, 08:05 PM   #9
Junior Member
iTrader: (1)
 
Join Date: May 2009
Location: TN
Posts: 328
Total Cats: 4
Default

Did you unplug the stock tps yet?
southernmx5 is offline   Reply With Quote
Old 01-14-2014, 08:05 PM   #10
Ds1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Feb 2011
Posts: 283
Total Cats: -31
Default

Quote:
Originally Posted by southernmx5 View Post
Trying to use the binary 1.6 tps is part of the problem. Everything in your tune that uses throttle position will **** with you.
I've heard about this. I'm working on trying to figure out how to hook up my automatic throttle body but haven't found definite wiring.

Could this be a big issue, even on idle when using literally NO throttle at all?
Ds1 is offline   Reply With Quote
Old 01-14-2014, 09:25 PM   #11
Ds1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Feb 2011
Posts: 283
Total Cats: -31
Default

Quote:
Originally Posted by southernmx5 View Post
Did you unplug the stock tps yet?
Just.... Unplug it?
Ds1 is offline   Reply With Quote
Old 03-28-2014, 12:27 AM   #12
Ds1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Feb 2011
Posts: 283
Total Cats: -31
Default

I'm back to this project now and have posted the MSQ here: https://www.miataturbo.net/build-thr...5/#post1115803

I still have not unplugged or changed the VTPS.
Ds1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:33 PM.