Excess electromagnetic interference? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 10-16-2012, 09:13 PM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2011
Posts: 119
Total Cats: 1
Default Excess electromagnetic interference?

It seems my car emits a lot of electromagnetic interference. My radio sometimes has an RPM-based intereference through the antenna. My DIYPNP kept disconnecting randomly and during WOT so I replaced the USB cord with a serial extension cable which solved that. I also have a lot of noise in my CLT signal (the sensor is right next to the coils) and AFR (the signal cable goes above the transmission tunnel, so it's acting like an antenna) but not much noise in the MAT signal (which stays away from the coils).

Is this common? I'm thinking maybe the coils might be arcing to something but I don't want to replace it unless I'm sure that's the issue (I already replaced the spark plug wires for an unrelated reason) Is there any good way to shield the coils to send any EMI to a ground somewhere or is it likely something wrong with the coils?
event is offline   Reply With Quote
Old 10-16-2012, 09:24 PM   #2
Elite Member
iTrader: (10)
 
soviet's Avatar
 
Join Date: Jan 2010
Location: VA
Posts: 3,519
Total Cats: 259
Default

wat.

I mean, yes, it's a very common issue, just wear a tinfoil hat when you drive.
soviet is offline   Reply With Quote
Old 10-16-2012, 09:27 PM   #3
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2011
Posts: 119
Total Cats: 1
Default

Quote:
Originally Posted by soviet View Post
wat.

I mean, yes, it's a very common issue, just wear a tinfoil hat when you drive.
Other folks' logs don't seem to have much noise in the AFR or CLT readings. I know it could be a signal ground issue, but I couldn't even get the laptop to stay connected with a shortest USB cable I had.
event is offline   Reply With Quote
Old 10-17-2012, 12:39 AM   #4
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

What plug wires?
JasonC SBB is offline   Reply With Quote
Old 10-17-2012, 02:33 AM   #5
Senior Member
iTrader: (3)
 
Join Date: Jul 2011
Location: STL
Posts: 528
Total Cats: 24
Default

resistor-less plugs?
midpack is offline   Reply With Quote
Old 10-17-2012, 02:56 AM   #6
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,441
Total Cats: 198
Default

I've had this issue on two different cars - both had low impedance injectors, and the DIYPNP is not compatible with these anyway.
Reverant is offline   Reply With Quote
Old 10-17-2012, 09:54 AM   #7
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2011
Posts: 119
Total Cats: 1
Default

Quote:
Originally Posted by midpack View Post
resistor-less plugs?
I'm running RX-8 injectors and Bosch Platinum Spark Plugs. I don't know how to visually verify that these have resistors in them so I searched them and found a resistance of 5kohm. I'm assuming these classify as resistor plugs. I had never even heard of resistor-less plugs until trying to search out my problem.
event is offline   Reply With Quote
Old 10-17-2012, 04:33 PM   #8
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

In general you don't want signal wires running near the plug wires or coils.
Especially signals that move quickly (e.g. TPS, as opposed to CLT)
JasonC SBB is offline   Reply With Quote
Old 10-17-2012, 05:26 PM   #9
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2011
Posts: 119
Total Cats: 1
Default

Quote:
Originally Posted by JasonC SBB View Post
In general you don't want signal wires running near the plug wires or coils.
Especially signals that move quickly (e.g. TPS, as opposed to CLT)
I guess I'll consider making an actual sheilded cable to take wires from the drivers side to the mega squirt. I'm not too worried about CLT.
event is offline   Reply With Quote
Old 10-17-2012, 08:09 PM   #10
Senior Member
iTrader: (3)
 
Join Date: Jul 2011
Location: STL
Posts: 528
Total Cats: 24
Default

Quote:
Originally Posted by event View Post
I'm running RX-8 injectors and Bosch Platinum Spark Plugs. I don't know how to visually verify that these have resistors in them so I searched them and found a resistance of 5kohm. I'm assuming these classify as resistor plugs. I had never even heard of resistor-less plugs until trying to search out my problem.
Something like this. Don't think Bosch makes any but if you look the part number up it should say.
midpack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
Advanced Engine Dynamix Review (dead oil pump content) itsMikey Insert BS here 0 09-05-2015 03:56 PM
949 Racing Supermiata Crossflow Radiator (NA/NB fitment version) thumpetto007 General Miata Chat 0 08-30-2015 07:17 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:19 AM.