Failed Firmware Upgrade - How Bolloxed Am I? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-22-2007, 01:51 PM   #1
Newb
Thread Starter
iTrader: (1)
 
Join Date: Feb 2006
Posts: 21
Total Cats: 0
Default Failed Firmware Upgrade - How Bolloxed Am I?

After reading the recent thread on using HiRes code on a MSPNP, I thought I'd try loading it on my 1991 1.6 running a BBR Turbo setup. When I tried to load the code provided by Saboteur it came up with Download Failed - Expected Response "Boot>" but received this "".

I then thought I'd better reload my existing code but the DOS batch file got terminated whilst it was flashing the chip. Now when I try to connect to the MSPNP Megatune shows this message -

Controller Code version does not match signature in MSnS-extra.ini (See audit.log for where the above file was found) - Expected "MSnS-extra format 029q******** (found in .ini file) Received "S - what???Boot>" (from Controller) - Table corruption may occur, this is usually a very serious problem. Terminate Megatune now.

So megatune can't communicate with the PNP and when I turn the ignition on (it wont start anyway) I can't hear the fuel pump priming.

So really my questions are -

How do I get out of this (install new chip?)
How do I upgrade to HiRes once I am fixed (in nice simple intructions)
&
Am I the only tit that has ever done this?

Time for a sit down and a beer......

Thanks.

Bob.
bbrbob is offline   Reply With Quote
Old 12-22-2007, 02:00 PM   #2
I'm Miserable!
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

is your boot jumper still installed?
bryantaylor is offline   Reply With Quote
Old 12-22-2007, 02:08 PM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

he didnt use a boot jumped when he flashed....so it failed.
Braineack is offline   Reply With Quote
Old 12-22-2007, 02:24 PM   #4
Elite Member
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default

He shouldn't need the boot jumper on the PnP as it's the extra code? or have DIY done something different that necessitates it's use?

either way it's not screwd the OP just needs to fit the boot jumper and load the code as per normal.
richyvrlimited is offline   Reply With Quote
Old 12-22-2007, 05:33 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

well, it's looking for a boost jumper after he completely erased the existing firmware.
Braineack is offline   Reply With Quote
Old 12-27-2007, 11:51 AM   #6
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

I'd say try the boot jumper first - often a reflash gone wrong can require using a boot jumper.
Matt Cramer is offline   Reply With Quote
Old 12-28-2007, 09:40 AM   #7
Newb
Thread Starter
iTrader: (1)
 
Join Date: Feb 2006
Posts: 21
Total Cats: 0
Default

Thank you everyone!! I improvised a boot jumper using a wire, re-flashed and it's now working OK. I really thought I'd fried something there...

Bob.
bbrbob is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
In need of base map for stock 1997 brandonbkd MEGAsquirt 0 09-29-2015 12:52 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:27 AM.