fan always on - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 10-13-2009, 10:28 AM   #1
Newb
Thread Starter
 
Join Date: Feb 2009
Posts: 3
Total Cats: 0
Question fan always on

Hello everyone,

I've megasquirted my N/A miata (come from canada 1990) according to wiki of miataturbo (HR10g code) and modified my board for fan control.
I've used a 2N2222A like described here: datasheet 2N2222A.

My issue is the following: when I switch on my msquirt fan is turning on.
I've modified temperature for
fan on: 78C
fan off: 75C

my setup:



I've checked pin of transistor linked to JS0 through a 1K resistor and I always have a 0.5mV. If I have a 0.5mV at Base pin it's logical to have my fan switch on (correct me if I'm wrong!). But I don't understand why I have this voltage since I swith on with my key.

To resume: I don't understand why my fan is always on!!

Thanks for your help!

Romano
romano is offline   Reply With Quote
Old 10-13-2009, 10:51 AM   #2
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,264
Total Cats: 51
Default

It should send a 5 volt signal to switch the fan on; 0.5 mV is an off signal.
Matt Cramer is offline   Reply With Quote
Old 10-13-2009, 11:22 AM   #3
Newb
Thread Starter
 
Join Date: Feb 2009
Posts: 3
Total Cats: 0
Default

Hello Matt,

You said that a 0.5mV from JS0 is an off signal?

ok but if it's an off signal why my fan is on?

That the thing I don't understand.

Romano.
romano is offline   Reply With Quote
Old 10-13-2009, 11:32 AM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,838
Total Cats: 1,787
Default

romano, RHD miata?
Braineack is offline   Reply With Quote
Old 10-13-2009, 11:50 AM   #5
Newb
Thread Starter
 
Join Date: Feb 2009
Posts: 3
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
romano, RHD miata?
Hello Braineack,

no it's a LHD. Steering wheel is on the left side of car.
I don't live in UK or JAPAN but in FRANCE!
My miata is a canadian one.

see:

Last edited by romano; 10-13-2009 at 11:58 AM. Reason: picture added
romano is offline   Reply With Quote
Old 10-14-2009, 12:03 PM   #6
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,264
Total Cats: 51
Default

Sounds like your transistor is damaged.
Matt Cramer is offline   Reply With Quote
Old 10-15-2009, 04:31 AM   #7
DXO
Junior Member
iTrader: (2)
 
Join Date: Jul 2008
Location: Kannapolis, NC
Posts: 229
Total Cats: 1
Default

Mine recently started doing this, about 2 months after having my MS out. I've just put it on the back burner for when I pull the MS out again. Figured it may have been a firmware problem. I've not had any problems with warmup till today, 45* out.
DXO is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Left over turbo build parts gdoehl Miata parts for sale/trade 16 10-01-2015 10:42 AM
Help multi issues here! ReallyRottenTurbo MEGAsquirt 4 09-22-2015 01:49 PM
Interpreting Deatchwerks Dead Times from Battery Wizard compuw22c MEGAsquirt 0 09-14-2015 07:08 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:36 PM.