Fan VSS shutoff not working on MS3x (JimStim) - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-31-2014, 06:22 AM   #1
Newb
Thread Starter
 
Join Date: Mar 2012
Location: Austria
Posts: 15
Total Cats: 1
Default Fan VSS shutoff not working on MS3x (JimStim)

Hi,

I finished building my MS3+MS3x and also got the JimStim v1.5 and JimStimX to work as they should.
TunerStudio is telling me that everything is working fine so far, having a rpm reading on the 99-00 setting, and all the other Variables read fine too.
For testing purposes on the JimStim, i set the VSS input to analogue on ADC13 in order to be able to control it via the JimStimX.
The VSS1 gauge on the cluster is reading fine.

I just tried out a few scenarios that I can think of and found out a few things that are not behaving as I think they should be.

1. In Fan Control, I set TPS shutoff to higher than 90% and VSS shutoff to higher than 60mph.
TPS shutoff is working fine as it is supposed to, but I can not get VSS shutoff to work.
When CLT is above the "Fan On Temperature", the Fan Relay is switching on, but it does not deactivate when VSS is higher than 60mph.

2. Same with A/C compressor shutoff. TPS shutoff working, VSS shutoff not working.

3. In Time-based acceleration, I get a "Tune error" when TPS is deccelerating and Decel Fuel Amount is set to e.g. 70.
When Decel Fuel Amount is set to 90, i dont get the error anymore and TPS decel is working fine.

Can you help me why MS3 is behaving as it is?

Thanks, David

edit:
attached my current .msq
Attached Files
File Type: msq CurrentTune.msq (207.0 KB, 52 views)

Last edited by David_G; 03-31-2014 at 08:02 AM.
David_G is offline   Reply With Quote
Old 04-01-2014, 08:57 AM   #2
Newb
Thread Starter
 
Join Date: Mar 2012
Location: Austria
Posts: 15
Total Cats: 1
Default

Ok I just figured out the first 2 points on my own.
I had VSS Input set to Nitrous-In and obviously MS3 didn't like that even though the gauges worked fine.
I set it to Flex-In now and it works perfectly!

Though I still have no idea why I get a Tune Error when Deccel Fuel Amount is set to below 74.

Does anybody have an idea about that? Anybody??
David_G is offline   Reply With Quote
Old 04-01-2014, 09:47 AM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,824
Total Cats: 1,781
Default

yeah you cant use Nitrous-In for VSS.


having your decel fuel that low will cause the worst driving car in history, as soon as you lift your pedal it's going to feel like you slammed on the brakes as well.


use accel-pump.
Braineack is online now   Reply With Quote
Old 04-01-2014, 11:15 AM   #4
Newb
Thread Starter
 
Join Date: Mar 2012
Location: Austria
Posts: 15
Total Cats: 1
Default

Thanks for your reply!

Hm ok its just confusing me because I read that on automatic trans vehicles (which I don't have but anyways) decel fuel amount might be needed to set somewhere in the 70% range.
Seems like the Code is just set up to through an error if under 74%, good to know!

Another question:
I built my MS3 according to WestfieldMX5's Assembly Guide. I wanted to add the ability to use the Fidle Output on the MS3 Motherboard as generic output.
I read through the Assembly Manual at msextra which says to install Q4, Q20, R39, D8 to be able to use Fidle as an programmable output.

I did that, but the corresponding LED is still not lighting up. Do I have to install more parts to make this work? Is it harmful if I turn on MS3 with only these 4 parts added?
David_G is offline   Reply With Quote
Old 04-01-2014, 11:20 AM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,824
Total Cats: 1,781
Default

what do you need that output for? you have 4 spare inj outputs, alone, for generics that required no additional work/effort.
Braineack is online now   Reply With Quote
Old 04-01-2014, 11:26 AM   #6
Newb
Thread Starter
 
Join Date: Mar 2012
Location: Austria
Posts: 15
Total Cats: 1
Default

good question actually
Maybe as a shift or knock light. I know I have some outputs left on the MS3x board but most of them will be used for sequential spark, Alt. Light, CEL

I just want to make sure that I don't have to work on the Motherboard again in lets say 2 years when I MAYBE need the Fidle output, which is why I want to do it now.

Soldering in a few more parts, is no effort as long as it is still all opened up. If its a more complicated thing to add the Fidle output, please let me know, then I won't bother messing with it!
David_G is offline   Reply With Quote
Old 04-01-2014, 11:48 AM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,824
Total Cats: 1,781
Default

I just think it's wasted effort with the amount of spare extra outputs you have available right now already.


but to actually answer your question, yes that's all you needed to add to make the Idle output to work. Fidle is the ms3x output, so don't get those confused. IIRC, or maybe im confused.
Braineack is online now   Reply With Quote
Old 04-01-2014, 12:09 PM   #8
Newb
Thread Starter
 
Join Date: Mar 2012
Location: Austria
Posts: 15
Total Cats: 1
Default

Thats weird then. I cant get the Fidle LED on the JimStim to light up when i set the generic output.
Or do I have to adjust anything on the JimStim? Don't think so though...

I just had a Look on the Stimulators, pinout diagrams and in Tunerstudio and all say that Fidle is on MS3 and Idle on MS3x...
David_G is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM


Tags
fan, ms3, vss

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:24 PM.