Got a free MS2, C16 is roasted... - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 10-26-2011, 02:43 PM   #1
Elite Member
Thread Starter
iTrader: (8)
 
Join Date: Aug 2007
Location: Bellingham, Wa
Posts: 2,732
Total Cats: 3
Default Got a free MS2, C16 is roasted...

Hey all,

Long story short a mechanic friend of mine asked me if there was anything I wanted off of an audi that a customer abandoned at his shop before he pushes it out in the street to get towed. I quickly found an MS2 and an LC1 that I snagged.

Here is the problem with the megasquirt. Never seen this one before. Perhaps someone installed this capacitor backwards? Or maybe a crazy voltage spike in the car?





Going to swap it out and see if it will power up. Anything else I should swap out while i'm doing that? There doesn't seem to be any visible damage to any of the diodes or anything.
Attached Thumbnails
Got a free MS2, C16 is roasted...-dsc03813.jpg   Got a free MS2, C16 is roasted...-dsc03814.jpg  
wayne_curr is offline   Reply With Quote
Old 10-26-2011, 03:45 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

I'd replace the three caps there. C17 and L1.

probably a voltage spike, or it was install backwards.
Braineack is offline   Reply With Quote
Old 10-26-2011, 03:51 PM   #3
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Quote:
Originally Posted by Braineack View Post
I'd replace the three caps there. C17 and L1.

probably a voltage spike, or it was install backwards.
QFT
Ben is offline   Reply With Quote
Old 10-26-2011, 04:55 PM   #4
Senior Member
iTrader: (4)
 
Join Date: Jan 2008
Location: Falls Church, VA
Posts: 1,367
Total Cats: 16
Default

Would that abandoned Audi run if it had a functioning ECU?
ScottFW is offline   Reply With Quote
Old 10-26-2011, 05:15 PM   #5
Elite Member
Thread Starter
iTrader: (8)
 
Join Date: Aug 2007
Location: Bellingham, Wa
Posts: 2,732
Total Cats: 3
Default

Quote:
Originally Posted by ScottFW View Post
Would that abandoned Audi run if it had a functioning ECU?
If you put an engine, transmission and rear diff in it you could probably get it to run. Then you could put an interior in it if you wanted to drive it.
wayne_curr is offline   Reply With Quote
Old 10-27-2011, 05:28 PM   #6
Senior Member
 
Join Date: Nov 2007
Location: Belgium
Posts: 939
Total Cats: 59
Default

I repaired a similar MS just last week. The alternator field wire was shorted, so it had a +25V voltage spike.
C16 had exploded and 2 diodes were burned short (a 1N4001 and a zener). Can't exactly remember wich one but it was 2 out of D10 to D13. As they were shorted, it was easy to test them. Also burned out 2 traces in that area.
WestfieldMX5 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 12-13-2017 10:04 PM
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
"Chimney Ethanol" E100 MiataGarage Engine Performance 5 09-30-2015 12:04 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:23 AM.