High load AFR unstable :( - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 11-21-2012, 03:15 AM   #1
Oni
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Location: Tasmania, AUS
Posts: 164
Total Cats: 3
Default High load AFR unstable :(

Hi all

Still having issues with AFR being shitty sometimes and awesome others. I was happy enough if it was semi stable at high loads but its not always. Here are 2 pics of 2 differnt days but with the same tune. First is great second is IMO horrible and unusable. Any opinions on wtf could be happening would be welcome. Car doesnt feel / seem different regardless of what AFR says is happening. Can chop up the logs and post if that might help.



max = 13.0 min = 12.6 Target = 12.9



max = 13.6 min = 12.0 Target = 12.7
Attached Thumbnails
High load AFR unstable :(-oni-11419-albums-troubleshooting-pics-200-picture-high-load-max-%253d-13-0-min-%253d-12-6-target-%253d.png   High load AFR unstable :(-oni-11419-albums-troubleshooting-pics-200-picture-wot-high-load-max-%253d-13-6-min-%253d-12-0-target.png  
Oni is offline   Reply With Quote
Old 11-21-2012, 09:43 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

Do you have like 2000cc injectors installed?

Last edited by Braineack; 11-21-2012 at 10:10 AM.
Braineack is offline   Reply With Quote
Old 11-21-2012, 10:06 AM   #3
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Why are yo uusing the default range from the LC-1? Most of the time we use 10-20AFR, not 7.5-22.3. How are the ground run? Any chance one log was taken with the lights or the AC on, and the other without?
hustler is offline   Reply With Quote
Old 11-21-2012, 10:09 AM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

why do you reduce the resolution by ~30% if you dont have to?


his issue is the injectors.




































In before:




BUT BUT BUT ID1000cc injectors are the best thing in the world.

Attached Thumbnails
High load AFR unstable :(-crybaby2.jpg  
Braineack is offline   Reply With Quote
Old 11-21-2012, 10:14 AM   #5
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Braineack View Post
why do you reduce the resolution by ~30% if you dont have to?


his issue is the injectors.
and now we postin in a troll thread.
hustler is offline   Reply With Quote
Old 11-21-2012, 10:22 AM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

I'm sorry if you cant handle harsh reality.
Braineack is offline   Reply With Quote
Old 11-21-2012, 11:47 AM   #7
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Braineack View Post
I'm sorry if you cant handle harsh reality.
I didn't have this problem with 750cc IDs on a 140hp 1.6.
hustler is offline   Reply With Quote
Old 11-21-2012, 11:49 AM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

and his injectors are 30% larger. look at his PW between the two logs, but the again the load is hardly different. With Injectors this large and horsepower this minute, you need to be able to control these things by the thousandth of a second to get good AFRs...so perfectly inputting deadtimes and voltage corrections curves is vitial.


Oni, can you post the logs instead of screenshots? I'd like to look at other things in the log.
Braineack is offline   Reply With Quote
Old 11-22-2012, 04:22 AM   #9
Oni
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Location: Tasmania, AUS
Posts: 164
Total Cats: 3
Default

Just getting Office to get the logs to a smaller size, they are all taken while driving to work.

Grounding ive tried a few systems

-Power from blue connector behind headlight and grounded to head where ecu grounds
-Currently power from MS harness and ground to MS harness ( Rev MS unit comes with these to use for wideband ). currently crimped, have tried solders and also twist and tape without any help.

I hope its not my injectors :( i got them to fix this issue based on the recomendations from here. ah well . Ive been using the deadtimes / voltage correction from the provided data but that could be incorrect for my car i guess.

I got the ID1000 because i have limited access to E85 but want to get everything solid before swapping. Currently only one pump in the state but its semi close to work.

I was worried about low PW stability but i saw a vid of ID2000's idling on a small engine, granted it was super rich.

Also im just using defaults becuase they match on my gadge and in TS so didnt see a reason to change it, happy to try a change though if it might help.

Cheers
Scott

Last edited by Oni; 11-22-2012 at 04:24 AM. Reason: Additional info
Oni is offline   Reply With Quote
Old 11-22-2012, 05:22 AM   #10
Oni
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Location: Tasmania, AUS
Posts: 164
Total Cats: 3
Default

OK log time, 3 in total, good day is from the ss above and so is bad day. the third is one that shows me driving for about 10min total pulling over 2 times to power cycle the car, to show how differnt the stability can be by restarting, worth a look at . somedays its awesome and i dont have to restart at all, other days i can restart 5+ times and its still bad.

Cheers
Scott
Attached Files
File Type: msl bad day.msl (363.2 KB, 72 views)
File Type: msl AFR Stability.msl (1.75 MB, 63 views)
File Type: msl good day.msl (1.89 MB, 72 views)

Last edited by Oni; 11-22-2012 at 05:37 AM.
Oni is offline   Reply With Quote
Old 11-22-2012, 08:23 AM   #11
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

Are you using mulitply map?


honestly I'm looking at the bad day log and trying to figure out how it could be any better...

The injectors are cycling in a range of 3.69xms and 3.63xms and giving you those AFR fluxations...at WOT for over 1000RPMs. that's it; what more can you expect out of them? You want better fuel control between 0.06ms of time...on batch fuel.

Looking at the good day log, I dont see much difference other than a longer log and helps make the peaks and valley filter out. Zoom out of the good day and afr stability log, and it looks just as "bad"

I still cant fathom why people are using 1000cc injectors and utilizing only 3% of capacity.

Last edited by Braineack; 11-22-2012 at 04:47 PM.
Braineack is offline   Reply With Quote
Old 11-22-2012, 02:40 PM   #12
Newb
 
Join Date: Oct 2010
Posts: 10
Total Cats: 0
Default

Greetings,

I dont have a Miata but I have a Protege with the same BP 1.8 engine as the Miatas with ID1000 and works great idles perfect almost as stock with 14.7 AFR.

MS3 with a MS3X board ECU running sequential.

But in order to for this injectors to work it is absolutely critical that you set the dead time properly and the Req Fuel or you will have problems.

I can share my tune if you want.
Scamby is offline   Reply With Quote
Old 11-22-2012, 03:25 PM   #13
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

Quote:
Originally Posted by Braineack View Post
I still cant fathom why people are using 1000cc injectors and utilizing only 3% of capacity.
I've noticed that too over the past 2 years more and more people are buying unnecessarily big injectors. I'm guessing because the market now has big injectors like that people just keep buying them. Remember before when rx7 injectors were considered big? Oh the days

Maybe people buy them that big just in case they decide to run a borg 17 years from now?
triple88a is offline   Reply With Quote
Old 11-22-2012, 03:55 PM   #14
I haz no trubo
iTrader: (2)
 
Oscar's Avatar
 
Join Date: Jan 2007
Location: Bolton, UK
Posts: 3,021
Total Cats: 114
Default

Because nobody makes an EV14 injector in the <500cc/min range. I has a sad
Oscar is offline   Reply With Quote
Old 11-22-2012, 04:04 PM   #15
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

DW makes 600cc injectors. Personally i thought those would drown the market.
triple88a is offline   Reply With Quote
Old 11-22-2012, 04:23 PM   #16
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Quote:
Originally Posted by Oscar View Post
Because nobody makes an EV14 injector in the <500cc/min range. I has a sad
Lolwut? I has 445cc FIC EV14 injectors.
Reverant is offline   Reply With Quote
Old 11-22-2012, 04:46 PM   #17
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

Quote:
Originally Posted by Scamby View Post
But in order to for this injectors to work it is absolutely critical that you set the dead time properly and the Req Fuel or you will have problems.

I can share my tune if you want.

mother effin this.
Braineack is offline   Reply With Quote
Old 11-22-2012, 05:23 PM   #18
Oni
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Location: Tasmania, AUS
Posts: 164
Total Cats: 3
Default

Thanks for the comments im at work ATM but ill grab my injctor settings tonight for people to look over.

Found the multiply map setting and it is set to "Multiply", should i have that on or off? .

Its intersting if you look over the good day log at high load and just press the arrow key you only see changes in steps of 0.1-0.2 where in the bad day you see 0.1-1.0, do you think this is just beucase its not sampling the same?. would it help if i made 2 logs that are over the same time period? i cant help but still think its differnt as when i watch my afr on a good day it will sit within a small window and not change much compared to the numbers dancing on the dial.

I think people are going with ID1000's becuase were being told there is no reason not to and for some extra head room. Im planning 250rwhp on E85 down the track so 1000's seemed like a good idea . but for now i just want to get a NA tune squared away.

If anyone has a SS of there injector settings for there ID1000's id love to see them . i did post mine before ( cant find them now ) and no one poked holes in them though.

Cheers
Scott
Oni is offline   Reply With Quote
Old 11-22-2012, 05:28 PM   #19
I haz no trubo
iTrader: (2)
 
Oscar's Avatar
 
Join Date: Jan 2007
Location: Bolton, UK
Posts: 3,021
Total Cats: 114
Default

Quote:
Originally Posted by Reverant View Post
Lolwut? I has 445cc FIC EV14 injectors.
Include a set with my ms3x. kthnxbai
Oscar is offline   Reply With Quote
Old 11-22-2012, 08:00 PM   #20
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

Quote:
Originally Posted by Oni View Post
Found the multiply map setting and it is set to "Multiply", should i have that on or off? .

its okay for you, since it seems your fuel map is perfectly tuned.


try logging the same amount time like you suggested, the bad log seems to have a more noisy battery log.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 Yesterday 10:04 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
01-05 Fab9 PNP COPs (used) FrankB Miata parts for sale/trade 6 09-30-2015 12:48 PM
In need of base map for stock 1997 brandonbkd MEGAsquirt 0 09-29-2015 12:52 AM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:43 AM.