I need some help - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 05-28-2010, 10:56 AM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2010
Location: Apra Harbor, Guam
Posts: 131
Total Cats: 0
Default I need some help

As some of you might know i just bought FastColts car and no offense to him this car is only good when it wants to ******* run....which is never. the megasquirt ecu is trash. I cant get the car to run for...well not at all. it will start then die then i start it again and it dies. ive adjusted every thing slightly. the fuel, the spark ignition, the idle setting. Every thing ive done hasnt helped for ****. Today i went through and was adjusting timings trying to smooth out the idle and i got it pretty smooth so i left the base auto shop got 50 yards and the engine died. started it again and drove back. i switched every thing back slightly and tried again and again got 50 yards and it died. so i drive back and set the car back to the tune i had it on yesterday. it was shaky but it at least drove. guess what now that tune wont even keep the car running it just starts and dies. I pop the clutch the engine dies. what the hell is going on with this car. On top of all that i cant even go get a professional tune because the only local shop wont touch megasquirt and the one place i found that will do a megasquirt tune has never used the program before.
SneakyB757 is offline   Reply With Quote
Old 05-28-2010, 10:13 PM   #2
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2010
Location: Apra Harbor, Guam
Posts: 131
Total Cats: 0
Default

Fine. I see this was a really go place for me to come and ask for help. I know you all can understand that im upset because i spend alot of money on this car and it wont run properly, But the fact the 22 people looked at this and said nothing, not even a "hey man sorry your car isnt running right" Ive been on this board for about a week and now im done with it. no help from anyone.
SneakyB757 is offline   Reply With Quote
Old 05-28-2010, 10:31 PM   #3
NB/VVT Connoisseur
iTrader: (23)
 
viperormiata's Avatar
 
Join Date: Aug 2008
Location: Key West
Posts: 6,065
Total Cats: 253
Default

Geez dude, relax! This is the most informative board on the net when it comes to turbo miatas.

Just take a deep breath, eat a chill pill and do some searching around.

Just because you bought a member's car doesn't mean we are required to spoon feed you all the information you want.

There is a reason that no one has said anything yet, we NEED more information. About the car, the situation that's going on with the car and whether or not megasquirt is actually the problem.

EDIT: Okay, just read your intro. To be honest, you took a HUGE plunge into the forced induction world. a 2300lb car with nearly 400whp? Yeah, scary as ****!

So back to your MS dilemma. Since this is your first FI car, can I safely assume that you have never tuned a stand alone engine management system? I'm gonna go with yes! My best advice right now(due to lack of actual diagnosis) is to read all the MegaSquirt stickies and the general miata turbo stickies. They are there for a reason. But, do not get frustrated and make any stupid decisions. MegaSquirt is a very capable and user friendly stand alone.

So please do that and report back with some more info on the car. Also, come back with a better attitude. The mods here will ban you for being disrespectful.

Last edited by viperormiata; 05-28-2010 at 10:43 PM.
viperormiata is offline   Reply With Quote
Old 05-28-2010, 10:40 PM   #4
I'm a terrible person
iTrader: (19)
 
FRT_Fun's Avatar
 
Join Date: Apr 2009
Location: Arizona
Posts: 7,293
Total Cats: 180
Default

How bout you post a damn MSQ and a Datalog of it dieing... oh no, why would you do that, it's not like you want us to help you.
FRT_Fun is offline   Reply With Quote
Old 05-28-2010, 10:54 PM   #5
Elite Member
iTrader: (9)
 
Join Date: Sep 2008
Location: Bloomfield, Michigan
Posts: 5,682
Total Cats: 10
Default

Im no likey the "I adjust the timing to smooth out the idle"
buffon01 is offline   Reply With Quote
Old 05-28-2010, 10:59 PM   #6
I'm a terrible person
iTrader: (19)
 
FRT_Fun's Avatar
 
Join Date: Apr 2009
Location: Arizona
Posts: 7,293
Total Cats: 180
Default

Quote:
Originally Posted by viperormiata View Post
The mods here will sexually exploit you for being disrespectful.
fixed.
FRT_Fun is offline   Reply With Quote
Old 05-28-2010, 11:28 PM   #7
NB/VVT Connoisseur
iTrader: (23)
 
viperormiata's Avatar
 
Join Date: Aug 2008
Location: Key West
Posts: 6,065
Total Cats: 253
Default

Quote:
Originally Posted by FRT_Fun View Post
fixed.
Oops, how could I have mixed that one up, lol.

Where is the OP???? We are here to help you now!!!!!!!
viperormiata is offline   Reply With Quote
Old 05-29-2010, 01:31 AM   #8
I'm a terrible person
iTrader: (19)
 
FRT_Fun's Avatar
 
Join Date: Apr 2009
Location: Arizona
Posts: 7,293
Total Cats: 180
Default

I know wtf I'm trying to help and he just leaves!! As you can tell I am very angry right now
FRT_Fun is offline   Reply With Quote
Old 05-29-2010, 10:29 AM   #9
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

So you're an only-child, parents are divorced, and you never had a father to show you how to be man...we can't help you there. Instead, why don't you work on the basics or even provide the .msq and a log so we can fix it for you. By "we" I mean the brain trust here like Joe Perez, Ben, Brain, Matt Cramer, Stephen Hawking, and myself.
hustler is offline   Reply With Quote
Old 06-03-2010, 12:53 PM   #10
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2010
Location: Apra Harbor, Guam
Posts: 131
Total Cats: 0
Default

OK im sorry i over reacted like i did, but i think anyone would be a little mad if they bought a car with this much work done to it and it didn't run properly. I just trying to get used to the ecu and how it works. its a pretty steep learning curve no matter how user friendly the program is. Ill try again a little more relaxed. The idle on the car is unsteady and the engine cuts out every time i push in the clutch for the first 20 min or so that i drive the car. I want to down size the injectors to balance out the idle, but i dont know what size to get? the car is running at about 15psi but is tuned for 22psi id like to keep the boost around 15 so what should i do with the tune depending on the injectors i put in. Im sorry i acted the way i did, ive got a lot of things going on in my life right now and they all need money i dont have to fix so im trying to sell some things but they arent selling. one thing i know i could sell on here i cant sell yet because i 1 dont have enough posts and 2 im not sure if ill need them for a 15 psi tune. Im not going to turn this into a pity story im just looking for some help so i can get one thing going right in my life.
SneakyB757 is offline   Reply With Quote
Old 06-03-2010, 01:02 PM   #11
Antisaint
iTrader: (17)
 
Vashthestampede's Avatar
 
Join Date: Feb 2007
Location: Danbury, CT
Posts: 4,659
Total Cats: 54
Default

Quote:
Originally Posted by SneakyB757 View Post
OK im sorry i over reacted like i did, but i think anyone would be a little mad if they bought a car with this much work done to it and it didn't run properly. I just trying to get used to the ecu and how it works. its a pretty steep learning curve no matter how user friendly the program is. Ill try again a little more relaxed. The idle on the car is unsteady and the engine cuts out every time i push in the clutch for the first 20 min or so that i drive the car. I want to down size the injectors to balance out the idle, but i dont know what size to get? the car is running at about 15psi but is tuned for 22psi id like to keep the boost around 15 so what should i do with the tune depending on the injectors i put in. Im sorry i acted the way i did, ive got a lot of things going on in my life right now and they all need money i dont have to fix so im trying to sell some things but they arent selling. one thing i know i could sell on here i cant sell yet because i 1 dont have enough posts and 2 im not sure if ill need them for a 15 psi tune. Im not going to turn this into a pity story im just looking for some help so i can get one thing going right in my life.
If I had a better understanding of MS myself I would give you a hand, seeing that you're a fellow CT member, but unfortunately I'm still learning it as well and cant offer much help.

What I can say though, is take the time to write a more thought out post/reply, without any lashing out, and you'll get a much larger audience that is willing to help you, rather than watch you walk away and never care about it.

Good luck with the car, I hope you get it figured out.
Vashthestampede is offline   Reply With Quote
Old 06-03-2010, 01:17 PM   #12
Senior Member
iTrader: (1)
 
Join Date: Sep 2007
Location: Trenton, NJ
Posts: 1,125
Total Cats: 0
Default

Quote:
Originally Posted by SneakyB757 View Post
The idle on the car is unsteady and the engine cuts out every time i push in the clutch for the first 20 min or so that i drive the car.

the car is running at about 15psi but is tuned for 22psi
The car is not "tuned" if it's not running.
ArtieParty is offline   Reply With Quote
Old 06-03-2010, 02:08 PM   #13
Elite Member
iTrader: (9)
 
Join Date: Sep 2008
Location: Bloomfield, Michigan
Posts: 5,682
Total Cats: 10
Default

Well I really dont want to sound like an *******, which I will by saying this, but you shouldve done some research and at least have a little more knowledge of what you were getting into before you bought a car with so many mods done to it.

With that said please upload your msq, and if you can let the car idle and turn the datalog function. Then post that datalog along with the msq so that way we at least have a clue what you got.

Another advice is dont look to change your injector. Given that you have financial issues, first try to look for a solution that doesnt involve any cash, in other word tune it, instead of spending more money and getting additional parts.
buffon01 is offline   Reply With Quote
Old 06-03-2010, 02:55 PM   #14
meatbag
iTrader: (50)
 
gospeed81's Avatar
 
Join Date: Nov 2008
Location: Houston, TX
Posts: 7,357
Total Cats: 26
Default

Any monkey can swap parts...a true mechanic does a proper diagnosis.

It sounds like your car was "built" for it's horsepower goal, but not "tuned" for it. That means the expensive part is done, since all the parts are in place. You get the really fun task of properly setting up an .msq and tuning it to safely manage that power.

Moving things "a little" isn't the way to go about this, especially with timing and fueling...it sounds like it's relative and small, but it's not. You need to set real goals for those parameters, and meet them.

Start with base timing. Make sure both your ignition and cam timing are spot on.

Then set AFR targets, and see if the car will run long enough to datalog, analyze and change the VE table.

One step at a time...
gospeed81 is offline   Reply With Quote
Old 06-03-2010, 05:47 PM   #15
Elite Member
iTrader: (11)
 
Join Date: Jun 2007
Location: Meriden, CT
Posts: 2,072
Total Cats: 1
Default

Are the kelford cams installed still? I remember helping Chris get this car idling with them but, from time to time it would die. I remember him saying he swapped them out and it ran better. Also IIRC he had just put in the 750cc injectors recently, so its likely that the VE table is wacked unless he did some tuning afterwards. Like the others said, get the car running and get a datalog posted along with the tune that is loaded....maybe even just post a screen shot of the spark table thats in there. Just from the little bit I've read, it sounds like you have a timing issue. I know you have adjustable cam gears on there, so you might check there....since I know fastcolt had to adjust them to get the kelfords to run.... I don't mind helping, as long as I get a ride in that thing when its dialed in good

Where's Dave (240toMiata)...he spent some time working with fastcolt on the MS....
Cspence is offline   Reply With Quote
Old 11-27-2010, 12:06 AM   #16
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2010
Location: Apra Harbor, Guam
Posts: 131
Total Cats: 0
Default

sorry this has taken so long for me to get up but ill put up the ve table, spark map and the data log i took today. I had a very odd issue of when i went into boost the engine or ecu restricted something and the engine started to sputter until i got off the gas. i have the ecu set to hard cut the boost if it gets to 21 psi but this happened at 11psi. Im running the tune that Fastcolt gave me so ill put up as much about it as i can. on the data log the green bar on the bottom is boost the rest of the layout is the standard layout for the megalog. i hope this helps and insight would be great because it doesnt look like im selling this car any time soon.

Name:  fueltable.png
Views: 1
Size:  166.9 KBName:  sparktable.png
Views: 1
Size:  173.0 KBName:  boostissue1.png
Views: 1
Size:  80.8 KBName:  boostissue2.png
Views: 1
Size:  77.4 KBName:  boostissue3.png
Views: 1
Size:  75.1 KBName:  boostissue4.png
Views: 1
Size:  78.4 KBName:  boostissue5.png
Views: 1
Size:  78.7 KBName:  boostissue6.png
Views: 1
Size:  79.2 KBName:  boostissue7.png
Views: 1
Size:  75.1 KBName:  boostissue8.png
Views: 1
Size:  78.2 KB
SneakyB757 is offline   Reply With Quote
Old 11-27-2010, 10:15 AM   #17
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

You're using MAF instead of speed density for your load for some reason. If you have a big enough MAF to not pose restriction, so be it, I guess I can understand an argument to go that route (especially MAF for fuel and SD for ignition). MAFs are generally 0-5V output. Your ignition table seems to be scaled ok. However what are you doing with your fuel table? The fact that the motor even runs is a testament to both the BP and the MS.

Before touching *anything* please read, read, and read. Here's a good start:
http://www.msextra.com/doc/ms1extra/...ing_Manual.htm
http://www.diyautotune.com/faq/faq.htm
http://www.megamanual.com/v22manual/mtune.htm

And if you want to keep going, here's a link to Matt & Jerry's book:
http://www.amazon.com/dp/1557885575?...ZNBMWSYKM0V4V&

Or these guys offer online classes:
http://www.efituningtech.com/
Ben is offline   Reply With Quote
Old 11-27-2010, 10:38 AM   #18
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2010
Location: Apra Harbor, Guam
Posts: 131
Total Cats: 0
Default

dont look at me. that fuel table was given to me by the previous owner. thats what he was running. the only thing ive done to that tune since ive gotten it is adjust the idle from 1k to 1.2k and turn off launch control. other than that every thing on that tune is the way i bought it.
SneakyB757 is offline   Reply With Quote
Old 11-27-2010, 02:27 PM   #19
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2010
Location: Apra Harbor, Guam
Posts: 131
Total Cats: 0
Default

well ive been reading this stuff, but i dont want to **** with anything. this is what my boost control setting is set at. does any think this is why my car is hard cutting at 2psi

Name:  boostcontrol.png
Views: 1
Size:  216.3 KB
SneakyB757 is offline   Reply With Quote
Old 11-27-2010, 08:35 PM   #20
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Nope. Your car runs poorly because it needs to be tuned. There's not a quick, magic answer. Recommend you set it to speed density and get started on your fuel and ignition tables. The info you need is found in the links from my last post.
Ben is offline   Reply With Quote
 
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:25 PM.