I need a Tach signal - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 04-21-2008, 12:10 PM   #1
:(
Thread Starter
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default I need a Tach signal

So to fill you guys in i followed Scots how to install Cop's and used some from a Millenia wich Patsmx5 provided. Got it all installed and fired it up. But since none of my coils have tach outputs like the toyota coils my in dash tach does not work for me. MS still works just fine though. So where can i splice into a tach signal for my dash? Plz I dont wanna have to have MS hooked up to read my rpms.
magnamx-5 is offline   Reply With Quote
Old 04-21-2008, 12:13 PM   #2
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

You will have to build the tach output circuit for the MS and connect it to your dash tach to get it to work right. You can find it here.
http://www.msextra.com/manuals/MS_Ex...l.htm#tachoout
cjernigan is offline   Reply With Quote
Old 04-21-2008, 12:45 PM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

oh, see you lacked to tell me that Richard...there's a difference between "my tach doesnt work after cops" and "my cops don't have a tach output."
Braineack is offline   Reply With Quote
Old 04-22-2008, 12:42 AM   #4
:(
Thread Starter
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

sorry Scot i thought i made that clear in my messages, at least the second one. I gues i am getting rusty i havent been postwhoring at all for a month or more now.
Do you guys think that mayhaps i can piggy of my trigger signal or something similiar? Or maybe i can share the signal that my Ms uses for rpm it still reads fine?
magnamx-5 is offline   Reply With Quote
Old 04-22-2008, 01:35 AM   #5
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Try this:

Name:  richardspic.jpg
Views: 8
Size:  58.6 KB
patsmx5 is offline   Reply With Quote
Old 04-22-2008, 03:28 AM   #6
Elite Member
iTrader: (3)
 
AbeFM's Avatar
 
Join Date: Aug 2006
Location: San Diego, CA
Posts: 3,048
Total Cats: 8
Default

Does the MS-I not put out tach signals? I built a similar circuit, but just drove it off an MS-II generated tach signal, instead of the two pins on the MS and the diodes and all that.
AbeFM is offline   Reply With Quote
Old 04-22-2008, 08:48 AM   #7
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Chicago (Over two miles from Wrigley Field. Fuck the Cubs. Fuck them in their smarmy goat-hole.)
Posts: 26,317
Total Cats: 1,915
Default

Yes, the MS-I gives you a tach output. CJ posted the hardware link, here's the software config:

Joe Perez is offline   Reply With Quote
Old 04-22-2008, 02:41 PM   #8
:(
Thread Starter
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

dammit that sucks. i was hoping i could do it easily
magnamx-5 is offline   Reply With Quote
Old 04-22-2008, 02:58 PM   #9
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Chicago (Over two miles from Wrigley Field. Fuck the Cubs. Fuck them in their smarmy goat-hole.)
Posts: 26,317
Total Cats: 1,915
Default

Well, the circuit that patsmx5 posted looks pretty easy to me, and should work just as well.
Joe Perez is offline   Reply With Quote
Old 04-22-2008, 03:38 PM   #10
Elite Member
iTrader: (3)
 
AbeFM's Avatar
 
Join Date: Aug 2006
Location: San Diego, CA
Posts: 3,048
Total Cats: 8
Default

Quote:
Originally Posted by Joe Perez View Post
Well, the circuit that patsmx5 posted looks pretty easy to me, and should work just as well.
indeed. :-) I'm kinda tempted to do that with mine, save a pin.
AbeFM is offline   Reply With Quote
Old 04-23-2008, 12:45 AM   #11
:(
Thread Starter
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

Uh guys what is a BD37? my MS1 was wired into the stock ecu board by Adbradley he didn't use a boomslang he modded and jumpered the baord internally. Pat if you can make it and explain how to implement it then i will use it and let you know if it works. There has to be a simpler way than all that **** to do this though geez. If it comes down to it i just wont run a dash tach this is getting rediculous all i wanted was more spark.
magnamx-5 is offline   Reply With Quote
Old 04-23-2008, 01:00 AM   #12
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Quote:
Originally Posted by magnamx-5 View Post
Uh guys what is a BD37? my MS1 was wired into the stock ecu board by Adbradley he didn't use a boomslang he modded and jumpered the baord internally. Pat if you can make it and explain how to implement it then i will use it and let you know if it works. There has to be a simpler way than all that **** to do this though geez. If it comes down to it i just wont run a dash tach this is getting rediculous all i wanted was more spark.
Hey it's simple stuff Rich, don't worry. The DB 37 is the 37 pin plug that most Mega squirts use. Anyways, if you know what two wires trigger your coils for the spark outputs, then the circuit I posted will work. Where my circuit says DB 31 and 36, those are you spark outputs. They are the trigger wires that go to your coils. Just tap those two wires somewhere and hook them up to the circuit where it says 31 and 36 and your golden. If you can find those wires and run a ground a 12V+ to my circuit, it will give you the tach output you need.
patsmx5 is offline   Reply With Quote
Old 04-23-2008, 01:04 AM   #13
:(
Thread Starter
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

I can do that Pat. Pm me a price and ETA plz and i will get back to you. Your diagram helped me alot in the install btw it runs very nicely with the cops, esp after i got the fuel back right
magnamx-5 is offline   Reply With Quote
Old 04-23-2008, 02:50 PM   #14
Elite Member
iTrader: (3)
 
AbeFM's Avatar
 
Join Date: Aug 2006
Location: San Diego, CA
Posts: 3,048
Total Cats: 8
Default

Er, it should be the LEDs, no? Aren't those spark outs? Just grab the signal there.
AbeFM is offline   Reply With Quote
Old 04-24-2008, 08:54 PM   #15
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Name:  Richardstachthingy.jpg
Views: 9
Size:  88.8 KB
patsmx5 is offline   Reply With Quote
Old 04-25-2008, 12:45 AM   #16
:(
Thread Starter
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

**** yeah Pat that is
awesome Shoot me a ETA plz i like it.
Hopefully i can get it and the ebc on real soon Then i hope to hit up the local dyno and see what a 1.6 can do with proper ignition
magnamx-5 is offline   Reply With Quote
Old 04-30-2008, 02:31 PM   #17
:(
Thread Starter
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

Pat you are a genius it works perfectly
magnamx-5 is offline   Reply With Quote
Old 04-30-2008, 05:59 PM   #18
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Quote:
Originally Posted by magnamx-5 View Post
Pat you are a genius it works perfectly


Cool, glad it's working for you. I'll probably be doing the same thing for COPs soon. Well, everybody it's official, Millenia COPs and that circuit I posted above works. The COPs came off a SC'd millenia that ran 14 PSI stock, so they should be pretty hot coils. All year supercharged millenia coils will work (95-02). Note the 2.3 millenia was the SC'd version with COPs. The 2.5 NA motor does not have these COPs, it has a distributor.

Also, the 95 coils had 4 wires, not 3. From a millenia forum:

Quote:
The extra 4th pin on the older coil was not used in 96 and later. Is called an ignition confirmation signal in the service highlights but no other description as to purpose.
That's probably the tach output circuit, but not 100% sure.

For Reference, you'll need:

4 Millenia COPs with connectors: http://i231.photobucket.com/albums/e...ys/barrys1.jpg

The tach output circuit: http://i231.photobucket.com/albums/e...ichardspic.jpg

Here's the pin out of the coils: http://i231.photobucket.com/albums/e...ram2-17-08.jpg

That should do it. Just follow Braineack's writeup on how to wire everything and use the pin out for the coils above and add the tach circuit.

Last edited by patsmx5; 04-30-2008 at 06:49 PM.
patsmx5 is offline   Reply With Quote
Old 04-30-2008, 06:04 PM   #19
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Remember, you don't have to build that circuit outside of the MS either. You can build the tach circuit inside the ms and just run an extra wire out of the DB37 for it.
cjernigan is offline   Reply With Quote
Old 04-30-2008, 06:06 PM   #20
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

pat, now send one to jason so he can scope them and let us know if they are better/worse than the toyota cops.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
ms2e No Rpm Signal Dobzeh ECUs and Tuning 5 09-17-2015 03:56 PM
how to Make 94-95 tach work with MSPNP2 JacksonRacingEngines Engine Performance 10 09-10-2015 10:52 AM
Sold fail wagon Miata parts for sale/trade 2 09-07-2015 09:51 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:54 AM.