I swear I go to college, still hopeless w/ ms2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 04-01-2010, 04:09 PM   #1
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Feb 2009
Location: Raleigh, NC
Posts: 321
Total Cats: 0
Default I swear I go to college, still hopeless w/ ms2

So I just got my msII built by brain in the mail.

My car is n/a and I'm ready to install it. It is apparently flashed and loaded with a map. I think as far as putting it in physically, I just plug into factory location and wire the ait up to the old afm harness.

Questions: Do I need to run a vacuum line to the MS? Do I need to load maps or worry about coils frying?

Now comes the stuff I don't get.

Step 1:

Install the Megatune software onto your laptop.

Run the installation software for MegaTune allow the software to install to the default location.

http://www.megasquirtpnp.com/downloa...tup_021108.exe
<did this

Open the directory, leaving just the 9093 WITHOUT AFM to use, delete all the remaining 9093 or 9495 folders. Rename it to something like “Project Folder” or "IM_AWESOME"

then go here: http://www.boostedmiata.com/MS/msq/hr_10g.zip

Extract hr_10g.zip into the folder you just renamed and run copy-ini.bat. This will update your software to hr_10g code.


^^no clue on doing this. I've tried a few times and my 9495noafm won't open (megatune terminates)

I dont know where this "directory" is and I have not found any way to change any of the 9495 or 9093 things I can find

Then I downloaded DIYAUTOTUNE'S software pack to "make things easier" but when I open megatune I have like 10 projects to shoose from and I dont know which one to use.

As of right now I uninstalled everything and am waiting on assistance to start over. I swear I've read the install guide on her 30 times. Yes I need someone to hold my hand.

damn this is gonna hurt.
kewilso3 is offline   Reply With Quote
Old 04-01-2010, 04:22 PM   #2
Elite Member
iTrader: (28)
 
Join Date: May 2008
Location: St. Augustine FL
Posts: 2,310
Total Cats: 2
Default

you better read the mega manual or you will not last........ put your flame suit on man.....
p51hellfire is offline   Reply With Quote
Old 04-01-2010, 04:24 PM   #3
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Feb 2009
Location: Raleigh, NC
Posts: 321
Total Cats: 0
Default

I'm on it. **** electronics. I know i'm gonna get ripped a new one for this, but hey, I'm hopeless otherwise, had to take a chance in the snake pit
kewilso3 is offline   Reply With Quote
Old 04-01-2010, 04:33 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

where is that **** from?

http://boostedmiata.com/MS/msq/instr...uctions_TS.pdf

Don't follow any instructions for the MS-I, I wrote the above for the DIYPNP which runs MS-II. And don't use MegaTune.


When you finally connect, make sure you use the current tune, not the offline one.
Braineack is offline   Reply With Quote
Old 04-01-2010, 04:54 PM   #5
Elite Member
iTrader: (12)
 
Join Date: Aug 2006
Location: Central-ish VA
Posts: 4,449
Total Cats: 16
Default

Damn Scott, you do more for these peeps for free than you do for money at your job.
neogenesis2004 is offline   Reply With Quote
Old 04-01-2010, 05:16 PM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

he paid me good money !
Braineack is offline   Reply With Quote
Old 04-01-2010, 05:17 PM   #7
Elite Member
iTrader: (12)
 
Join Date: Aug 2006
Location: Central-ish VA
Posts: 4,449
Total Cats: 16
Default

I fail for not even seeing line 1 :( I'll go to my corner now.
neogenesis2004 is offline   Reply With Quote
Old 04-01-2010, 05:18 PM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

its okay. ive still gone too far out of my way to publish everything i do for everyone to give it a go.
Braineack is offline   Reply With Quote
Old 04-01-2010, 05:35 PM   #9
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Feb 2009
Location: Raleigh, NC
Posts: 321
Total Cats: 0
Default

in that link to the pdf, all the options is completely different.

*edited for typo relization

Last edited by kewilso3; 04-02-2010 at 10:57 PM.
kewilso3 is offline   Reply With Quote
Old 04-01-2010, 05:59 PM   #10
Senior Member
iTrader: (4)
 
Join Date: Jan 2008
Location: Falls Church, VA
Posts: 1,367
Total Cats: 16
Default

Start up tunerstudio, check for update and make sure you're using the latest version, 0.994.1. You should see MS2 Extra Rel 3.0.3r as one of the drop-down menu options. EDIT: I'm assuming that's what Brain preloaded you with. You could also "detect" if you have the ECU connected. EDIT EDIT: That 3.0.0r in the pdf is a typo.

Quote:
Originally Posted by kewilso3 View Post
I swear I go to college
I'm gonna have to see proof of this. You've been on the forum for a year, you know the drill. Pics or it didn't happen. It's a glorious day today so you should have no problem providing pics of hot scantily clad undergrad ***. The female kind. Although if you go to college in Raleigh you probably know that most NC State chicks are about as ugly as Dook chicks (would not hit that with a stolen dick) so you may have to drive over to Chapel Hill to photograph some specimens worthy of our viewership.

Last edited by ScottFW; 04-01-2010 at 06:10 PM.
ScottFW is offline   Reply With Quote
Old 04-01-2010, 06:00 PM   #11
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,775
Total Cats: 1,106
Default

Quote:
Originally Posted by ScottFW View Post
I'm gonna have to see proof of this. You've been on the forum for a year, you know the drill. Pics or it didn't happen. It's a glorious day today so you should have no problem providing pics of hot scantily clad undergrad ***. The female kind. Although if you go to college in Raleigh you probably know that most NC State chicks are about as ugly as Dook chicks (would not hit that with a stolen dick) so you may have to drive over to Chapel Hill to photograph some specimens worthy of our viewership.
There were some pretty girls out today at Mason. I will try to get some pics when I go back on Monday.
shuiend is offline   Reply With Quote
Old 04-01-2010, 07:24 PM   #12
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Feb 2009
Location: Raleigh, NC
Posts: 321
Total Cats: 0
Default

ok so i should use the "detect" option if it's not there on my comp? Otherwise, Brain, which version do I have?
kewilso3 is offline   Reply With Quote
Old 04-02-2010, 10:45 PM   #13
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Feb 2009
Location: Raleigh, NC
Posts: 321
Total Cats: 0
Default

college, a great time to embarrass exes
kewilso3 is offline   Reply With Quote
Old 04-02-2010, 11:53 PM   #14
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Quote:
Originally Posted by kewilso3 View Post
Then I downloaded DIYAUTOTUNE'S software pack to "make things easier" but when I open megatune I have like 10 projects to shoose from and I dont know which one to use.
As a hard core NEWB you need to use MS2E 2.1.0 which is the latest stable release MS2 firmware.

3.0.3r is an alpha firmware, meaning that while it's passed initial testing, it's not ready for full release. So there's potential to run into a bug. NEWB plus bug = fail. So let's use 2.1.0.

You can go to c/program files/megasquirt and delete several of the firmware definitions that are not relevant to you, such as all the MSPNP, MS1 Extra, and the BG firmware folders. You'll probably only have MS2E 2.1.0 remaining at that point.

So first thing you need to do is close everything on the laptop. Connect and power up to the ECU. Run the program in your MegaSquirt folder called PortCheck. If you can connect to the ECU, PortCheck will tell you which com port it's on and the firmware version that is loaded.
If it tells you that you're on com port X and you are running MS2 Extra Firmware x.x.x, it's a good thing.

If you're not running 2.1.0, then you need to flash it in. Then you'll set up your basemap.
Ben is offline   Reply With Quote
Old 04-09-2010, 07:47 PM   #15
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Feb 2009
Location: Raleigh, NC
Posts: 321
Total Cats: 0
Default

ok thanks i have 3.0.3r, will figure out flashing and go from there... actually I have no f'ing cluee what any tutorials are even talking about... why does everyone say this is easy?

Last edited by kewilso3; 04-09-2010 at 08:05 PM.
kewilso3 is offline   Reply With Quote
Old 04-09-2010, 08:49 PM   #16
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Feb 2009
Location: Raleigh, NC
Posts: 321
Total Cats: 0
Default

all this copying gui's and INI's and renaming things... and I havn't even gotten to loading maps and tuning yet. Most guides go something like this: plug ecu in, configure, start tuning... useful

I think hardcore NEWBS should stay away from loading firmware... I can't even find 2.1.0 anywhere


kewilso3 is offline   Reply With Quote
Old 04-09-2010, 08:54 PM   #17
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

didn't you read my guide? it pretty much says: plug in ecu, AIT, load software and start tuning. The 3.0.0r was a typo, yours has 3.0.3r loaded with a basemap and is ready to rock and roll.
Braineack is offline   Reply With Quote
Old 04-09-2010, 08:58 PM   #18
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Feb 2009
Location: Raleigh, NC
Posts: 321
Total Cats: 0
Default

yeah Ben scared me with the beta talk though... guess if there's a problem i'll cross that bridge when I come to it. Hopefully I'll be running standalone tonight... a big hope... My wideband still hasnt arrived yet, Can I go ahead without it on the same basemap? Just use the narrowband option for stock sensor?
kewilso3 is offline   Reply With Quote
Old 04-09-2010, 10:07 PM   #19
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Loading code isn't too painful, and you can find documentation on it at both the msextra site and on our website.

MS2E 2.1.0 is included in our software package and can also be found at the msextra web site:
http://www.msextra.com/doc/ms2extra/...e_20100123.zip

2.1.0 is the latest 'stable release' firmware. This is the firmware version I recommend for new users. 3.0.3r or 3.0.3s are both considered 'alpha' and while considered generally solid, may potentially have a bug or two. As a new user, if you run into trouble, it may be a bit overwhelming. Case in point, we potentially found something odd in 3.0.3r & s just this morning.
Ben is offline   Reply With Quote
Old 04-10-2010, 10:35 PM   #20
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Feb 2009
Location: Raleigh, NC
Posts: 321
Total Cats: 0
Default

ok got it started up and it ran fine for a while, high idle around 1200 but smooth. Driving went well all around on a few short trips.

Now the idle is poor, very low after startup around 600-800 and not stable, eventually sputtering and shutting off. Couldn't figure out data logging or if it helps with idle stuff, could make a file but couldn't view it really.

opened up startup/idle settings and got too scared to change anything.
kewilso3 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Boosting on a Budget: Greddy Kit Done *Right* typicalsteve Build Threads 203 01-11-2016 08:51 AM
Lurker Intro and Brief-ish Build Summary Ted75zcar Meet and Greet 10 08-05-2015 08:41 PM
New Enhanced MS2 put to the test Reverant MS Labs - Miata Accessories 10 12-10-2012 04:42 AM
1.8L Brian Built MS2 with Harness CarWhore Miata parts for sale/trade 0 10-30-2012 06:27 PM
Idle issue with MS2 unit, Log and Msq inside. Cross MEGAsquirt 70 06-29-2011 03:29 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:00 PM.