Idle too high w/correct spark angle settings? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-03-2008, 03:04 AM   #1
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Jun 2007
Location: Overland Park, Kansas
Posts: 5,382
Total Cats: 43
Default Idle too high w/correct spark angle settings?

I set my Fixed Angle to 10 degrees, adjusted the trigger angle until my timing mark on the crank pulley was at 10 degrees advance which ended up being 55 degree in Megatunes trigger angle box. Set the Trigger angle addition to 0. Set fixed angle back to -10 and wrote it to the controller, checked timing with light and its about 18 degrees... Idles at 1600rpm now. Did a quick drive, logged, rewrote my fuel map.. still idles too high.

Everything I've tried, can't get it to idle down.. except set the trigger angle addition to +22.5 degrees then the idle is PERFECT, except the car doesn't accelerate for ****! Set it back to 0 and she pulls like a striped *** ape!

Also if I have AFR Target set to active using one of the target tables I think Paul posted for N/A, it runs like ****.. Turn that off, runs okay, sans the hella high idle?

What am I doing wrong??
elesjuan is offline   Reply With Quote
Old 02-03-2008, 03:27 AM   #2
Senior Member
iTrader: (8)
 
turbobluemiata's Avatar
 
Join Date: Aug 2006
Location: Springfield, IL
Posts: 1,019
Total Cats: 0
Default

i just adjust my idle with like i would when it was N/A
turbobluemiata is offline   Reply With Quote
Old 02-03-2008, 11:41 AM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,838
Total Cats: 1,787
Default

do you even know what the +22.5 does?

your adding 22.5 trigger angle!

if you set you timing without it, then leave it at 0. if you set you timing with it, leave the addition.

it's there because you don't want a trigger angle between 14-45, so you add 22.5 with that option and you change change the other number above it so it's outside that range again.
Braineack is offline   Reply With Quote
Old 02-03-2008, 04:14 PM   #4
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Jun 2007
Location: Overland Park, Kansas
Posts: 5,382
Total Cats: 43
Default

Well I figured that much about the trigger angle addition, was mostly tinkering wondering why my idle was so high.
elesjuan is offline   Reply With Quote
Old 02-03-2008, 04:21 PM   #5
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,359
Total Cats: 1,323
Default

You have the idle screw turned down all the way?
Savington is offline   Reply With Quote
Old 02-03-2008, 05:33 PM   #6
Elite Member
Thread Starter
iTrader: (11)
 
Join Date: Jun 2007
Location: Overland Park, Kansas
Posts: 5,382
Total Cats: 43
Default

Just checked the idle screw and its backed out ALL the way. Unhooked the idle air control valve, idles down fine. Checked the settings in megatune and I had the idle valve frequency at 26, switched it to 62 and idles solid at 850 and smooth.

Still need to figure out my Tach problem. Checked pin 2I at boomslang and I've got frequency. Checked at the DL connector labeled IG- and got nothing. Next thing I need some longer leads on my multimeter then I'm going to check resistance between that point on the DL connector and the boomslang. Not sure why it'd have stopped working? Far as settings go in megatune for the tach, theres not much to mess up. Since I'm getting frequency out of the megasquirt it should show something on the tach, but appears the signal isn't getting there.

All the driving I did last night I have a pretty good fuel table I think, just need to figure out my spark table. 38 degrees out this morning and it fired right up, so thats a good thing.
elesjuan is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
01-05 Fab9 PNP COPs (used) FrankB Miata parts for sale/trade 6 09-30-2015 12:48 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:26 PM.