Installed DIY MS. So far so good. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 01-12-2008, 03:20 AM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2006
Location: Sydney Australia
Posts: 138
Total Cats: 0
Default Installed DIY MS. So far so good.

Hi Guys.

First of all a huge thanks for Braineack's post which convinced me to take the leap, a second (but no less worthy) thank you to Samlo1 for shipping me some harness connectors too.

I hooked up the MS in parallel without hooking up the injectors or coils until my wideband arrives from your side of the pond, and all readings seem normal, there was more noise overall in the system until I uncrossed the signal/body grounds to the MS

I currently have the HKS Fcon mini taking care of the fuel until the wideband arrives and Im brave enough to tap the MS in.

I am thinking of taking control of the ignition before the wideband arrives, which will give me an appreciation of the tune. Therefore leaving the HKS to control fueling.

What do you guys think?
ampz is offline   Reply With Quote
Old 01-12-2008, 03:27 AM   #2
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Sounds like a good plan. Hurry up with the wideband already though. Makes life soo much better. What injectors?
cjernigan is offline   Reply With Quote
Old 01-12-2008, 09:33 AM   #3
Junior Member
Thread Starter
 
Join Date: Mar 2006
Location: Sydney Australia
Posts: 138
Total Cats: 0
Default

Standard 1.6 injectors. The Fcon increases their opening time with rpm, the kit is making the original 5 psi with an ebay fmic.

I have 315cc injectors which are ready to go in, but i will do so once the lc1 arrives and i tap it into the exhaust.

The car fired right up with the MSPNP ignition table. But it is a little aggresive under boost. With the wastegate open it was running very nicely, it pinged as soon as i put the actuator back on (1 pull). I'll look around for a ignition map that will suit.

One weird thing is, the car is running smoother than ever, rpm is stable in megatune, but the tach is all over the place other than idle. Just the dashboard tach. It was fine when running cop whilst the mazda ecu was driving them. The only change i guess would be the lesser dwell time (running) of 2.5ms.
ampz is offline   Reply With Quote
Old 01-12-2008, 02:34 PM   #4
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

The ignition map you have is probably the best one you can possibly use outside of a custom dyno tune. Take the DIY map and retard it 3 degrees in boost. Try that first.
cjernigan is offline   Reply With Quote
Old 01-12-2008, 05:39 PM   #5
Junior Member
Thread Starter
 
Join Date: Mar 2006
Location: Sydney Australia
Posts: 138
Total Cats: 0
Default

Thanks CJ i will try that.
I do still have quite a bit of noise in the system, i suspect the grounds are a little insufficient. I have 4 gounds from the MS pins 7, 8+9, to 2A, 2C and 17,18 +19 to 2B, 2D. Swapping over 2C with 2D made it less noisy but it is still quite noisy.

Name:  graph.png
Views: 1
Size:  7.2 KB

Don't mind the o2 raeding, it is reading voltage out of my narrowband right now.
It wasn't noisy beore the MS, I noticed Joe has slightly different grounds on his harness pinout. I will try a couple of grounds strapped to the back of the head this morning too.

Oh one other thing. When you first power up the car, the coils (cop) buzz for a second and the tach needle spikes to 6000rpm on the dash. But then everything runs smooth.

Update:
The weirdness with the coils has been fixed (added a ground to the head from the coils) then 2 additional grounds from the megasquirt to the head and all is fine.

The Fcon freaked out and would lose its **** occasionally with the MS, so the MS is controlling fuel and spark, as a safeguard I have added 20 points to the pnp map in fuel until i get the lc1.

Last edited by ampz; 01-12-2008 at 10:50 PM.
ampz is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:18 AM.