Low Imp injector still a no go? - Miata Turbo Forum - Boost cars, acquire cats.

MEGAsquirt A place to collectively sort out this megasquirt gizmo

Low Imp injector still a no go?

Old 03-30-2007, 10:28 PM
  #1  
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2006
Location: Ontario, Canada
Posts: 83
Total Cats: 0
Default Low Imp injector still a no go?

Has everyone given up on using these?

I have a set kicking around from a year ago picked them up for cheap, looks like I wont be needing them.

Is it just on miata applications that the low imp injectors don't work or is this a MS issue in general?
2004GS is offline  
Old 03-30-2007, 10:29 PM
  #2  
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,140
Total Cats: 6
Default

You can use the low imp injectors, long as you wire in resistors. Pretty sure Al Hounos is using a set.
cjernigan is offline  
Old 03-30-2007, 10:54 PM
  #3  
Supporting Vendor
iTrader: (5)
 
Join Date: Jun 2006
Location: Duluth, GA 30097
Posts: 798
Total Cats: 0
Default

With a v3.0 PCB MS you can use low-z injectors without the resistor pack. You'll just need to tune the PWM settings as per the MegaManual....
__________________
Jerry a.k.a. 'FoundSoul'
DIYAutoTune.com
'91 Miata BEGi S3 GT2560 w/ MSPNP - 14.1psi - 253whp, 232wtq
'95 Miata n/a
A few other cars....
FoundSoul is offline  
Old 03-31-2007, 06:33 AM
  #4  
Elite Member
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,641
Total Cats: 41
Default

Originally Posted by FoundSoul View Post
With a v3.0 PCB MS you can use low-z injectors without the resistor pack. You'll just need to tune the PWM settings as per the MegaManual....
I can't remember who it was, but they found that with the Mx5 mods the low Imp stuff didn't work prooperly?
richyvrlimited is offline  
Old 03-31-2007, 08:58 AM
  #5  
Supporting Vendor
iTrader: (5)
 
Join Date: Jun 2006
Location: Duluth, GA 30097
Posts: 798
Total Cats: 0
Default

Weird... and to be honest I can't see why that would be the case. I'll test it out when I get the chance.
__________________
Jerry a.k.a. 'FoundSoul'
DIYAutoTune.com
'91 Miata BEGi S3 GT2560 w/ MSPNP - 14.1psi - 253whp, 232wtq
'95 Miata n/a
A few other cars....
FoundSoul is offline  
Old 03-31-2007, 01:52 PM
  #6  
Senior Member
 
Join Date: Oct 2005
Location: Knoxville
Posts: 1,168
Total Cats: 0
Default

it may be due to poorly chosen grounds on my part, but yeah I always got tach spikes/drops with low imp injectors in PWM mode.
Al Hounos is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Full_Tilt_Boogie
Build Threads
63
08-09-2018 07:54 PM
90 Turbo
MEGAsquirt
19
10-19-2015 04:23 PM
Trent
WTB
2
10-01-2015 01:15 PM
The Gleas
MEGAsquirt
3
10-01-2015 10:30 AM
JesseTheNoob
DIY Turbo Discussion
15
09-30-2015 03:44 PM


Quick Reply: Low Imp injector still a no go?


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.