LS Coil question - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 05-06-2016, 01:24 AM   #1
Junior Member
Thread Starter
 
Join Date: Jun 2008
Location: Delhi CA
Posts: 91
Total Cats: 0
Default LS Coil question

I am hoping someone could double check my wiring for my 95 Miata and LS1/D580....since my car doesn't want to start. My current wiring is: BROWN/YELLOW - SIGNAL 1&4, BROWN - SIGNAL 2&3, BLACK - GOUND, BLACK/WHITE - GROUND, BLUE - 12V. To help illustrate what I've done, I made a terrible, terrible MS Paint drawing.



I would also like any input on my dwell settings:



Thank you in advance.
Attached Thumbnails
LS Coil question-ls1%2520wiring.jpg   LS Coil question-dwell%2520settings.jpg  
Gregor is offline   Reply With Quote
Old 05-06-2016, 02:32 PM   #2
Ich verstehe nur Bahnhof
iTrader: (3)
 
psyber_0ptix's Avatar
 
Join Date: Mar 2012
Location: Northern VA
Posts: 3,709
Total Cats: 319
Default

output test mode. are you getting spark at all or is it just a fucked up firing order?
psyber_0ptix is offline   Reply With Quote
Old 05-06-2016, 03:28 PM   #3
Junior Member
Thread Starter
 
Join Date: Jun 2008
Location: Delhi CA
Posts: 91
Total Cats: 0
Default

I didn't have time to test last night, I will today as soon as I get off work.
Gregor is offline   Reply With Quote
Old 05-06-2016, 08:51 PM   #4
Senior Member
iTrader: (1)
 
Join Date: Dec 2010
Location: Farmington Hills, MI
Posts: 878
Total Cats: 93
Default

That cranking dwell looks way too high for LS coils.
acedeuce802 is offline   Reply With Quote
Old 05-06-2016, 10:15 PM   #5
Junior Member
Thread Starter
 
Join Date: Jun 2008
Location: Delhi CA
Posts: 91
Total Cats: 0
Default

What would you recommend for cranking dwell?

I tried test the spark out put, nothing on any of the plugs. I'm going to undo my wiring loom and re-check my wiring.
Gregor is offline   Reply With Quote
Old 05-07-2016, 06:38 PM   #6
Junior Member
Thread Starter
 
Join Date: Jun 2008
Location: Delhi CA
Posts: 91
Total Cats: 0
Default

I figured it out. It appears that the ground from the LS1(D580) coils has to go to an engine ground, not the BLACK/WHITE wire on the Miata harness. The car now starts ups very quickly and idles very stable. Now, to turn up the boost!
Gregor is offline   Reply With Quote
Old 05-07-2016, 07:29 PM   #7
Junior Member
 
Join Date: Dec 2009
Location: Brisbane, AUSTRALIA
Posts: 486
Total Cats: 45
Default

Quote:
Originally Posted by Gregor View Post
I figured it out. It appears that the ground from the LS1(D580) coils has to go to an engine ground, not the BLACK/WHITE wire on the Miata harness. ...
Like many other readers of this thread, I'd ASSUMED that you you knew this already - otherwise there's no point having 2 grounds on each coil AND the Miata harness.
The https://www.miataturbo.net/diy-turbo...-thread-82744/ thread consolidates most of the info about LSx coils and the LS1 diagram shows separate grounds, "Signal Ground (at Sequencer)" and "Ground (near Coil)".
I added the L2 Wasted Spark MSM wiring diagram and specified "ECU igniter" and "Engine Ground" to make this clear.

We all make these sort of mistakes at some time so thanks for posting your "solution" to close out the thread properly.
I hate it when people post problems but don't post their solutions, it's not clear whether they've just given up or solved the problem and not shared it (which sucks for others later on with similar issues).
You can bet someone else will do what you did and will read the solution here,
Lokiel is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
WTB: Xede Wiring Harness for 1999 Miata mattk3650 WTB 1 05-13-2016 02:02 PM
Car cranks over but won't fire, no spark or fuel boileralum ECUs and Tuning 11 05-13-2016 10:10 AM
MS3X VVT - no crank and cam signal issue coma MEGAsquirt 35 05-12-2016 02:45 PM
Fancy intake for not so fancy Miata Charmin89 Fabulous Fabrication 11 05-03-2016 10:04 AM
Miata vs Viper ApexAddict Media 9 05-02-2016 10:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:30 AM.