Map sensor and high idle - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 10-01-2016, 07:52 PM   #1
Junior Member
Thread Starter
 
Join Date: Jun 2016
Location: Wichita, Kansas
Posts: 92
Total Cats: 3
Default Map sensor and high idle

Hey guys, I am running ms2 and am trying to dial my idle down. For some reason I am going straight to 2800 as soon as the engine starts. I've tried everything but it seems like the IAC doesn't want to cooperate. Im thinking it could be my map sensor settings but I'm unsure. Base timing is set to 10 degrees, afr's are a little rich but I'll turn those down when I'm able to idle lower. Thanks for your time.


High Idle.msq
Jmanwork is offline   Reply With Quote
Old 10-02-2016, 08:43 PM   #2
Junior Member
Thread Starter
 
Join Date: Jun 2016
Location: Wichita, Kansas
Posts: 92
Total Cats: 3
Default

Tried a few different things today with no luck, even with the idle control valve turned off I'm still idling heckahigh. Here's a short data log as I shut it off before it revs too high at idle. I don't think its my MAP sensor im getting ~95kpa from it.

2016-10-02_19.33.26.msl
Jmanwork is offline   Reply With Quote
Old 10-03-2016, 09:47 AM   #3
Junior Member
 
Join Date: Jan 2016
Location: Akron, Ohio
Posts: 205
Total Cats: 22
Default

Are you getting ~95kpa while idling at 2800?
Joseph Conley is offline   Reply With Quote
Old 10-03-2016, 09:54 AM   #4
Junior Member
Thread Starter
 
Join Date: Jun 2016
Location: Wichita, Kansas
Posts: 92
Total Cats: 3
Default

Quote:
Originally Posted by Joseph Conley View Post
Are you getting ~95kpa while idling at 2800?
No to clarify, 95kpa with the engine off.
Jmanwork is offline   Reply With Quote
Old 10-05-2016, 01:49 PM   #5
Junior Member
Thread Starter
 
Join Date: Jun 2016
Location: Wichita, Kansas
Posts: 92
Total Cats: 3
Default

For anyone who runs into the problem of high idle here was my solution. I had a air leak which was causing a way higher pressure than desired in my intake manifold. I would recommend first checking for air leaks!
Jmanwork is offline   Reply With Quote
Old 10-06-2016, 02:57 AM   #6
Newb
iTrader: (1)
 
Join Date: Sep 2015
Posts: 31
Total Cats: 1
Default

^Yes, check for vacuum leaks.
Also try selecting "inverted" instead of "normal" or vice versa under the Idle Valve Settings and see if that helps.
pakmx5 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2 sets 15x10 - Silver Jongbloed and Nickel 6ULs SUV-ETR Miata parts for sale/trade 12 12-08-2016 03:49 PM
INNOVATE MTX-L Wideband Sensor broken? 88hk General Miata Chat 4 09-29-2016 02:35 PM
Need serious help with wiring my MS2 here :/ Windsteed MEGAsquirt 10 09-29-2016 09:23 AM
Engine Timing Woogi Engine Performance 7 09-28-2016 05:40 PM
Running way rich at idle mike103 MEGAsquirt 3 09-12-2016 06:48 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:57 AM.