MegaSquirt install - turns over, won't start. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-02-2011, 07:57 PM   #1
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default MegaSquirt install - turns over, won't start.

All right. Just installed my MegaSquirt2 (V3 board) today, everything reads out as expected on TunerStudio.

Go to start it, it turns over nice and healthily, but it won't start. Fuel pump is on and getting fuel pressure there. Swapping over to the stock ECU, it starts fine.

Looking for advice on what I did wrong with the attached basemap and log - as it's basically the DIYAutotune basemap however, I'm not sure what would be wrong with it.

Thank you!

(Edit) Specs:

Stock '91 1.6 with AFM and no mods yet.
Attached Files
File Type: msq 2011-03-02_14.21.41.msq (51.4 KB, 90 views)
File Type: msl 2011-03-02_13.51.24.msl (621.9 KB, 96 views)

Last edited by blaen99; 03-02-2011 at 08:09 PM.
blaen99 is offline   Reply With Quote
Old 03-02-2011, 08:15 PM   #2
Elite Member
iTrader: (10)
 
Join Date: Oct 2008
Location: Seattle, Wa
Posts: 1,780
Total Cats: 30
Default

The log has nothing in it except TPS and some random glitches.

Post pics of your harness and the board.
Jeff_Ciesielski is offline   Reply With Quote
Old 03-02-2011, 08:18 PM   #3
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

Quote:
Originally Posted by Jeff_Ciesielski View Post
The log has nothing in it except TPS and some random glitches.

Post pics of your harness and the board.
Harness is wired up as per



Board was made by someone else, claimed working.
blaen99 is offline   Reply With Quote
Old 03-02-2011, 08:24 PM   #4
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

You sure it's a Miata basemap? Not sure why a NA Miata map would be set up as Twin Trigger tach input mode.
Ben is offline   Reply With Quote
Old 03-02-2011, 08:25 PM   #5
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

Unfortunately, that's how it was loaded in my Tunerstudio Ben.

To say the least, I'm befuddled as to how that would happen.

(Edit) Looking closer at this, I have no idea how that basemap was imported that way. Does someone have a MS2Extra 2.1 basemap they could point me towards, to see if this is duplicable behavior?
blaen99 is offline   Reply With Quote
Old 03-02-2011, 08:30 PM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

tell me your complete setup and I'll create a basemap for you.



and where did you put the fan mod? ebc? etc?
Braineack is online now   Reply With Quote
Old 03-02-2011, 08:37 PM   #7
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

According to the seller,

Quote:
It was built following DIY Auto-Tune's guide for the 1990-1993 Miata

Last edited by blaen99; 03-03-2011 at 03:43 PM.
blaen99 is offline   Reply With Quote
Old 03-03-2011, 09:32 AM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

you need to open it up and take pictures of the top and bottom of the board.
Braineack is online now   Reply With Quote
Old 03-03-2011, 01:47 PM   #9
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

All right.
Attached Thumbnails
MegaSquirt install - turns over, won't start.-0303010942.jpg   MegaSquirt install - turns over, won't start.-0303010941.jpg  
blaen99 is offline   Reply With Quote
Old 03-03-2011, 01:49 PM   #10
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

this MS2 was built using the MSI input circuit. it'll never run as is.
Braineack is online now   Reply With Quote
Old 03-03-2011, 01:59 PM   #11
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

Seriously? Jesus christ. I was told differently by the seller.

Last edited by blaen99; 03-03-2011 at 03:43 PM.
blaen99 is offline   Reply With Quote
Old 03-03-2011, 02:01 PM   #12
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

It looks built okay, but the tach input mods so see on the underside were for the MS-I inputs. It needs to be modified so the MS2 can get the CAS signals.

are you handy with an iron?
Braineack is online now   Reply With Quote
Old 03-03-2011, 02:02 PM   #13
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

Decently handy, yeah.
blaen99 is offline   Reply With Quote
Old 03-03-2011, 02:06 PM   #14
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

do this:






the yellow wires need to be added and go to the LED pins that the small length of black wire attach to. I just realized there's no spark outputs either. lolz
Braineack is online now   Reply With Quote
Old 03-03-2011, 03:38 PM   #15
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

Wow, whod you buy that from? lol
Marc D is offline   Reply With Quote
Old 03-03-2011, 03:43 PM   #16
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

blaen99 is offline   Reply With Quote
Old 03-03-2011, 03:48 PM   #17
Elite Member
iTrader: (46)
 
Stein's Avatar
 
Join Date: Dec 2007
Location: Nebraska
Posts: 4,812
Total Cats: 138
Default

Well, instead of saving 10 hours of soldering for $100, you get to save 9-ish.
Stein is offline   Reply With Quote
Old 03-03-2011, 04:03 PM   #18
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

There's only like 15-20 minutes more work left on the board, if even that. Want me to time/video it? Blaen is sending it to me to just get 'er done for him.
Braineack is online now   Reply With Quote
Old 03-03-2011, 04:30 PM   #19
Elite Member
Thread Starter
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,112
Total Cats: 27
Default

That and to fix my shitty harness job.

Better in Brain's hands at this point then mine, I'd have to rush the build like mad instead of putting in a working MS and working on the damn car.
blaen99 is offline   Reply With Quote
Old 03-03-2011, 05:50 PM   #20
Elite Member
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default

I like the complete absence of ignition outputs on that board.

Seller failed miserably at building the MS properly. Unlucky OP, but at least you've got Brain to fix it for you
richyvrlimited is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM


Tags
joe perez

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:12 PM.