MEGAsquirt A place to collectively sort out this megasquirt gizmo
Sponsored by:
Sponsored by:

Megasquirt PNP Gen 1 no spark on 1 and 4

 
Old 09-27-2018, 08:13 PM
  #1  
Newb
Thread Starter
 
Join Date: Sep 2018
Posts: 2
Total Cats: 0
Default Megasquirt PNP Gen 1 no spark on 1 and 4

I was at an autocross this weekend and the car started up and ran fine. Let it warm up in grid and shut it down. When I took my run the car was running like crap. Still 14th fastest out of 65 drivers with on one run with 2 cylinders.

Came back to grid and diagnosed that I had no spark one cylinders 1 and 4. Since I switched to COP a month ago I assumed that was the problem. After checking the wiring and re-soldering some connections I still had no luck. After getting back home I checked the CAS and one of trigger signals wasn't working while cranking (checking with a volt meter). So I got an NB CAS off ebay. The CAS that was in the car was the original optical NA style. Problem is I'm still not getting a trigger signal from the ECU. I've checked the CAS signals at the ECU and they appear good. Check the ignition trigger signals at the ECU and only one is working. I put back on the stock coils and igniter and same thing, no spark on 1 and 4.

I'm thinking it's a problem in the ECU. Might have done something stupid while messing with the ignition wiring in the pits. The NB CAS should work shouldn't it? Is there anything else to check? Thanks.
q2slinger is offline  
Old 09-28-2018, 09:22 AM
  #2  
Junior Member
 
Join Date: Jun 2015
Location: VIC, Australia
Posts: 131
Total Cats: 17
Default

Wait wait..you got an NB CAS? You mean NA8? NB uses completely different seperate cam / crank sensor. (I'm assuming your car is an NA).
You also can't test the cam/crank sensor signals with a multimeter. You need an oscilloscope. Luckily you can check them using Tunerstudio and the tooth logger.
Also if you're getting spark on cylinders 2 & 3 while cranking then its not an issue with the CAS as its reading rpm correctly or else the ECU wouldn't fire the ignition coils.
Barton is offline  
Old 09-28-2018, 10:01 AM
  #3  
Newb
Thread Starter
 
Join Date: Sep 2018
Posts: 2
Total Cats: 0
Default

Yep, it's an NA8 CAS. The car is a 1990 with a 1.8 swap.
q2slinger is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Johnny Tater
MSPNP
1
09-27-2015 12:38 AM
nickt93
Miata parts for sale/trade
0
04-14-2015 12:26 PM
AdoboMiata
MEGAsquirt
4
11-27-2014 09:18 PM
jimboy15
MSPNP
2
08-11-2014 04:08 PM
beansrown
WTB
2
01-21-2013 08:36 PM


Thread Tools
Search this Thread
Quick Reply: Megasquirt PNP Gen 1 no spark on 1 and 4


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.