MS-II Firmware, where and what? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 09-13-2009, 10:08 PM   #1
Slowest Progress Ever
Thread Starter
iTrader: (26)
 
thirdgen's Avatar
 
Join Date: Oct 2007
Location: The coal ridden hills of Pennsylvania
Posts: 5,806
Total Cats: 183
Default MS-II Firmware, where and what?

So I am attempting to run MS-II with Abe's PNP adapter board. I just now finally downloaded my firmware from here...
MS2/Extra Manual Index
I downloaded the MS II release 2.0.1 setup
What should I download so I can start getting this MS-II to read and work?
thirdgen is offline   Reply With Quote
Old 09-13-2009, 10:15 PM   #2
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

MegaSquirt Software and Firmware - MegaTune - MSnS-E

I assume most of the forum is still using MegaTune, but I'm converted over to TunerStudio. It's an awesome program.

Why 2.0.1? 2.1.0 has been out for a while. I'm running 2.1.1b.
Ben is offline   Reply With Quote
Old 09-13-2009, 10:18 PM   #3
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

Er, dont use the 2.0.1 release code.

Have you tried TunerStudio yet? Its easy to get it to talk to your computer/MS by just creating a new project and selecting the firmware when you download it to your computer. And its visually appealing ^_^

Again, Dont use the 2.0.1 firmware. Theres a lot of improvement that can be utilized with the newer beta/alpha codes. Im currently flashed the newest alpha code released a couples of days ago.

Heres a link: http://www.msextra.com/ms2extra/file...ha20090912.zip

This is code 3.0.3 alpha. YOu can read the changes on the thread here:
MSx/Extra EFI • View topic - MS2/Extra Alpha 3.0.3 20090912
Marc D is offline   Reply With Quote
Old 09-13-2009, 10:28 PM   #4
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Hmmm. Be careful with that one Marc. When I was at DIY Autotune yesterday, Jerry had an NA miata on the dyno running "the newest code released a few days ago." I didn't realize that they just released a 3.0 code and assumed it was 2.1.1b. Now I'm thinking it was this 3.0 alfa. The car on the dyno had uneven dwell times on the two coils. One was overdwelled as confirmed by o-scope.

This was on the 4AGE settings, which may not even apply to 99-00 settings, so this could all be nothing. But then it might be something. Jerry was getting with the MS coders and is going to have more info in the next few days.
Ben is offline   Reply With Quote
Old 09-13-2009, 11:13 PM   #5
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

Hrmmm... Really. Geez. Well I could just revert back to the newest 2.1.1b, released a few days ago too, it shouldn't be a problem. I was just excited for that version, because they said they rearranged code to allow higher idle valve frequency (up to 457Hz). Well, the 2.1.1b has this change too.
Marc D is offline   Reply With Quote
Old 09-14-2009, 08:48 AM   #6
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Don't get too carried away as it could be a non issue.
Ben is offline   Reply With Quote
Old 09-14-2009, 02:06 PM   #7
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

Kinda funny, they just updated with a new firmware just 2 days ago, didn't even realize it.
Marc D is offline   Reply With Quote
Old 09-17-2009, 01:58 AM   #8
Slowest Progress Ever
Thread Starter
iTrader: (26)
 
thirdgen's Avatar
 
Join Date: Oct 2007
Location: The coal ridden hills of Pennsylvania
Posts: 5,806
Total Cats: 183
Default

I just downloaded tuner studio. It looks pretty cool. Actually it looks like a futuristic version of Megatune. So I click "File" then "New project". I go to ECU Definition and select "MS2EXTRA rel 2.0.1n", or do I select "MS2Extra rel 2.0.1p"?
thirdgen is offline   Reply With Quote
Old 09-17-2009, 02:04 AM   #9
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

Depending on the version you upload, all you have to do is locate the ms2.ini file to be sure you use the right version. That is the safest way, honestly. The code has many revision changes, and even though it has the same signature, it could be a different code all together. If you download the firmware, it should be in the same folder i.e. the same folder with the "download.bat" file.

Dont use the uS.ini. Thats obviously for microsquirt.
Marc D is offline   Reply With Quote
Old 09-17-2009, 02:08 AM   #10
Slowest Progress Ever
Thread Starter
iTrader: (26)
 
thirdgen's Avatar
 
Join Date: Oct 2007
Location: The coal ridden hills of Pennsylvania
Posts: 5,806
Total Cats: 183
Default

I downloaded this:
http://www.msextra.com/ms2extra/file...ha20090912.zip
It's on my laptop right now, but my intake tube is in my locker at work so I can weld my IAT bung onto it. I still should be able to plug the MS in and burn the stuff to it. Maybe tomorrow morning will be the time. I just wanna get all this software downloaded that I need, right now.
thirdgen is offline   Reply With Quote
Old 09-17-2009, 02:41 AM   #11
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

you dont even need to burn the new firmware to the MS to make a new project using the new code. Just create the new project, and on the select code, click "Other" or "browse" and just look for the code in that folder you unzipped. Its simple.
Marc D is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
No spark while cranking? navalhawkeye MEGAsquirt 9 10-07-2015 08:10 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
In need of base map for stock 1997 brandonbkd MEGAsquirt 0 09-29-2015 12:52 AM
MS3 Basic Connection Issues EErockMiata MEGAsquirt 6 09-24-2015 10:49 AM
ms2e No Rpm Signal Dobzeh ECUs and Tuning 5 09-17-2015 03:56 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:16 PM.