MS No power? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 08-20-2009, 02:35 PM   #1
Junior Member
Thread Starter
 
Join Date: Feb 2007
Posts: 125
Total Cats: 0
Default MS No power?

I had 2 working megasquirts. Both would light the 2 outside LEDs with ignition on.

For some reason, now one will work and light the LEDs, but the other doesnt seem to be getting power? I literally unplug one from the harness and plug in the other and nothing.

Ive tried it on the stim, nothing. Tried reflashing firmware with and without boot jumper, nothing.

What have I blown?!

:(
DMRider_10 is offline   Reply With Quote
Old 08-20-2009, 02:37 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

what happens if you swap the CPUs?
Braineack is offline   Reply With Quote
Old 08-20-2009, 03:07 PM   #3
Junior Member
Thread Starter
 
Join Date: Feb 2007
Posts: 125
Total Cats: 0
Default

Erm unfortunately first time round I soldered the CPU in, 2nd time I used a holder, sorry :(
DMRider_10 is offline   Reply With Quote
Old 08-20-2009, 03:35 PM   #4
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,328
Total Cats: 1,926
Default

Well, obviously you need to start with the power supply section, which is page 6 of the schematic. Fortunately it's pretty simple. On the stim, verify +12 going into U5 (measure at the striped side of D9) and +5 coming out of U5 (measure at non-striped side of D9), both relative to ground.

Verify +5 coming out of F1 (measure at striped side of D19).

Verify +5 at pins 1 and 20 of U1.
Joe Perez is offline   Reply With Quote
Old 08-26-2009, 09:47 PM   #5
Junior Member
Thread Starter
 
Join Date: Feb 2007
Posts: 125
Total Cats: 0
Default

Finally found a minute to check these.

Banded side of D9 = 7.6v
Non banded side of D9 = 5v
Banded side of D19 = 5v
U1 Pin 1 = 5v
U1 Pin 20 = 5v

All taken using the metal strip as ground and tested with different batteries on the stim

Also not sure if it has any relevance but PMP is constantly flashing on the stim?

???
DMRider_10 is offline   Reply With Quote
Old 08-27-2009, 01:32 PM   #6
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

It sounds like your 9 volt battery is almost dead.
Matt Cramer is offline   Reply With Quote
Old 08-27-2009, 01:50 PM   #7
Junior Member
Thread Starter
 
Join Date: Feb 2007
Posts: 125
Total Cats: 0
Default

I tried 2 different batteries. Putting the multimeter between the terminals of the batteries, one reads 8.98v the other 8.76v, so neither are particularly bad? Not to mention the value given at Banded side of D9 was exactly the same with either battery
DMRider_10 is offline   Reply With Quote
Old 08-27-2009, 02:40 PM   #8
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,328
Total Cats: 1,926
Default

Batteries will always measure higher when you're testing them with no load. There's a reason your car battery puts out >12v when it's just sitting there, but drops to 9 or 10 when the starter is turning.
Joe Perez is offline   Reply With Quote
Old 08-27-2009, 02:50 PM   #9
Junior Member
Thread Starter
 
Join Date: Feb 2007
Posts: 125
Total Cats: 0
Default

ok I will test with a new battery then. Will get back to you later on when Ive got one
DMRider_10 is offline   Reply With Quote
Old 08-27-2009, 02:54 PM   #10
Junior Member
Thread Starter
 
Join Date: Feb 2007
Posts: 125
Total Cats: 0
Default

Found another 9v that reads 9.2v when tested with multi meter? Must be a healthier one?

That gives me 8v at banded end of D9.

I will still get a brand new one and retest later though
DMRider_10 is offline   Reply With Quote
Old 08-27-2009, 06:41 PM   #11
Junior Member
Thread Starter
 
Join Date: Feb 2007
Posts: 125
Total Cats: 0
Default

Brand new battery reading 9.5v with the Multi meter, Banded side of D9 varies between 8.18v and 8.3v
DMRider_10 is offline   Reply With Quote
Old 08-29-2009, 01:52 PM   #12
Junior Member
Thread Starter
 
Join Date: Feb 2007
Posts: 125
Total Cats: 0
Default

Any ideas on what else I can check to confirm whats up?

Thanks alot
DMRider_10 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Garrett Turbo, 1.8 Oil Pan, & Misc. Stuff nbdooey Miata parts for sale/trade 9 08-30-2017 10:50 PM
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:51 PM.