ms-pnp weird inj behavior - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 08-11-2008, 06:10 PM   #1
Senior Member
Thread Starter
iTrader: (2)
 
dc2696's Avatar
 
Join Date: May 2005
Location: Edmonton Ab, Canada
Posts: 1,176
Total Cats: 13
Default ms-pnp weird inj behavior

Long story short mspnp is in fired up fine was doing some light drives and noticed I was way rich but not only that but the wideband was fluctuating from 14 to 10 wildly then it would be fine for awhile...

I follow the problem to the pulse width and duty cycle gauges which for some reason are steady one minute (as steady as they get atleast varying only by points) then jumping around like ******* crazy, up from 5 to 10percent the next!

It doesn't seem to do it more or less during cruise or accel but it is much more noticeable during accel,obviously.

During mild accel duty cycles were going from 20 to 30per and pulse width was also jumping ten or so points.

The ve table is smoothed out abit as I thought it might have been going from one cell to another and they were to large of intervals but that's not the case either.

Injectors are rc370cc and have been in for a long time with
Any ideas?
dc2696 is offline   Reply With Quote
Old 08-11-2008, 10:38 PM   #2
Senior Member
iTrader: (5)
 
Join Date: Nov 2007
Location: Troy, MI
Posts: 860
Total Cats: 13
Default

how smooth is your VE map? if there is large change between the cells the situation you describe can occur.

EDIT just read the full post and maybe posting your msq and a log will help?
The_Pipefather is offline   Reply With Quote
Old 08-12-2008, 03:25 PM   #3
Senior Member
Thread Starter
iTrader: (2)
 
dc2696's Avatar
 
Join Date: May 2005
Location: Edmonton Ab, Canada
Posts: 1,176
Total Cats: 13
Default

Well after a 3hr drive this morning to work it dawned on me.

The map reading was moving alittle to much then I remembered that my leakdown test showed a 50per leak in cylinder 2 out the intake valve and 35per out cylinder 3 intake valve.

Soooo with all this pressure heading back into the intake no wonder the map is jumping and thus the injectors think she's getting more air lol.

Needless to say it sucks because the right way to fix it is a rebuild, but I'm going to try a restrictor to even out the readings, hopefully that woll work for the time being.
dc2696 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
MS PNP requires reading and following directions??? satisfied MEGAsquirt 141 10-06-2015 11:44 AM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
mslabs MS2 - Idle control issue ndragun MEGAsquirt 0 09-20-2015 11:28 PM
Mystery Engine Trouble. Halp, mt.net! vehicular General Miata Chat 12 09-14-2015 04:17 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:35 PM.