MS1 drivability issues/questions - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 04-21-2011, 07:29 PM   #1
Senior Member
Thread Starter
iTrader: (9)
 
Join Date: Oct 2006
Location: Lexington SC
Posts: 1,003
Total Cats: 14
Default MS1 drivability issues/questions

I have had the MS1 installed on my 91 for over a year now. First on my old 200k mile 1.6 and now on the fresh 1.8 I installed over the winter, no turbo yet. Everything is tuned pretty well. It runs very well with no major issues.
At low rpm and low load (driving in parking lot in 1st) it is very toutchy on the gas. Its kinda hard to describe and has made it even harder to search for. It is like a little self induced oscillation that is very hard to control unless you give it a little more gas or speed up. It really sucks in stop/go traffic. I checked to see if maybe it was related to the fuel pressure regulator since it was happening at low maps and ran it for a while with the vacuum line diconnected and plugged. Still same behaviour. I built a MS1 years ago for my brothers FFR cobra and we had the same issue with it, I attributed it to alot of low end torque in a very light car and the nut behind the wheel. I definitely do not have that much torque in the 1.8 so I doubt that is the issue in the MS'ed Miata.
I have also noticed a very slight oscilation when cruising at 70mph some times. It is very subtle. I gave tried to correlate the oscillations with fluctuations in MAP or any other readings but MAP does not change at the rate that I feel the oscilations at cruise.
On my brother's cobra it improved greatly when he switched to MS2 a whie back, don't really know why, I think it might be due to MAP averaging or something.
Rallas is offline   Reply With Quote
Old 04-21-2011, 07:46 PM   #2
Elite Member
iTrader: (10)
 
Join Date: Oct 2008
Location: Seattle, Wa
Posts: 1,780
Total Cats: 30
Default

Are you running mapdot or TPSDot for AE?
Jeff_Ciesielski is offline   Reply With Quote
Old 04-21-2011, 09:25 PM   #3
Senior Member
Thread Starter
iTrader: (9)
 
Join Date: Oct 2006
Location: Lexington SC
Posts: 1,003
Total Cats: 14
Default

TPS using the 96 1.8 tps, had the same issue with the ford TPS on the 1.6 before the 1.8 swap.
Rallas is offline   Reply With Quote
Old 04-22-2011, 12:55 AM   #4
Elite Member
iTrader: (13)
 
Join Date: Dec 2009
Location: Fraser Valley, British Columbia
Posts: 2,502
Total Cats: 13
Default

My old MS1 drove better than my current Haltech in it's current state. Not much time has been done tuning it though for drivability. The Haltech surges a lot (no tps right now) and the MS1 never erally did (also no TPS).

I imagine though when I go back for the Rotrex tune with my BMW tps things will be completly diff.

It's all in the tune, not the hardware... for the most part.
falcon is offline   Reply With Quote
Old 04-22-2011, 01:00 AM   #5
Elite Member
iTrader: (10)
 
Join Date: Oct 2008
Location: Seattle, Wa
Posts: 1,780
Total Cats: 30
Default

Post up your map and a datalog of the surging.
Jeff_Ciesielski is offline   Reply With Quote
Old 04-22-2011, 09:24 AM   #6
Senior Member
Thread Starter
iTrader: (9)
 
Join Date: Oct 2006
Location: Lexington SC
Posts: 1,003
Total Cats: 14
Default

I will when I get home. I would not quite define it as surging, especially since I am running NA. It is just a slight oscilation in the power delivery. Its one of those weird things that is hard to describe unless you are sitting in the car. I was hoping that this might be a more common phenomena like the 65mph shimmy.
I went ahead and tuned with a target AFR that was constant accross the whole <2500rpm and <40kpa as well as a constant advance in the same area to ensure that I am not moving accross a timing change or fueling change which could cause any upsets or transients. The resulting VE table is smooth in the area as well.

I have tried two different MS1 boxes and both give the same results, not that that really proves anything.
Rallas is offline   Reply With Quote
Old 04-22-2011, 03:25 PM   #7
Junior Member
iTrader: (1)
 
Join Date: May 2009
Location: TN
Posts: 328
Total Cats: 4
Default

edit: nevermind I can't read

Last edited by southernmx5; 04-22-2011 at 08:55 PM.
southernmx5 is offline   Reply With Quote
Old 04-22-2011, 06:35 PM   #8
Senior Member
Thread Starter
iTrader: (9)
 
Join Date: Oct 2006
Location: Lexington SC
Posts: 1,003
Total Cats: 14
Default

???
Rallas is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Turbo 1995 Miata Low mileage Clean Tekel Cars for sale/trade 29 02-05-2016 05:16 PM
MS PNP requires reading and following directions??? satisfied MEGAsquirt 141 10-06-2015 11:44 AM
Drivability issues with rx-7 maf? Ben DIY Turbo Discussion 10 09-20-2009 11:05 AM
Idea for a long term project Arkmage Insert BS here 6 06-30-2007 03:30 PM
Next Step Shadow Prefabbed Turbo Kits 13 09-06-2006 11:47 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:49 PM.