MS1 v30 almost finished. have some questions - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 07-06-2011, 11:58 AM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default MS1 v30 almost finished. have some questions

I am nearly complete with my MS1 board assembly. I am stuck on the fuel pump circuit for a 90 1.6 liter. Is it possible to run the purple fuel pump wire from the DB37 connector to the fuel pump relay instead of building the circuit on the board? If so I think would rather do that. I am also confused with all of the firmware available and am not sure which would be best for my needs. As of now the car is 100% stock. I have everything for a turbo setup but I am waiting to get the MS1 installed and for me to get used to working with it first.
also since I have a 1.6 do I need to build a fan circuit in megasquirt or will the original sensor ground setup work just the same without the factory ecu installed? Just a not i have removed the a/c so that s taken out of the equation. Thanks for any help guys!
duffbuster243 is offline   Reply With Quote
Old 07-06-2011, 12:00 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,838
Total Cats: 1,787
Default

Well If you are running the AFM you dont even need it.

However, if you remove it you'll need to do something about it. The reason we do something special for it is becuase the AFM grounds the fuel pump relay, not the ECU.

So you have a few options. The easiest would be to run the purple wire to 2O in your harness, then at the AFM connector (once removed) you jump that pin and the fuel pump ground pin with a short piece of wire stuck into the end. the end. easy.

Another way would be installing the High Side Driver circuit. This powers the fuel pump up in a similar way to when you turn the key to ON and the fuel pump primes. You send 12v out to 1C and that in turn powers the fuel pump relay. the ST_SIGN fuse must be removed.

The last way is to run the purple wire under your dash across to the actual relay and connect it to the light green wire.
Braineack is offline   Reply With Quote
Old 07-06-2011, 12:59 PM   #3
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default

Quote:
Originally Posted by Braineack View Post
Well If you are running the AFM you dont even need it.

However, if you remove it you'll need to do something about it. The reason we do something special for it is becuase the AFM grounds the fuel pump relay, not the ECU.

So you have a few options. The easiest would be to run the purple wire to 2O in your harness, then at the AFM connector (once removed) you jump that pin and the fuel pump ground pin with a short piece of wire stuck into the end. the end. easy.

Another way would be installing the High Side Driver circuit. This powers the fuel pump up in a similar way to when you turn the key to ON and the fuel pump primes. You send 12v out to 1C and that in turn powers the fuel pump relay. the ST_SIGN fuse must be removed.

The last way is to run the purple wire under your dash across to the actual relay and connect it to the light green wire.
Thanks for the quick reply.

I do plan on removing the AFM, the first option sounds best for me. I would run the purple fuel pump wire from pin 37 on the db37 to the 2O pin on the harness which is the pin right next to the yellow coolant wire as per this pinout: http://www.boostedmiata.com/gallery2...ne_harness.jpg correct?

any idea which pins I jump at the AFM plug?
duffbuster243 is offline   Reply With Quote
Old 07-06-2011, 01:12 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,838
Total Cats: 1,787
Default

correct.

you'd jump pins 6 & 1 depending how you look at it.

Assuming the AIT senor pin is 7, then you can go by that.
Braineack is offline   Reply With Quote
Old 07-06-2011, 08:33 PM   #5
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default

Ok so now I'm a bit mixed up with the firmware. I would like to use the MSPNP startuop map which has the .029v firmware. I load the firmware in and the stimulator works in megatune until I load the .msq file in. After that I no longer get an rpm readout in megatune. Is this normal or do I have a problem?
duffbuster243 is offline   Reply With Quote
Old 07-06-2011, 09:37 PM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,838
Total Cats: 1,787
Default

regular stim or jimstim?


the regular stim cannot output the trigger wheel of the miata, thus no rpms.
Braineack is offline   Reply With Quote
Old 07-06-2011, 10:31 PM   #7
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default

Quote:
Originally Posted by Braineack View Post
regular stim or jimstim?


the regular stim cannot output the trigger wheel of the miata, thus no rpms.
I figured it out. I changed the trigger in megatune off of generic wheel and noticed that the rpms work (I reloaded the map after to preserve the original settngs). I concluded that the megastim doesn't provide the correct input. So all seems to be working as it should. I'm going to plug it in tomorrow and cross my fingers.

I appreciate the help being a noob. I'll let you know how it turns out.
duffbuster243 is offline   Reply With Quote
Old 07-08-2011, 06:41 PM   #8
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default

Plugged it in with the mspnp base tune for 90-93 no afm and it started right up.
thanks a bunch for the help.
I started playing with tunerstudio and ve analyze live and it works great so far. 2 problems I have is between 2k and 3k rpm under moderate throttle I get knock, and I also get knock when tipping into the throttle from idle. I figure I should retard the timing a little bit in the range I get knock but what about the tip in from idle?
duffbuster243 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
15x10 - 15x11 6UL @ 949 Racing emilio700 Wheels and Tires 151 06-02-2017 03:36 PM
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
NA Seat Sliders and Seat Belt Receivers skipstr Miata parts for sale/trade 2 09-28-2015 11:53 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:17 PM.