MS2 1.6 Fuel Pump Mod on SPR4? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-03-2015, 01:29 AM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2013
Posts: 79
Total Cats: -8
Default MS2 1.6 Fuel Pump Mod on SPR4?

I used SPR4 to run 12V for the fuel pump mod on my ms2. It's not working when I hook up the MS to my car. I had to jump GDN and FP on the diagnosis box in the engine bay to get the car to start.

I check the wiring on my car and it's fine. I chased all my solder points on the MS, more specifically the fuel pump mod and everything is good, no shorts.

My MS is not pushing out 12v to SPR4. Do I need to make a software change in Tunerstudio to make this work on SPR4?

ennjay is offline   Reply With Quote
Old 12-03-2015, 01:32 AM   #2
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

Did you wire 12v to the spr4 internal connection?
aidandj is offline   Reply With Quote
Old 12-03-2015, 02:01 AM   #3
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2013
Posts: 79
Total Cats: -8
Default

I used the following circuit.
Attached Thumbnails
MS2 1.6 Fuel Pump Mod on SPR4?-attachment.jpg  
ennjay is offline   Reply With Quote
Old 12-03-2015, 02:06 AM   #4
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

What's wrong with just jumping the wires?
aidandj is offline   Reply With Quote
Old 12-03-2015, 02:08 AM   #5
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2013
Posts: 79
Total Cats: -8
Default

What do you mean? Can you clarify?
ennjay is offline   Reply With Quote
Old 12-03-2015, 09:42 AM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

Most of us use the normal fuel pump circuit and send it out to the AFM.

in the AFM connector, you jump that pin to the pin that connects back to the fuel pump relay.


then MS controls the pump like normal without a sketchy circuit you had to build.



This sounds like it's never worked? you probably built the circuit wrong or did something n00bish.
Braineack is offline   Reply With Quote
Old 12-03-2015, 06:52 PM   #7
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2013
Posts: 79
Total Cats: -8
Default

@ braineak Noob is right on. It never worked, yet. Funny you say sketchy circuit, I followed your write up:
https://www.miataturbo.net/useful-sa...76/#post169701

So, it sounds like I should do away with this circuit and utilize the existing GND output in the MS to drive the pump through the AFM now.

Can you clarify? I appreciate any feedback. Really I do...
ennjay is offline   Reply With Quote
Old 12-03-2015, 07:39 PM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

jump this




like so:



put normal purple wire fuel pump output (pin 37) on 2O.
Attached Thumbnails
MS2 1.6 Fuel Pump Mod on SPR4?-91178d1381422159-fuel-pump-wiring-1600-eunos-1990-afm_fuel_jump.jpg   MS2 1.6 Fuel Pump Mod on SPR4?-20150531_170832_zpsmnteavvy.jpg  
Braineack is offline   Reply With Quote
Old 12-06-2015, 06:07 PM   #9
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2013
Posts: 79
Total Cats: -8
Default

Thank you Braineak, that helped. Your suggestion was so much easier than building that circuit. I was able to get the fuel pump to turn on as expect. =)
ennjay is offline   Reply With Quote
Old 12-06-2015, 06:36 PM   #10
Sadfab Union President
iTrader: (3)
 
Join Date: May 2014
Location: Kansas
Posts: 2,690
Total Cats: 113
Default

Pull ST_SIG fuse, first. otherwise the transistor go boom.
deezums is offline   Reply With Quote
Old 12-07-2015, 08:05 AM   #11
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

Quote:
Originally Posted by deezums View Post
Pull ST_SIG fuse, first. otherwise the transistor go boom.
what transistor? here's not using one now.

one does not need to pull ST_SIGN fuse if you do build the unit like I do.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
BP-Z3 engine with VICS elektron Engine Performance 17 12-09-2015 09:18 AM
Fuel pump shuts off at low RPM ryansmoneypit MEGAsquirt 23 12-08-2015 10:29 AM
TunerStudio CAN exchange log? russian MEGAsquirt 13 12-05-2015 06:37 PM
Engine additive -- "Xtreme Green" turbofan Insert BS here 22 12-02-2015 09:57 PM
1997 1.8 - Trying to reinstall fuel hoses Based General Miata Chat 0 11-26-2015 08:02 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:15 AM.