MS2 with CAN bus problems - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 05-13-2013, 06:35 PM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2006
Location: Zilina,Slovakia
Posts: 79
Total Cats: 0
Default MS2 with CAN bus problems

I installed MS2 from Reverant to my FFS mp62 supercharged miata (305cc inj.) 1 year ago. Idle was a big problem, rpm gauge didnt run sometimes and then my ignition coils failed (only 55.000km on car).
So, then Reverant sent me new MS2 with CAN bus ecu, idle was much more better but it isnt still smooth like with stock ecu. After few months and about 1500km another problems with new coils begin (1st and 4th cylinders are without spark sometimes, also when I exchanged coils each other). Today in the evening dashboard started to light very shine,and airbag dashboard light also shine,so I immediatelly check digital voltmeter in glovebox - 18.9V,and I stopped the engine. After another start it run 14V few seconds, but when I rev the engine to about 2.000 rpm, it began to charge 19V again, so I stopped the engine and keep the car on the street.

I havent got complete schematic of Reverant Ecu and harness, alternator regulator is included in the ecu I think.
Any help with similar issue?

Last edited by elektron; 05-14-2013 at 06:44 PM.
elektron is offline   Reply With Quote
Old 05-14-2013, 02:14 PM   #2
Junior Member
iTrader: (5)
 
Join Date: Mar 2012
Location: Gilbert, Az
Posts: 337
Total Cats: 26
Default

What year is your car?
SJP0tato is offline   Reply With Quote
Old 05-14-2013, 02:21 PM   #3
Junior Member
Thread Starter
 
Join Date: Oct 2006
Location: Zilina,Slovakia
Posts: 79
Total Cats: 0
Default

Sorry I forgot, it is NB 2000,european version.
elektron is offline   Reply With Quote
Old 05-14-2013, 02:23 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

alternator charging circuit is fubar.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:40 AM.