MS2 Extra AFR very rich - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 04-09-2013, 07:07 AM   #1
Newb
Thread Starter
 
Join Date: Jan 2011
Location: New Zealand
Posts: 23
Total Cats: 0
Default MS2 Extra AFR very rich

MS2 Extra on a 99 with FM turbo kit, 550cc, MTX-l wb. Car has been running good for a couple days with good/normal AFRs. Car starts well hot or cold idle is set at 950-1000 oscillates a bit but not really bad. The last couple days its running unusually rich AFRs from idle and also when driving. Iv tried changing the VE idle cells which seem to change the mixtures a bit but after a while it goes back to 10:1 sometimes down to 9s. Tried changing the settings on the MAT correction table, warm up enrichment, tried disabling EGO control. nothing seem to make any difference. first start usually @12-13 but after a minute or two its back to 10s. Iv reloaded the map reverent supplied without changing anything but its still the same. Even with the very rich afr the car still starts well hot or cold, idles ok just eye watering rich and very bad mileage. Heres the msq and a log (logged with no boost and low rpm)

Attachment 72951

Attachment 72952

Last edited by ccsfd; 04-18-2013 at 06:22 AM.
ccsfd is offline   Reply With Quote
Old 04-09-2013, 07:20 AM   #2
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 197
Default

Do you happen to have any datalogs from when the car was running well?
Reverant is offline   Reply With Quote
Old 04-09-2013, 07:46 AM   #3
Newb
Thread Starter
 
Join Date: Jan 2011
Location: New Zealand
Posts: 23
Total Cats: 0
Default

heres one ..as you can see the afrs are ok
Attachment 72953

this has different timing map and some minor differences to your original loaded map..but even loading this one now wont make any difference with the afrs. its like the ms doesnt respond to any fuel setting changes even though the settings are burned into it

Last edited by ccsfd; 04-18-2013 at 06:22 AM.
ccsfd is offline   Reply With Quote
Old 04-09-2013, 08:04 AM   #4
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 197
Default

Interesting. Your pulsewidths are still the same.

What injectors are you running?
Reverant is offline   Reply With Quote
Old 04-09-2013, 08:09 AM   #5
Newb
Thread Starter
 
Join Date: Jan 2011
Location: New Zealand
Posts: 23
Total Cats: 0
Default

looking at the two logs which basically has the same settings theres a big diffrence in the afrs..the second log is car just idling also the last bit of the first log car is also just idling but its 13-14:1 compared to 10:1.
also on the first log the afrs are all over the place for such a small range in the map no boost/low rpm
ccsfd is offline   Reply With Quote
Old 04-09-2013, 08:12 AM   #6
Newb
Thread Starter
 
Join Date: Jan 2011
Location: New Zealand
Posts: 23
Total Cats: 0
Default

RX7 550cc high impedance injectors
ccsfd is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
K&N Intake Filter nbdooey Miata parts for sale/trade 0 09-28-2015 09:46 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:31 PM.